FORUMS
Remove All Ads from XDA

[13FEB2012][FIXED!!!] - No Sound with BT/ Voice Commands (Read First Post)

2,022 posts
Thanks Meter: 1,539
 
By ph03n!x, Senior Member on 21st August 2011, 03:14 AM
Post Reply Email Thread
Anyone seeing this for the first time, please take your time to read at least the first post to ensure you know what your are getting into
The attachments at the bottom of this post are NOT THE MOST UPDATED. Read the updated info below.


Update: 20th FEB 2012
The No Sound Bug, which kills all sounds in the phone when BT is used over a period of time without reboot or instantly if BT Voice Commands are issued, has been fixed effectively.


HUGE Thanks to the Cyanogenmod team for fixing this pesky bug.

The following kernels currently have the fix (with Test Status):

AOSP/ CM/ MIUI KernelsSense Kernels
Note: fhasovic's Fikret AOSP/ CM/ MIUI kernel also has the fix implemented, but did not pass the tests (my test | @karapialis' test). But fhasovic has promised to look into it - hopefully there will be a fix in the next version of fikret kernel (Please follow the changelogs in his kernel thread)

Credits:

Whew! This is going to be difficult. Let me try - if I miss someone, please PM me!!!
FIXED!!!

After exactly 6 months of opening this thread, we have squashed this pesky bug!!!

How do I get this fix?
By using one of the kernels listed/ ROMs with one of these kernels - Note that this list will not be the most updated source for kernels. The kernel changelog will the best place to look!

Does this fix all sound issues?
I Dont Know! Apart from the BT issue, which is kernel related, there are also issues with VoIP calls through viber/ skype that I did not test. These issues in all likelihood are related to the libaudio.so. Most ROMs comes with the iamgpc 2.8E version of libaudio.so - I suggest you try the drizztje v5 version too, just to see if it fixes your issue. If it does, please report back - we may have to start another thread to fix the libaudio.so

What libaudio.so do I have in my phone?
Use the CRC32/ MD5 Hash given below to find out:
History:
Update: 18th FEB 2012.
Test Reports
fhasovic's Fikret 2.16 - This kernel has the fix, but unfortunately failed in my tests for the No Sound bug.
Warrenb213's ACAKernelImplement020812a - This kernel behaved perfectly, and passed the test.
marc1706's Sense kernel v0.1.8 - This kernel also behaved perfectly, and passed the test.

Current status: Fixed, pending validation of fhasovic's fikret kernel that also incorporates the fix.
It feels so good to think the purpose of this thread is achieved, and if someone can validate Fikret kernel, I can take a break

Update: 12th FEB 2012.
@marc1706 seems to have found the root cause that kills audio when we use BT Voice Commands. Please Read this post and help with testing.

Update: 18th Nov 2011.
What we fixed by removing two way call recording is the sound crashing/ dialer freeze either over a period of time if you use BT for calls/ listening to music, or instantly if you issue a few BT Voice Commands. That does not occur anymore indeed.

I still am getting No Sound once in a while at various times - after a VoIP or normal calls, after disconnecting from BT, etc.

There indeed is something that is left to be fixed - more so because a few users have posted experiences of losing sound in Viber or Skype too, if they turn on the speakerphone. While I am not testing too much lately, partly because it is not as annoying (for me!) as with the BT/ Voice Commands issue, because stuff at work and personal life is giving me a lot less time, and because I am hoping the 2.6.35 kernel will help us.

I will update the thread as and when I stumble upon something. And I request all testers and enthusiasts to do the same, and hope that this stuff goes away once and for all.

On a related note - someone I know with a Galaxy SII has the dialer freeze issue at times too. But for him, after the FC things go back to normal - he still has sound...

Update: 3rd Oct 2011.
As of today, we have fixed the no Sound bug with varying results. Further progress can be followed in Tytung's Kernel Thread (Changelog). I will take a break from updating this thread until we discover something new/ radical (like making call recording work without killing sound!!). Hearty thanks to @drizztje, @Tytung, @themadproducer, @dannybiker, and everyone who tested/ participated in discussions on this mean issue

Update: 28th Sep 2011

The issue is fixed!!! I used the phone for couple of hours, used BT Voice Commands 25 times, played audio, used BT calls, used VoIP, and ya, I danced like I am a kid!!!

The fix is posted by @Tytung in this post (Kernel R12.2) and in this post (Kernel 12.3). I'm EXTREMELY GRATEFUL to Tytung and drizztje (who pointed at the cause in this post, and gave us the most updated libaudio.so v5 that works practically for all our purposes)!!!

(Deleted content to make space for the fix - see this post)

Quote:

UPDATE (27 Sep 2011)
@drizztje has updated the libaudio.so to v5 (CRC32: AB011130 | MD5:957f15c6c47a29c198cd868ccb5b4c2f), available in this post. Extract the libaudio.so in your computer and push it using ADB to /system/lib on your phone. If you use Root Explorer, do not forget to set permissions - they should read rw-r--r--!

Don't forget to post back your experience/ feedback.

UPDATE (26 Sep 2011)
@drizztje has been kind enough to spend some time on this issue, and has given us a new version of libaudio.so (CRC32: 19BF49C6) to test. Please download the attachment from this post, extract the libaudio.so in your computer and push it using ADB to /system/lib on your phone. Don't forget to post back your experience/ feedback.

UPDATE (16 Sep 2011)

Quote:
Originally Posted by ph03n!x

iamgpc has updated his ROM to v2.8E - the kernel is updated to #294, and the libaudio.so seems to be different too (CRC32:F5942882).

I am attaching the libaudio.rar (to be extracted and pushed to /system/lib using ADB/ QtADB), as well as the full kernel package to flash through CWM for Magldr and cLK for anyone who wants to try.

I have flashed the cLK package - the kernel, modules & wpa supplicant, and libaudio.so to my phone (just rebooting), and will give my experience on how it goes over the next day or two.

Link 1 - @iamgpc cLK kernel package #294 for CWM
Link 2 - @iamgpc Magldr kernel package #294 for CWM (Updated, thanks to Xylograph for adding RMNET module!)
Link 3 - @iamgpc libaudio.so from his AOSP ROM v2.8E. This is a RAR file, extract and push the libaudio.so file to /system/lib using ADB (or use QtADB).

@iamgpc - If you do not want me to post your kernel links here, please let me know in the thread or through a PM and I will take them down!
Thanks a lot for all the work you have put in for the HD2!

Known Issues: Read the updated for Sep 14th below. I have not verified if the same issues exist in this version too or not.

UPDATE (14 Sep 2011)

I started off trying different kernel / libaudio.so/ htcleo.acdb/ default.acdb combinations, and here are a few experiences:

1. Revised @iamgpc libaudio.so from this post
@TheMadProducer's experience on BT VOice Commands with Tytung r12b1
My Feedback with Tytng R11 Final - Post 1 | Post 2

2. drizztje's v2 libaudio.so with Tytung R12 (mic gain fix)
Slows down the phone - @memin1857's post | My Post | @TheMadProducer's post

3. Tytung R10 with drizztje's libaudio.so v2 and Letama's htcleo.acdb
This was pretty stable, lasted about 24 hours of VoIP, BT (not commands, just calls) and GPS usage, but dies with the infamous BUZZ of Sound Death when I got a call ~24 hours since reboot (My Post 1 and Post 2)

4. The twist in the tale - new libaudio.so from iamgpc's ROM v2.8D
I stumbled upon the update in @iamgps's ROM thread that he has been updating his AOSP ROM and downloaded the latest version (2.8D).
Like I thought, it had an updated libaudio.so (confirmed by Tytung)
I extracted the following files from @iamgpc's ROM and flashed it in my CM7 nightly-
  • kernel and initrd.gz - this seems to have a similar feature set as Tytung R12 (Mic gain fix, RNDIS/ USB Tethering, Wake-up lag fix, 00:23:76 MAC address for WiFi.... (Check @iamgpc forum thread in mobile01.com for the complete changelog)
  • /system/bin/wpa_supplicant
  • /system/lib/libaudio.so (CRC32 - 85BCF15E) - This seems to be an improved version, VoIP, mic gain, BT calling (not voice commands ) seem to work fine
  • /system/modules/*
I also renamed the standard default.acdb as htcleo.acdb. Without htcleo.acdb, the ROM is looping into a hot reboot on startup.

Known issues-
  • This did not affect my experience or functionality, but when I turn on BT logcat spits this:
    Quote:

    get_adapter_path: D-Bus error: org.freedesktop.DBus.Error.ServiceUnknown (The name org.bluez was not provided by any .service files)

    I have no clue what this is, but it stops after coming up a bunch of times and everything works.
  • If you delete htcleo.acdb, the ROM gets into a hot reboot loop on the next reboot. I have copied the default.acdb as htcleo.acdb to ensure mic gain fix works fine. I have also adjusted the values in 10mic_level to what worked the best for me. Use the HD2 Mic Control app from the market to change this easily. Read more on this in the Mic Gain fix thread.
  • You will have to re-do your BT pairings.
  • I have not tried Voix to see if call recording works - please try and report back.

I am attaching the CWM flash packages in this post, as well as the libaudio.so alone for anyone to try this. Also, if someone can try the libaudio.so in Tytung R12, it will be great if you give your feedback! I am not sure how this will affect Sense ROMS - use carefully!

Note: I backed up my current ROM in CWM, wiped my cache and dalvik before flashing this and rebooting. If you flashed this, and want to go back, restore /boot and /system from Advanced restore in CWM. If you did not backup, just flash your ROM's .zip in CWM without wiping data.

***Links Updated to Sep 16 Downloads***
Link 1 - @iamgpc cLK kernel package #294 for CWM
Link 2 - @iamgpc Magldr kernel package #294 for CWM
Link 3 - @iamgpc libaudio.so from his AOSP ROM v2.8E. This is a RAR file, extract and push the libaudio.so file to /system/lib using ADB (or use QtADB)

@iamgpc - If you do not want me to post your kernel links here, please let me know in the thread or through a PM and I will take them down!
Thanks a lot for all the work you have put in for the HD2!

Archives of the old post follows...

@iamgpc and TYTung have given us an updated version of the original iamgpc with wonk fix, which includes drizztje's fix too. This can be found in this post.

What works with this version:
1. Volume fix (the handset volume level set by the user is adhered to)
2. Wonk fix (No robot voice)

What works but has problems:
1. VoIP fix (drizztje's fix) - VoIP works fine, but you end up having 60mA drain and losing all sounds. A reboot fixes it.
2. BT usage - Moderate BT usage for calls and audio works, but this tends to slow down dialer over time and eventually crashes it. A reboot is needed to get the phone back up.

What does not work:
1. BT voice commands slows dowm/ FC's the dialer after the 4th or 5th time you use it. This also leads to no signal and no sound. A few reboots is needed to get back to normal.
2. Not compatible with TYTung r12b1, as drizztje's VoIP fix breaks compatibility with mic gain fix

Whenever you are rebooting, make sure you have VoIP turned off, and BT disabled!

From my experience, this version works best with TYTung r11 Final kernel. It seems to have troubles with TYTung r12b1, which includes the mic gain fix - the dialer gets slowed down/ may result in a FC or no sound. (Thanks to memin1857 and clyder for testing and confirming)

To try this version:
1. Make sure you do not have the r12b1 kernel (Settings > About Phone > Kernel version). If you do, you can use r11 from here - flash it through clockworkmod. I have not tried this with r10 or below, if you are still on one of the older versions, please test and report
2. Download the libaudio.so zip from this post and flash it using clockworkmod.
3. Reboot and use your phone.

Known issues:
1. Voix seem to not record outgoing calls. Incoming calls record fine though. I recommend you to disable call recording when testing this fix
2. Tell us!

To uninstall this fix, extract the libaudio.so from your ROM's zip file (/system/lib/libaudio.so), and push it using ADB to the phone's /system/lib and reboot. If you are not comfortable with ADB command lines, use QtADB.

Bug reporting: Please include the following when you report issues after flashing the libaudio.so from this post.
Code:
ROM:
Kernel:
Is htcleo.acdb present in /system/etc/firmware?
If htcleo.acdb is present, what is its size?
Description of issue:
Original Post follows...
There was a string of discussion on libaudio.so in tyween's TyphooN thread. I am creating this thread to post @themadproducer's summarization, as well as my experience, hoping a Dev would be able to help us out.

This is probably the only problem with AOSP Android/ GB in Leo that p*sses me off so much because it impairs functionality, and any help is greatly appreciated...

@TheMadProducer's summarization post:

My experience:

I have a BT stereo headset, and my car's audio headunit supports BT as well. I regularly (almost everyday) connect my phone to either of these two BT devices for playing music as well as taking/ making calls. So far so good.

Now, after using BT for a while (playing music, talking on the phone), or after I have disconnected from it, I can certainly say that if I make a call, I will be able to listen to the other person clearly, by they will not hear me at all. The symptom is that when making a call, I will not hear the other party's phone ring but they will pick up the call after a long stretch of silence (where I should actually be hearing the phone ring). Even when they are not able to hear me, if I turn on the speaker phone, we can have a decent conversation and hang up.

But when none can hear me when I call them while having this issue, if I receive a call, everything is fine. I also doubt that I maybe having a higher battery drain (~60mA) in standby, but I have not confirmed it.

I have tried 4 versions of libaudio.so
- the originaliamgpc version (CRC32: 1EB93DC2 | MD5: 1f182b9593232d47265bcc7c39f941be)
- the iamgpc version with wonk audio fix (CRC32: 41A370AD | MD5: ab8f4f8b50c20e1e26d62bd992f4178d)
- drizztje v2 of libaudio.so (CRC32: 098A3A03 | MD5: 11b4b54be602cd7f07210a7f5e63af28)
- drizztje v3 of libaudio.so (CRC32: 34518C00 | MD5: 5549401447d07a2cbaf1b85f6502f1fc)

All of these show varying degrees of tolerance, but the issue shows up eventually. I have seen this in CM7 based ROMs as well as Tytung's AOSP ROM. Not sure if they come in Sense ROMs, been a while since I tried a Sense build.

If I reboot the phone, the problem goes away. If I do not use BT at all, the phone *mostly* stays fine (at least until I reboot it for a new ROM or something), but I have faced this problem even without BT a couple of times.

Can anyone with Dev skills take a good shot at it and fix this for us? I am sure the entire community will be grateful if we see a fix the libaudio problem!

NOTE: I am posting this in the DEV section to discuss this issue in its own thread, and as it required a Dev's intervention for sure, to hopefully get a solution.

The Following 27 Users Say Thank You to ph03n!x For This Useful Post: [ View ] Gift ph03n!x Ad-Free
 
 
21st August 2011, 03:26 AM |#2  
YZ's Avatar
Retired Forum Moderator
Thanks Meter: 3,459
 
More
Great thread.
21st August 2011, 03:40 AM |#3  
Senior Member
Flag Desert Rat
Thanks Meter: 223
 
More
Hope some devs will look into this.

Thanks for the post.
21st August 2011, 04:46 AM |#4  
s_superman's Avatar
Senior Member
Flag Cairo
Thanks Meter: 121
 
More
I was just thinking about writing a thread about this
but didnt know how
nice thread man

the most bugging issue for me is the robo voice issue and then no voice and hanging phone app
on all cm7 builds
happenes to me a lot when I have haptic feed back enabled
and almost every call when audible touch tones enabled

I really wish for a fixed libaudio.so
21st August 2011, 04:10 PM |#5  
ph03n!x's Avatar
OP Senior Member
Flag Madras
Thanks Meter: 1,539
 
More
It has been a while since I tried a non-CM7 ROM, going to try a few Sense, and maybe some MIUI to see how it is. I am frustrated enough to get back ton WinMo on this one, and maybe get a native device You'll never know if the other person can hear you when you call someone! But the silver lining is if I receive a call, all seems fine.

EDIT:
Content removed from first post:
Quote:

Before you jump in joy (like I am still doing) and install the fix, read this:
  1. The fix is the Tytung R12.2/ R12.3 Kernels
    (Download Link for R12.2 - Magldr | cLK | Post)
    (Download Link for R12.3 - Magldr | cLK | Post)
    Tytung R12.2 has the following changes from the standard Tytung R12 Kernel:
    • based on R12
    • reverted "bluetooth stack"
    • disabled "call recording" in kernel config
    • included libaudio_v5-drizztje
    Tytung R12.3 has the following changes from the standard Tytung R12 Kernel:
    • based on R12
    • reverted "bluetooth stack" Uses the latest BT Stack
    • disabled "call recording" in kernel config
    • included libaudio_v5-drizztje
  2. If you are using a call recording app, remove it (at least disable it),else BT Voice Command will behave erratically,leading to FC of the dialer and losing audio - remember, the kernel has 2 Way Call Recording support disabled.
  3. If you use CSipSimple for VoIP, disable BT before making calls. If not, call audio will not be available on the phone, speaker-phone or on the BT Handsfree. I did not observe any other adverse effect like slow down or losing audio, disabling BT and VoIP Calling again works just fine. Note that @drizztje has confirmed that the built-in VoIP feature of gingerbread works just fine over BT in this post. Anyone with other VoIP Apps like SipDroid, please post your experience.
  4. Finally, don't forget to thank Tytung (post) and drizztje (post). Do donate to them as a token of your appreciation for their contributions - they have made our beloved HD2 even better!!!
I think it is only proper to quote @drizztje's post here:
Quote:
Originally Posted by drizztje

About donation offers, I worked on this because I was sick of getting missed calls after bt usage, and because I wanted some distraction from all the frustrations at work and trying to move from one country to another. So, if you want to donate, do it to a charity for Somalia and/or to the guys that made android run on hd2 and/or to kernel maintainers and/or to cyanogenmod team... For me, well, just wish me luck for the moving.

Using kernel Tytung R12.2/ R12.3 on CM7/ MIUI based ROMs

A. Why does it not work in CM7/ MIUI?
Quite a few of you have reported that you are getting bootloops/ stuck at boot animation on CM7/ MIUI ROMs. This is because the initrd.gz, which gets flashed along with the kernel in the /boot partition, has to be modified for the recent versions of these ROMs (IIRC versions released in September) from the standard AOSP version.

B. How do I use it then?
If you are on Magldr, all you have to do is open the CWM package for Magldr in WinRAR, head to the folder named boot, delete the file named initrd.gz, and flash it on your ROM. This way, you will not overwrite your existing initrd.gz that would have been modified to meet the new requirements. Or, you can download this modified version of Tytung R12.2 and flash it (I have not uploaded a modified Magldr version for 12.3 - do you want me to??)

If you are on cLK, There are two ways of doing this. If you have Android up and running on your phone, follow the "Installation of other ROMs" part in Tytung's kernel thread.

If you do not have Anrdoid running, or if you want to incorporate it into your ROM CWM (or a standalone CWM) before flashing, follow this.
  1. Have Linux (I am not sure if this can be done in Windows)
  2. Download the Magldr version of your ROM, Tytung R12.2 or Tytung R12.3 (choose one!) Magldr version and the cLK version
  3. From your ROM's ZIP file, extract the initrd.gz file from the folder named boot
  4. From the /boot folder of Tytung R12.2 or the R12.3 Magldr version, extract file named zImage
  5. With mkbootimg binary, the initrd.gz file and the zImage file in the same folder, use the following command
    Code:
    mkbootimg --kernel zImage --ramdisk initrd.gz --cmdline "console=null" --base 0x11800000 -o boot.img
    This will create a boot.img in the same folder
  6. Open the Tytung R12.2 or Tytung R12.3 cLK CWM ZIP file, replace the boot.img in the ZIP with the one you created. Flash and enjoy the fix
If you find the steps for cLK something you don't want to do/ can't do, seek help in your ROM thread- am sure your ROM Chef or someone else will help you.

C. I flashed Tytung's version of the kernel R12.2 or R12.3 in my CM7/ MIUI ROM and now it boot loops/ stuck at boot animation. Help!
Don't panic! Just flash back your ROM's CWM ZIP without wiping data, cache or dalvik-cache, and you should be fine.

Note:
The Tytung R12.2 and R12.3 kernel package that fixes the "no sound bug" has a 10mic_level file included that will go to /system/etc/init.d folder. This will overwrite your current Mic gain settings with a value of 400 for handset and 600 for speaker phone.

To retain your existing mic gain settings, you can either open the Tytung R12.2 or 12.3 kernel CWM ZIP in WinRAR and delete the 10mic_level file from system/etc/init.d, or use the HD2 Mic Control app from the market to set your desired mic level after flashing.

If you experience echo, try reducing it down a notch or two - high handset/ speakerphone volume is also known to cause echo. You can read-up more on @memin1857's thread.

cLK CWM ZIP packages for custom CM7 Builds

As explained above, the Tytung R12.2 and 12.3 kernel needs to be flashed with your ROM's initrd.gz for MIUI and CM7 ROMs. This is easily done for Magldr, but not so for cLK. I will post the links for various ROMs' cLK image for Tytung R12.2 as and when someone posts it in this thread or informs me.

21st August 2011, 06:18 PM |#6  
Senior Member
Flag Brussels
Thanks Meter: 355
 
More
Wow thanks ph03n!x, I should have done that earlier but I just don't have the time.

Yes I can confirm that the "shhh" is gone with drizztje libaudio. Well at least, I didn't got it so far. Also, it seems that the no sounds bug takes way more time to appear. I thought it was gone actually until I almost didn't wake up one day because my alarm didn't ring, only vibrated, after 3 days of uptime. In the past, it only took several hours for the bug to appear.

Here's the common log for that bug :

Code:
04-27 10:15:10.301   132 21896 E QCvdec  : adsp: cannot open cpu_dma_latency, fd: 15 (Permission denied)
04-27 10:15:12.051 18373 18373 E libBlurEffect: AndroidBitmap_getInfo() failed ! error=-1
04-27 10:15:26.470   498   525 E lights  : gpc: power status changed, i have to show power information first
04-27 10:15:51.321   498   941 E Tethering: attempting to remove unknown iface (eth0), ignoring
04-27 10:17:00.240   132   181 E AudioHardwareQSD: Cannot start voice
04-27 10:17:14.140   498   932 E lights  : gpc: manual set BL value=0 (Mode=1)
04-27 10:17:14.880   498   932 E lights  : gpc: manual set BL value=250 (Mode=1)
04-27 10:17:14.880   498   932 E lights  : gpc: value=55 (Mode=1)
04-27 10:17:41.752 18373 18373 E libBlurEffect: AndroidBitmap_getInfo() failed ! error=-1
04-27 10:17:48.172   498   932 E lights  : gpc: value=70 (Mode=1)
04-27 10:17:51.172   498   932 E lights  : gpc: value=250 (Mode=1)
04-27 10:17:51.492 18373 18373 E libBlurEffect: AndroidBitmap_getInfo() failed ! error=-1
04-27 10:18:18.952   132   181 E AudioHardwareQSD: Cannot start pcm playback on AUDIO_START
04-27 10:18:23.962   132   181 E AudioHardwareQSD: Cannot start pcm playback on AUDIO_START
04-27 10:18:28.982   132   181 E AudioHardwareQSD: Cannot start pcm playback on AUDIO_START
04-27 10:19:13.182 18373 18373 E libBlurEffect: AndroidBitmap_getInfo() failed ! error=-1
04-27 10:19:20.302   132   181 E AudioHardwareQSD: Cannot start pcm playback on AUDIO_START
04-27 10:19:23.602 18373 18373 E libBlurEffect: AndroidBitmap_getInfo() failed ! error=-1
04-27 10:19:25.322   132   181 E AudioHardwareQSD: Cannot start pcm playback on AUDIO_START
04-27 10:19:28.592 18373 18373 E libBlurEffect: AndroidBitmap_getInfo() failed ! error=-1
04-27 10:19:30.342   132   181 E AudioHardwareQSD: Cannot start pcm playback on AUDIO_START
04-27 10:19:35.362   132   181 E AudioHardwareQSD: Cannot start pcm playback on AUDIO_START
04-27 10:19:36.922   132   181 E AudioHardwareQSD: Cannot start voice
04-27 10:19:57.112 21968 22168 E ToneGenerator: --- Stop timed out
04-27 10:19:58.712   132   181 E AudioHardwareQSD: Cannot start pcm playback on AUDIO_START
When that happens, the phone doesn't make any sound at all : ringtones, music, notifcations, etc. Only solution is a reboot.
I can't be 100 % positive but I'm fairly sure it doesn't happen with MIUI. Also, note that I NEVER use bluetooth. So Bluetooth might be a parameter but not the cause.

I'll report back with more info when I can...
21st August 2011, 06:42 PM |#7  
Senior Member
Flag Brussels
Thanks Meter: 355
 
More
Also, it's hard to tell when it start happen. I didn't happen with MDJ's CM7 or Typhoon's prior to the 3.x versions. I did get it with a 2.9.x build but it starts not much before that...

Maybe dritzztje could post what he did exactly to the libaudio ?
21st August 2011, 10:48 PM |#8  
Senior Member
Flag Kozani
Thanks Meter: 325
 
More
with typhoon 3.5.8,miui v24 from langthang and dorimanx rom i am getting instead of no sound bug the bzzzzzz bug.until now i was using with many roms drizzte v2 libaudio and never experienced this bug.it doesnt happen everytime but sometimes if someone calls me,when i answer i hear from speaker a continuous bzzzzzz sound and of course i cant speak.if i make reboot this issue is solved until the next random moment it will happen.the other sounds on phone are not affected.
unfortunatelly i cant re-produce it so i havent logcat.
22nd August 2011, 11:51 AM |#9  
ayyu3m's Avatar
Senior Member
Flag System Error
Thanks Meter: 271
 
More
Man i hope this problem gets f**king fixed. Hehehe.

Just hyped up. Please dont ban me for the bad example of words to noobies

and ph03n!x, i wud ***king kick your a$$ were you in Bangalore, cos for a moment i was like

"so thats why i keep gettin FC in Angry Birds" until your sense of humor kicked in.
22nd August 2011, 02:30 PM |#10  
Senior Member
Thanks Meter: 16
 
More
Thank gods for this!

Can a mod sticky this mofo to the top of this forum as the way I see it this is the last fecker to get resolved with the HD2 and NANDriod!

I see the bluetooth issue all the time where once I have hooked it up to the car and used it a couple of times, after disconnecting and trying to call someone, I can't actually chat to someone Most annoying!
22nd August 2011, 06:55 PM |#11  
ph03n!x's Avatar
OP Senior Member
Flag Madras
Thanks Meter: 1,539
 
More
I'm wary of saying this (least I jinx it), but my phone has not acted up for 34 hours now. This is about the longest I have run *AFTER* using Bluetooth Headset, GPS, SIP and the usual stuff. To put this in perspective, I usually have to reboot once or twice a day owing to libaudio.so

I am using drizztje's v2 of libaudio.so and the stock CM7 nightly htcleo.acdb - I had been using Letama's htcleo.acdb until now (attaching both - just in case). This is the last pair of changes I made to my phone - and it seems to work so far. Even if it works for 24 hours like this, I wouldn't mind and reboot every morning or so!

Am attaching what I am using if you want to give it a try - note that I have not modified the libaudio.so or the htcleo.acdb from drizztje's version or stock CM7 nightly version.

Note that am using a custom build of CM7 nightly (16th Aug) in cLK with Tytung's R11b2 (with init.gz and .ko modules from it), RPC version of GPS Libraries, libhtc_ril_wrapper version 0.8b5, and all wifi/ BT related files as well as libhtc_ril.so from Tytung's NexusHD2 v2.9. The radio I use is 2.15.50.14 right now, but I also try 2.12.50.02_2 at times (my sign will say what I am on)...
Attached Files
File Type: rar libaudio_htcleo.rar - [Click for QR Code] (26.4 KB, 61 views)
The Following 2 Users Say Thank You to ph03n!x For This Useful Post: [ View ] Gift ph03n!x Ad-Free
Post Reply Subscribe to Thread

Tags
bluetooth, drizztje, iamgpc, libaudio.so

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes