FORUMS

The HP Touchpad Demo Unit Solution - Bypass Activation

10 posts
Thanks Meter: 4
 
By bluepoint951, Junior Member on 22nd August 2011, 05:38 AM
Post Reply Email Thread
As of 1425 CDT on 22-Aug 2011 it appears HP has unlocked the DEMO units; you may not need the steps below. I'll leave them here for reference.

MOD EDIT (LP): If required, please read "[GUIDE] Turning a Demo unit into a fully functional Retail Unit" posted by mplacido9 for more detailed instructions. Give him your Thanks (by hitting the Thanks button) if you find his in-depth guide useful.

Solution with the help of other posts [special thanks to user chekz here on precentral.net and & webOS roundup] This set of instructions will take your DEMO unit 32GB HP TouchPad and place it into Dev mode [and help you update to webOS 3.0.2 if you haven't already done so].

Just an FYI, the error that you receive after you flash to regular webOS 3.0.0 or 3.0.2 and can't move forward in registration is: PalmS3036 which is listed as "Device is Locked from doing FirstUse". This leads me to believe, like others, that it is merely a software reason and not a hardware one as to why we cannot use these like regular units.

This does remove the DEMO software, allows you to update to webOS 3.0.2, and keeps you from getting stuck on trying to register; however, It is untested on weather you can log into an existing webOS account. I am unable to create a webOS account as I don't own any other webOS devices and I do not know if this will impact your ability to register/unlock your DEMO unit in the future [if HP does so]. I would assume you should be able to use webOS Doctor once again to restore the unit as it was before this solution was developed.

Here is where i got the information:

Touchpad demo mode - (Page 5)

how can i flash stock rom? - (Page 3)

Activation-Bypass Tool - webOS Developer Center

====

You will need this file:
Right click and Save as: http://onebluepoint.net/chekz-devicetool.zip

or

FileServe Download (again thanks to chekz)


I. HP TouchPad Demo Unit Solution - Bypass Activation

Steps:

1. If you have not already, update to webOS 3.0.2

****a. To do this download this: http://palm.cdnetworks.net/rom/touch...2hstnhwifi.jar

****b. Run the aforementioned file by double clicking (You must have Java installed; I did this on Windows 7 Ultimate 64-bit)

****c. Continue the setup until you get to the step where you are asked to connect your device with a USB cable. (But, do not connect your TouchPad at this step)

****d. On you TouchPad shut down the tablet (you should be able to do this by holding the power option for a few seconds and selecting the "Shut Down" option ; if you can't get that to come up you can force a restart by holding the "Home" button and power button at the same time for apx 5-10sec)

****e. Restart/Start-up you device holding the Power button and the Volume Up button (This boots the device into Recovery Mode) You will know if you are successful if you see the USB logo on your screen.

****f. Connect your TouchPad to your computer; on screen you should be able to hit the next button to allow your device to be updated.

****g. Allow 10-15min for the application to finish; at the end it will tell you the device is resetting. You will see a small HP logo on your TouchPad, disconnect the USB from your computer.

****h. Once the upgrade is complete and has loaded you can attempt to login or create and account but if you have a demo unit; you won't be able to register. [aka ERROR CODE: PalmS3036]



2. Power down your TouchPad (see step 1d for help if needed)

3. Hold down the Power and Volume Up button to allow your device to boot into Recovery Mode. You should see a USB logo on screen. (see step 1e for help if needed)

4. On your desktop, unzip the chekz-devicetool.zip file. You might want to copy this un-zipped file to your C: drive to make the next step easier.

5. You will need to open a Command Prompt (for Vista and/or Win7 you might need to run as Admin by right clicking on the icon in your Start>Programs>Accessories folder)

6. Change to the directory where the unzipped file is located (i.e. C:\chekz-devicetool )

7. Connect your TouchPad to your Computer

8. In your Command Prompt type the following command: java -jar devicetool.jar

9: You should see the following (your device will restart a time or two):



10. Once you see the "Device is ready." You can Disconnect your TouchPad from your computer.

11. When you power on your TouchPad, you should go straight to the home screen; by bypassing the activation screen.

-----

I don't have a webOS Account to log into to see of existing users can log into their accounts. I was able to use the stock applications and login to the existing applications like Facebook. I did this about 30 minutes ago so, I am still playing around.


==============

Update from 22 - Aug 2011 @ 13:45 CDT

After completing yesterday's work; Today my goal was to get this thing fully working. I was able to create and log into a webOS Account ad even access the App Catalouge. Steps below.

II. Create/Log in to webOS profile for DEMO 32GB Touchpads

Information found:

Installing Preware with WebOS Quick Install

WebOS Quick Install v4.2.3

Impostah

Steps:

1. Download WebOS Quick Install (check the links above)

2. Open the afrorementioned downloaded file (i.e. WebOSQuickInstall-4.2.3.jar)

3. If your TouchPad is not connected, you will get a message that says "No Devices Found". Connect your TouchPad and hit OK.

3. Click the third button on the right (the globe icon)

4. Select the Applications tab at the top

5. Search for Preware

6. Click Install.

7. On you Touchpad, on the home screen hit the Launcher icon (on the bottom right, looks like an arrow) and go to the Downloads Tab

8. Touch/open the program Preware

9. In the top right corner, touch/open the Magnifying Glass and type in "Impostah". Click the one result that comes up.

10. At the bottom of the description page you should see a Install button; touch/click to install the program.

11. Once the download and install is complete, you should be able to launch the program. (If you are brought back to the Launcher, Impostah can be found in the Downloads tab)

12. Once Impostah is launched, select the Activation button.

13a. For Existing webOS Account holders You should be able to type in your email address and password and hit Login To Profile.

13b. For New Users, type in the email address you wish to associate your account with and the password you wish to use. Then hit the Create New Profile button. You should see message asking you to confirm that you wish to proceed. To continue simply hit the green "Create New Profile" button.

14. To verify that your TouchPad has your webOS Account associated with your device. Open the Launcher, go to the Settings Tab, then touch/open the "Device Info" icon. You should see the e-mail address you used to register/log-in to your account listed in the "HP webOS Account" field. If the "Name" field is blank, you will need to tap the blank area and enter your name.

15. You are done! Enjoy! You can now access the HP App catalog and other webOS features.

If you want to verify your account was created, you canlog-in to your webOS Account here: Manage my HP webOS Account

Thanks to everyone else here and they guys over at webOS roundup for some guidance.
The Following 2 Users Say Thank You to bluepoint951 For This Useful Post: [ View ] Gift bluepoint951 Ad-Free
22nd August 2011, 08:46 PM |#2  
OP Junior Member
Thanks Meter: 4
 
More
It looks like from what others have said that the DEMO's are now OK to register. You simply need to run webOS Doctor to get the latest build and you should be able to log-in and/or create a new account.
22nd August 2011, 09:25 PM |#3  
Member
Thanks Meter: 0
 
More
Can anyone confirm that they have been able to register their demo units?
22nd August 2011, 09:44 PM |#4  
OP Junior Member
Thanks Meter: 4
 
More
I re-flashed to the stock webOS 3.0.2

http://palm.cdnetworks.net/rom/touch...2hstnhwifi.jar

and was able to register a new account. I even was able to log into my existing account.
23rd August 2011, 12:28 AM |#5  
Junior Member
Thanks Meter: 0
 
More
Exclamation Upgrade to 3.0.2
Hi,

I'm currently doing the upgrade to the latest version on a demo unit 32GB Model and it has stayed stuck at 62% on step 1g for 25 minutes, and I'm starting to get nervous. I haven't touched the installation and on the tablet screen it still appears as if it's doing the upgrade, what options do I have?
23rd August 2011, 12:44 AM |#6  
Junior Member
Thanks Meter: 0
 
More
in the "just type" feature type

1. webos20090606
2. Hit the Developer Mode icon that appears.
3. That’s it, you’re ready to install anything on your TouchPad.
23rd August 2011, 12:47 AM |#7  
Junior Member
Thanks Meter: 0
 
More
@ King 003
Hi,

Thanks for your reply but in the current point in the installation i don't have a screen to type anything i'm strill trying to do the upgrade to web os 3.0.2 and it's stuck at 62%
23rd August 2011, 12:49 AM |#8  
Junior Member
Thanks Meter: 0
 
More
something happen to me, I just turned the touchpad off
23rd August 2011, 02:44 AM |#9  
Senior Member
Thanks Meter: 503
 
More
This worked like a charm, and the best part, once I ran WebOS Doctor, I didn't have to do anything else, I was able to create an account and now I'm enjoying a full webos experience!! Thanks XDA!
24th August 2011, 12:43 AM |#10  
Junior Member
Thanks Meter: 0
 
More
Help!
I am getting a error code of PAMS9999 "Generic Fault" when I try to register an existing account or set-up a new one on my touchpad. I have tried after the doctor, and followed the additional steps for the full hack, but I still am unable to set-up any webos accounts on the device.

Any suggestion??
24th August 2011, 01:43 AM |#11  
Junior Member
Thanks Meter: 0
 
More
i'm not able to create a new account... I use to have a palm pre and i can't login with that account either.

help...
Post Reply Subscribe to Thread

Tags
bypass activation, demo, palms3036, reset, touchpad

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes