FORUMS
Remove All Ads from XDA

Cannot find solution to connect to hidden 802.1x network :(

629 posts
Thanks Meter: 44
 
By mesnati, Senior Member on 22nd September 2011, 01:15 PM
Post Reply Email Thread
Hi!

I Cannot find solution to connect to company's hidden Wifi 802.1x network

I tried almost anything to make it work .... but without success
I have had various wpa_supplicant bin files.
I have edited 100x wpa_supplicant.conf file.
I was reading forums with "SOLVED" solutions ... for other phones ... but cannot find solution to work on Huawei IDEOS X5 U8800.
I also have tried it with various ROMs: MIUI 1.8.x and 1.9.x, VOID, B135, B136,B160, cm7-100911, Oxygen ...

But every time with no success ...

Hints:
a) All other colleagues connect without problem (they have HTCs, Samsung Galaxy S I,II, iPhones 3,4 ...) while my friend and i cannot connect

b) I connect to my home Wifi (WPA/PSK) without a problem!

Anyone have similar problem?
BTW: MY wpa_supplicant.conf file looks like:

ctrl_interface=wlan0
update_config=1

network={
ssid="mySSID"
scan_ssid=1
key_mgmt=IEEE8021X
group=WEP104 WEP40
auth_alg=OPEN SHARED
eap=PEAP
identity="[email protected]"
password="zzzzzz"
phase2="auth=MSCHAPV2"
}

Brgds,
S.

HELPPPPP
 
 
4th October 2011, 11:17 PM |#2  
Have had sporadic issues myself, and found that setting ap_scan=2 in /system/etc/wifi/wpa_supplicant.conf was helpful but not flawless. I reverted back to a CWM of MIUI 1.8.19 which I recalled seemed to connect without issues. On reviewing the wpa_supplicant.conf files in system and data, I noticed that the ctrl_interface was different.

ctrl_interface=DIR=/data/misc/wifi/wpa_supplicant GROUP=system

rather than ctrl_interface=wlan0

I haven't yet tried moving back to the latest version of MIUI to test these changes, but will do so when I get the time.

Modify below files and ensure permissions dont change
Both /data/misc/wifi/wpa_supplicant.conf
and /system/etc/wifi/wpa_supplicant.conf

also create a new folder wpa_supplicant in /data/misc/wifi/
mkdir /data/misc/wifi/wpa_supplicant -m 750
4th October 2011, 11:46 PM |#3  
Retired Recognized Developer
Flag Brisbane
Thanks Meter: 597
 
Donate to Me
More
Quote:
Originally Posted by haydnlj

Have had sporadic issues myself, and found that setting ap_scan=2 in /system/etc/wifi/wpa_supplicant.conf was helpful but not flawless. I reverted back to a CWM of MIUI 1.8.19 which I recalled seemed to connect without issues. On reviewing the wpa_supplicant.conf files in system and data, I noticed that the ctrl_interface was different.

ctrl_interface=DIR=/data/misc/wifi/wpa_supplicant GROUP=system

rather than ctrl_interface=wlan0

I haven't yet tried moving back to the latest version of MIUI to test these changes, but will do so when I get the time.

Modify below files and ensure permissions dont change
Both /data/misc/wifi/wpa_supplicant.conf
and /system/etc/wifi/wpa_supplicant.conf

also create a new folder wpa_supplicant in /data/misc/wifi/
mkdir /data/misc/wifi/wpa_supplicant -m 750

The control interface is changed so that it works with other versions of wpa_supplicant. If you change it to the way it was in the older Miui then wifi won't work at all.

If it never worked (even on stock) then the issue probably isn't with wpa supplicant, and could be a problem with the wifi driver, or the hardware itself. This really needs someone who knows what they're doing and access to a hidden 802.1x network to look into it.
5th October 2011, 02:00 AM |#4  
Quote:
Originally Posted by stockwell

If it never worked (even on stock) then the issue probably isn't with wpa supplicant, and could be a problem with the wifi driver, or the hardware itself.

Was there a driver change between 1.8.19 and later MIUI versions? The supplicant seems like the same version (v 0.6.10)?

On returning to 1.8.19 have had 3 days without issues. When on 1.9.30 the change to ap_scan=2 definitely improved and seemed to make a connection on reboot flawless, but reconnection from sleep was sporadic (probably <30%). Watching wpa_cli output when waking phone from screen off on 1.9.30 showed a failed connection attempt, and then a series of timed scans (CTRL-EVENT-SCAN-RESULTS) - these continued after CTRL-EVENT-CONNECTED (something that didn't occur after toggling wifi on/off/on and connecting).

Quote:
Originally Posted by stockwell

This really needs someone who knows what they're doing and access to a hidden 802.1x network to look into it.

Agree
5th October 2011, 02:38 AM |#5  
Retired Recognized Developer
Flag Brisbane
Thanks Meter: 597
 
Donate to Me
More
Quote:
Originally Posted by haydnlj

Was there a driver change between 1.8.19 and later MIUI versions? The supplicant seems like the same version (v 0.6.10)?

On returning to 1.8.19 have had 3 days without issues. When on 1.9.30 the change to ap_scan=2 definitely improved and seemed to make a connection on reboot flawless, but reconnection from sleep was sporadic (probably <30%). Watching wpa_cli output when waking phone from screen off on 1.9.30 showed a failed connection attempt, and then a series of timed scans (CTRL-EVENT-SCAN-RESULTS) - these continued after CTRL-EVENT-CONNECTED (something that didn't occur after toggling wifi on/off/on and connecting).

Agree

Thanks for you feedback, that really helps. Even though the version number is the same they aren't the same file.

I'll get in contact with you via pm to try and sort this out.
5th October 2011, 10:59 AM |#6  
OP Senior Member
Thanks Meter: 44
 
More
Thanks guys for trying!
So there is no solution yet?
18th October 2011, 10:42 AM |#7  
OP Senior Member
Thanks Meter: 44
 
More
Any news ?

Thanks!
20th November 2011, 09:16 PM |#8  
yub's Avatar
Junior Member
Thanks Meter: 1
 
More
Any news ?

I have same problem with that.
19th April 2017, 12:24 PM |#9  
Junior Member
Thanks Meter: 0
 
More
I also have the same problem, and looking for a solution. I am using Redmi 4a MIUI 8.2.6.0
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes