FORUMS
Remove All Ads from XDA

[webtop] webtop2sd discussion (currently version 2.0.1)

503 posts
Thanks Meter: 364
 
By Sogarth, Retired Recognized Developer on 8th October 2011, 09:12 PM
Post Reply Email Thread
Note: Please keep this thread restricted to Photon-specific issues. Atrix (and general) webtop2sd issues should be discussed in this thread instead. Threads for other devices are referenced at the top of the main webtop2sd thread.

Discuss webtop2sd here (the other thread will be kept clean for announcements, FAQs, etc.).

Before you report an issue:

Make sure it's not on the Known Issues list first!.

Basic debugging, since these are going to be questions I ask anyways:
  • If you hit problems with the Android webtop2sd application, you'll need to tell me the error, and give me the last few lines of adb logcat. Run this adb command, which will filter out most of the unimportant lines:
    • adb logcat ActivityManager:i AndroidRuntime:i webtop2sd:i *:s
  • Are you actually booting from your SD card? You can find this out by checking the Diagnostics tab in webtop2sd, under "Currently mounted webtops". If mmcblk1p12 isn't listed, you're not booted from your SD card. If this is the case, report what ROM you're running from.
  • Is the webtop configurator application showing, but not running successfully? If so, plug your device into your dock and run a terminal (either locally or adbWireless + adb shell) and run the following:
    • su
    • /usr/bin/sudo -H -u adas bash
    • export DISPLAY=:0
    • python /usr/local/bin/webtop-configurator.pyc
    I'll need whatever output shows up.
The Following 8 Users Say Thank You to Sogarth For This Useful Post: [ View ] Gift Sogarth Ad-Free
 
 
9th October 2011, 12:16 AM |#2  
Lokifish Marz's Avatar
Inactive Recognized Developer
Flag Olympus Mons, Mars
Thanks Meter: 3,752
 
Donate to Me
More
Tested this prior to release and can say this is what Moto should have thought of for webtop devices. Slower SD cards do cause noticable lag ofcourse so you want to have a class10. Once support for the internal memory is implimented it will eliminate the storage fragmentation and make this a "Crazy not to do this" mod.

Thanks
9th October 2011, 12:34 AM |#3  
Senior Member
Thanks Meter: 49
 
More
Dang I just realized I have a class 2 sd card. I guess it's time to upgrade.
9th October 2011, 02:06 AM |#4  
OP Retired Recognized Developer
Thanks Meter: 364
 
More
Quote:
Originally Posted by Lokifish Marz

Tested this prior to release and can say this is what Moto should have thought of for webtop devices. Slower SD cards do cause noticable lag ofcourse so you want to have a class10. Once support for the internal memory is implimented it will eliminate the storage fragmentation and make this a "Crazy not to do this" mod.

Support for internal memory, though, will only be for /data (since attempting to create one in /mnt/sdcard causes serious issues), so unless the Photon has a significantly larger /data than the Atrix does, that may not make a significant difference.
9th October 2011, 02:30 AM |#5  
Lokifish Marz's Avatar
Inactive Recognized Developer
Flag Olympus Mons, Mars
Thanks Meter: 3,752
 
Donate to Me
More
Quote:
Originally Posted by Sogarth

Support for internal memory, though, will only be for /data (since attempting to create one in /mnt/sdcard causes serious issues), so unless the Photon has a significantly larger /data than the Atrix does, that may not make a significant difference.

I tried a /home and /usr move to /mnt/sdcard with very inconsistant results. The end result was always an rsd flash to get running again so I moved on to other things. I was hoping you had some tricks up your sleeve. Even with webtop2sd pretty much being a /sd-ext mount, this is still very usable. Considering the lack of space on /data I'm not sure if it's worth trying to bring that feature back unless /home can be move elsewhere.

I have had a couple more issues during the install and will try to duplicate and get you the logs.
9th October 2011, 10:43 PM |#6  
Junior Member
Thanks Meter: 1
 
More
Having just a tad bit of trouble with apt-get and the webtop-configurator... Are the repos down for the photon??

Code:
adas@localhost:/$ python /usr/local/bin/webtop-configurator.pyc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Traceback (most recent call last):
  File "./webtop-configurator.py", line 455, in <module>
  File "./webtop-configurator.py", line 382, in main
  File "./webtop-configurator.py", line 153, in install
SystemError: W:Failed to fetch http://ca25-webtop-mirror.am.mot.com....5-9_armel.deb  Could not resolve 'ca25-webtop-mirror.am.mot.com'
, W:Failed to fetch http://ca25-webtop-mirror.am.mot.com...2.0.40_all.deb  Could not resolve 'ca25-webtop-mirror.am.mot.com'
, E:Aborting install.
If they are, does anyone have a cat output of the sources.list for the Atrix, maybe we could use that?

Edit: oh wait... only the bionic and photon are jaunty builds aren't they?
10th October 2011, 04:13 AM |#7  
OP Retired Recognized Developer
Thanks Meter: 364
 
More
Quote:
Originally Posted by Cryp7os

Having just a tad bit of trouble with apt-get and the webtop-configurator... Are the repos down for the photon??

Code:
adas@localhost:/$ python /usr/local/bin/webtop-configurator.pyc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Traceback (most recent call last):
  File "./webtop-configurator.py", line 455, in <module>
  File "./webtop-configurator.py", line 382, in main
  File "./webtop-configurator.py", line 153, in install
SystemError: W:Failed to fetch http://ca25-webtop-mirror.am.mot.com....5-9_armel.deb  Could not resolve 'ca25-webtop-mirror.am.mot.com'
, W:Failed to fetch http://ca25-webtop-mirror.am.mot.com...2.0.40_all.deb  Could not resolve 'ca25-webtop-mirror.am.mot.com'
, E:Aborting install.
If they are, does anyone have a cat output of the sources.list for the Atrix, maybe we could use that?

Edit: oh wait... only the bionic and photon are jaunty builds aren't they?

Fixing this right now. They changed the internal Motorola servers between the Atrix and Proton (which are both Jaunty - the Droid Bionic is Maverick). You should see a 2.0.1 shortly which will have a fixed webtop-configurator in it (for what little use it is ;p).
The Following User Says Thank You to Sogarth For This Useful Post: [ View ] Gift Sogarth Ad-Free
10th October 2011, 05:01 AM |#8  
OP Retired Recognized Developer
Thanks Meter: 364
 
More
Quote:
Originally Posted by Sogarth

Fixing this right now. They changed the internal Motorola servers between the Atrix and Proton (which are both Jaunty - the Droid Bionic is Maverick). You should see a 2.0.1 shortly which will have a fixed webtop-configurator in it (for what little use it is ;p).

  • 2.0.1 (October 9, 2011):
    • Tweak webtop-configurator for the Photon's sources.list.
The Following User Says Thank You to Sogarth For This Useful Post: [ View ] Gift Sogarth Ad-Free
10th October 2011, 06:40 PM |#9  
cybericebyte's Avatar
Senior Member
Pamona
Thanks Meter: 7
 
More
Lxterminal not launching

Sent from my MB855 using XDA App
10th October 2011, 10:34 PM |#10  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by cybericebyte

Lxterminal not launching

Sent from my MB855 using XDA App

Did you use the webtop configurator to install it first? The lxterminal icon on the dock is a bit deceiving.
11th October 2011, 12:59 AM |#11  
cybericebyte's Avatar
Senior Member
Pamona
Thanks Meter: 7
 
More
Ah sorry for got to mention webtop configurator not launching either.

Sent from my MB855 using XDA App
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes