Remove All Ads from XDA

[Q] WPA-Enterprise+AES+PEAP (custom WM 6.1 ROM)

316 posts
Thanks Meter: 136
Thread Closed Email Thread
Hello everyone

Last school year, when I still had the original WM5 ROM on my Uni, I could connect to my school's wifi network that requires:
- WPA-Enterprise (Not WPA2!)
- AES encryption (AES on WPA - not 2 - looks a bit strange, but it«s the way it is setup on Windows 7 that can connect)
- PEAP for the EAP
- The routers are Cisco gear so I suppose they use Cisco LEAP
- No certificate (do not validate server cert)

On WM5, I could connect: I could select WPA on the first dropdown of the network settings, then on the box below that one I selected AES. Next step, I selected PEAP for the EAP type, and Finished. then I added a registry key somewhere so it wouldn't try to validate the server certificate. It asked for my credentials when I tried to connect to the network, and it connected fine and worked well.

Now I use a WM6 ROM, Tomal 8.9. I can select WPA but there is no AES option, only TKIP. I already added the registry key for it not to validate the server certificate, but it isn't even trying to validate the cert - doesn't get to that step, the furthest I could go was having it asking my network credentials in an infinite loop.

Should I try another ROM? (oh, and BTW, I'm sure that the network doesn't use WPA2, but WPA with AES encryption)

Any help is greatly appreciated. Even because I don't have a 3G data plan and the wifi at school was very useful.
6th October 2011, 07:24 PM |#2  
OP Senior Member
Thanks Meter: 136
Nevermind. After inputing my network credentials enough times, I could connect using TKIP. But somehow Windows computers are still configured for WPA AES instead of TKIP, which is strange. Anyways, it works now, and that's what matters.
Thread Closed Subscribe to Thread

aes, peap, wifi, wm6, wpa-enterprise
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes