Remove All Ads from XDA
Honor View 10

FXP41+ Data Loss Bug Hunt (Bug Squashed)

567 posts
Thanks Meter: 189
By GreatBigDog, Senior Member on 26th October 2011, 11:30 PM
Post Reply Email Thread
Bug issue has been solved as if FXP45. Thanks to all who helped track this nasty critter down.

I've been asked to start up a thread specifically for tracking down the data loss bug in FXP41,42 and 43. I'm currently one of the very few that are not suffering from this problem.

The data loss issue is when your wifi or 3g status indicators still show you as being connected to the internet and Google (green indicators) but no data is transferred. A reboot of the phone will restore data for a limited period of time before the same thing occurs again. After a fresh install, it can take anywhere from a few minutes to a few hours for data loss.

For those that have the problem nothing tried so far as been able to rectify the problem for any length of time and for those of us that don't have the problem we can't duplicate it.

What needs to be done

We need to find some common denominator between the devices / users that are having this problem that is also something that none of the working devices / users don't have. If you have anything to add that you've tried to do to duplicate the problem or fix the problem please post or PM me with the details and I'll keep this OP up to date.

What been tried to duplicate problem on working devices

1. Fresh install - Nope
2. Market update / downgrade - Nope
3. Forcing sync - Nope
4. Factory data reset and login with different account - Ongoing

What's been tried to fix the problem

1. Fresh install - Nope
2. No Gapps - Nope
3. Market downgrade - Nope

What still need to be tested (suggestions please)

1. Working device/user create a different Google account and test with that.
2. Who is using 2 step verification and do they have problem or not.
3. Compare results of a clean install using the same account on a working and not working phone. (I have account setup PM me for login if you want to help test)

This should get the ball rolling, I'll add some more is a couple of hours once I get my head in gear.
The Following 7 Users Say Thank You to GreatBigDog For This Useful Post: [ View ] Gift GreatBigDog Ad-Free
27th October 2011, 12:14 AM |#2  
Senior Member
Flag Seville
Thanks Meter: 38
I've had the problem today. I didn't try to format the sdcard first, but maybe it helps. I can't try it until next week at least

Enviado desde mi X10i usando Tapatalk
27th October 2011, 12:15 AM |#3  
lunarjetman1's Avatar
Senior Member
Thanks Meter: 97
I was on this rom (fxp041) for a while, it was at least two weeks before i got the data bug. I'll have another go tomorrow installing the latest version fresh. I'll experiment to see what causes it. Hopefully report back tomorrow with some report.

cheers, lunar.

Sent from my X10i using XDA App
27th October 2011, 12:17 AM |#4  
GreatBigDog's Avatar
OP Senior Member
Flag Prince Edward Island
Thanks Meter: 189
I've just done a factory data reset and setup the phone using a different gmail account that I created for this test. If I loose data then maybe it's account related.
27th October 2011, 01:09 AM |#5  
Senior Member
Flag Alberta
Thanks Meter: 157
Donate to Me
Well, I have tried two different google accounts, so either both of my accounts are screwed, or it isn't something tied to the Google account. However, it didn't happen to me UNTIL I installed the GApps addon package either time - first time I installed the ROM, had data no problem for about 3 hours, then was like "Whoops, wait a minute, need my Gmail / Market apps", so I installed the package and lost it. Second time, installed both, had net, did a Market download of a few apps, checked gmail, worked fine for about half an hour, then went kaput. Did the second time with a DIFFERENT google acct.
27th October 2011, 01:25 AM |#6  
Senior Member
Thanks Meter: 18

The data bug began for me with the fxp30b release. I tested so many things to tackle that nasty bug.


Sent from my X10i using Tapatalk
27th October 2011, 01:41 AM |#7  
azrull's Avatar
Senior Member
Thanks Meter: 9
FXP043 also have data bug. I will use stock or VMOD version later.
27th October 2011, 08:51 AM |#8  
colossus's Avatar
Retired Senior Moderator
Thanks Meter: 3,122
Donate to Me
Hi GBD,,

I have tried everything you have in the op and nothing has worked for me too, also you can rule using a new account as i have tried that too even on a fresh install.
I thought that when market updated it was that causing the issue but yesterday i froze the marketupdater app with titanium, signed in, and the problem still occurred.In fact before signing into google the phone had worked fine for several hours with no data issues.

I wonder if Crowds has found the solution here..

Maybe we do have a fix so waiting now for good news.

I have gone back to fxp030 for now as i need my phone for work.
27th October 2011, 12:42 PM |#9  
Crowds's Avatar
Senior Member
Flag Azeitão
Thanks Meter: 2,226
Donate to Me
Originally Posted by colossus

I wonder if Crowds has found the solution here..

let´s see what i sent to FXP will do

i had the same issues as many but after i´ve tried several mixes i was able to stay connected all the time without interruption since 21:00 yesterday till now

27th October 2011, 01:18 PM |#10  
DooMLoRD's Avatar
Inactive Recognized Developer
Flag Pune
Thanks Meter: 39,810
i think its related to new Market... on ARC i have similar issues on CM7 as well as stock ROM :P
27th October 2011, 01:20 PM |#11  
Crowds's Avatar
Senior Member
Flag Azeitão
Thanks Meter: 2,226
Donate to Me
Originally Posted by DooMLoRD

i think its related to new Market... on ARC i have similar issues on CM7 as well as stock ROM :P

for some it seams like but for many still have issues

i didn´t change/delete anything from original rom and i´ve manage to work everything. well...almost. seams that i´ve lost capabilitie to turn bluetooth on
Post Reply Subscribe to Thread

bug hunt

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes