Remove All Ads from XDA

"error formatting /data" and "error formatting /cache"

40 posts
Thanks Meter: 0
By tbogs, Member on 4th November 2011, 06:23 AM
Post Reply Email Thread
Let me start by saying I'm new to posting on these forums. I've been flashing roms now for over 7 months and have enjoyed it immensely.

The other day I ran into a problem that I've never had before. I was running Nil's 3.5 rom which is a great rom, and installed the V6 Supercharger Script (also great) to see how it would work with the rom. I installed everything, had V6 working and was prompted by V6 to change I believe it was /data and /cache files. I thought ok there shouldn't be a problem. So I ran V6 and everything seemed to run with no problems. Then things got a bit laggy so I decided lets try and uninstall V6 and see if that helps. V6 restored my settings that were backed up, and I uninstalled V6. I decided at this point to do a complete wipe and reflash the rom. This is when I encountered my problem.

I reboot the phone into recovery mode: (Using the lastest clockworkmod recovery)

wipe data factory reset
wipe cache partition

I go under mounts and storage, format

I get an error stating "error formatting /data" and "error formatting /cache".

I am unable to restore any backups that I had already made because I receive this error message. When I install a new rom, I receive bootloops. The only rom that works, is Nils 3.5 rom that is still stuck on the phone, and when that loads, nothing works properly. I cannot download apps, the apps already installed force close on me.

I have no clue on what to do. Now I am asking myself, did I brick my phone? Any help, suggestions would greatly be appreciated.



I decided to try downgrading to the official 2.2 stock version with S-On with hopes of trying to start from scratch and now I am stuck in bootloops. The phone goes to the red eye, pauses for about 20 seconds and reboots. Any suggestions on what to do now?
16th November 2011, 12:59 AM |#2  
Thanks Meter: 11
Just had this issue on my wife's phone. System random rebooted after an app update and now /cache and /data won't format. Nothing posts past the white Incredible screen.

Came up with some solutions that I have yet to try, but here's what I found:

Looks like basically we need to force fix the file system and push something initial onto the phone though adb.

I'll keep this tab open and post my results as I try some fixes tonight on my wife's phone.
16th November 2011, 02:25 AM |#3  
Junior Member
Thanks Meter: 0
Bad news for you guys. I had this happen a month ago and could not fix it. Someone over at the CM forums helped me try and fix the partitions in the internal memory, but we both think the hardware was the culprit. I was under warranty still and got a replacement phone.

16th November 2011, 04:12 AM |#4  
Thanks Meter: 11
That is the thread I'm following. So far I've had moderate success with the commands posted here:
that are designed to totally re-create the partitions. Attempting to format at the moment from the phone recovery with no connection to the computer. I'm hoping this isn't all hardware related.

---------- Post added at 09:12 PM ---------- Previous post was at 09:11 PM ----------

Grr... still getting errors. Might be dead in the water.
16th November 2011, 06:01 AM |#5  
OP Member
Flag Salt Lake City
Thanks Meter: 0
After about a week and a half messing around with things, I have been unable to fix this issue. Luckily I was able to upgrade and went with the Rezound.
16th November 2011, 03:39 PM |#6  
Junior Member
Thanks Meter: 0
I was able to get the format data command to work from within CWM once or twice, but not consistently. I really do think my phone hardware failed. It is scary that if it happened three months later, I would have been out money.
16th November 2011, 06:37 PM |#7  
dragon droid's Avatar
Senior Member
Thanks Meter: 10
If I'm not mistaken nils roms format the phone to a different type ext. You may want to find a way to reformat the phone to the stock ext. I may be completely wrong on this but since you currently have a brick it might be worth looking into.

Sent from my Incredible Stock+ Ginger Tiny
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes