FORUMS
Remove All Ads from XDA

[Recovery]Clockwork Mod 6.0.1.2

3,585 posts
Thanks Meter: 1,656
 
By TheManii, Wiki Admin / Recognized Contributor on 6th November 2011, 02:33 AM
Post Reply Email Thread
Quote:

Requirements:

  • Ability to enter fastboot mode
  • Basic understanding of the command line
  • Battery with 60% or greater charge
  • A compatable rom (see below)

Compatable roms:
  • Supported:
    • Stock 5xx
    • Cyanogen Mod 9.0 Mod
    • Honeystreak R7 and newer
  • Not supported:
    • Stock 3xx
    • Honeystreak R1-R6
    • "normal" Cyanogen Mod 9.0 (ICS B4)
    • AOSP/JB

Quote:

Install Instructions:

  1. Download Clockwork mod recovery.img
  2. Reboot device into fastboot mode
  3. Flash the recovery with "fastboot flash recovery <path to recovery.img>"
  4. Finished

Quote:

What works:

  • Nandroid
  • Factory resetting
  • Clearing caches
  • Update zip flashing

What doesnt:
  • USB mounting (requires kernel mods)

Quote:

Notice:

  • What to do if your nandroid freezes at /cache, /data, /datadata:
    • Flash update-CWMfixer-1.zip as an update zip and try again.
    • OR: Factory reset and manually restore data (Not recommended)
  • To note again: you CANNOT use this if you were previously using HS r2-r6 or ICS
  • If you had previously gotten the 'password' bug on a previous version of CWM (CWM 4.0 specifically), fac resetting from a newer custom recovery will fix this
  • The fac reset command from the bootloader menu will no longer work with a custom recovery installed, but the one from inside the recovery can replace it
  • USB mounting does not work, it cannot be fixed without kernel mods

Quote:

Controls:

  • Vol Up: Scroll up
  • Vol Down: Scroll down
  • Power: Select item
  • Back: Go back

Quote:

Changelog:

  • Sep 09 2012: Updated to 6.0.1.2
  • Aug 21 2012: Added workaround for nandroid issues
  • Aug 07 2012: Updated to 6.0.1.1 - updated formatting code
  • Jul 21 2012: Updated to 6.0.1.0 - updated instructions
  • Jul 20 2012: Updated to 6.0.0.9 - fixes update.zip formatting
  • Jul 18 2012: Updated to 6.0.0.6
  • Nov 30 2011: Removed beta tag as it's stable enough, file hasnt changed
  • Nov 13 2011: Updated to 5.0.2.7 - includes built in dual sdcard support
  • Nov 5,2011: Released first beta

1000th POST!
The Following 9 Users Say Thank You to TheManii For This Useful Post: [ View ] Gift TheManii Ad-Free
 
 
6th November 2011, 06:18 PM |#2  
Senior Member
Flag Moscow
Thanks Meter: 7
 
Donate to Me
More
nandroid backup AND successful restore?
zip flashing is not tested or not working?
6th November 2011, 06:46 PM |#3  
OP Wiki Admin / Recognized Contributor
Thanks Meter: 1,656
 
More
simply not tested, i expect it to work but i'm not sure which zips are compatable

(this is also true of cwm4.0 OR because of 5xx roms being different. I am still examining them, if you wish to test, try using superuser7.zip with cwm5.0)
6th November 2011, 07:09 PM |#4  
Senior Member
Flag Moscow
Thanks Meter: 7
 
Donate to Me
More
i've tested superuser7 with cwm 4 on 506 and it worked, at least i got root ;) but had to flash stock recovery back... gonna test cwm5 with superuser7 on 506 tomorrow on friend's ds7
12th November 2011, 06:58 PM |#5  
OP Wiki Admin / Recognized Contributor
Thanks Meter: 1,656
 
More
Next release of CWM will contain dual sd card support (like on the s7), I will wait for it to stabilize before building a new version.

Also going to build for the s10, but that's slightly unrelated
13th November 2011, 11:15 PM |#6  
OP Wiki Admin / Recognized Contributor
Thanks Meter: 1,656
 
More
Uploaded new beta, based on cwm 5.0.2.7 which has dual sdcard support built in.

USB mounting does not work, it is a known bug
.android_secure is not backed up, as i've never had a need for it I cant even test it. If someone that actually uses it can test it and post results i'll look into it.

Edit: Not an issue, it's automatically backed up apparently, just as much HC cannot use it anyway

Now it should have all the functionality that was included in dj_steve's version of CWM 4.0.

If a couple people can go around testing all the features in it and making sure everything works I can move it from beta to being release worthy.
14th November 2011, 12:15 PM |#7  
Senior Member
Flag Heredia
Thanks Meter: 1,051
 
Donate to Me
More
TheManii, I see everything working except for mounting the USB which we know is a known issue, besides that it all seems good

EDIT: Ok now I am having the same issue as Mystical here below me. I can't flash from the external sd where I had all my files for flashing like themes and such
15th November 2011, 12:18 AM |#8  
Mysticales's Avatar
Senior Member
Thanks Meter: 122
 
More
Issue for me is I tried to use a external SD card witch files to flash, it claimed it couldnt mount the sdcard. Tho the internal one it accesses fine when using "choose zip"

Also the USB Mounting, yea, that wouldve been nice to have working. =)
15th November 2011, 12:25 AM |#9  
OP Wiki Admin / Recognized Contributor
Thanks Meter: 1,656
 
More
That's a known issue in this cwm, i'm not sure if it's cwm itself or cwm on the streak.

If you click external sd a couple more times it will eventually work and keep working for that session,

does installing zips work fine? That's the main thing that still needs to be tested before I can say it's release worthy
15th November 2011, 06:25 AM |#10  
Senior Member
Flag Moscow
Thanks Meter: 7
 
Donate to Me
More
some reports - superuser7 flashed ok.
but after some browsing through menues cwm beta2 stopped working - press on power button only shows empty CWM screen.
15th November 2011, 06:49 AM |#11  
OP Wiki Admin / Recognized Contributor
Thanks Meter: 1,656
 
More
That might be the hidden feature, did your screen say "back button disabled"?

If it did just scroll up or down until the screen says "back button enabled"
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes