FORUMS

Overwrote Stock with CM 7.1, want to load books into internal memory for Nook App

5 posts
Thanks Meter: 2
 
By m0nsieur2, Junior Member on 9th November 2011, 06:49 AM
Post Reply Email Thread
This is my first Nook Color-> android flash. I'm having trouble loading my books back onto my Nook.

I followed a how to from android forums, setting up a 2GB uSD card to install CM7.1 using CWR:
I downloaded the rom from CM: update-cm-7.1.0-encore-signed.zip
(I cannot share the link since i just joined, but if you google: "nook color cm7 storage" and click the first link, that's the process I followed)

Installation went fine, I also added the google apps package, and can finally download apps from the general android market rather than the B&N market. I downloaded the nook app so I can load my books back on (mostly epub format). The problem is that when I run the Nook app, it says I have no SD card inserted. This is true, but I didn't need one to load books into my additional storage on the Stock Nook rom. I also have lost the USB storage mode ability I had on the stock rom.

If I go to Settings->Storage I have the following partitions:
1)Internal storage: 0.792/0.92GB
2)Additional Storage: 4.82/5.00GB
this is the /mnt/emmc drive
3)Additional Storage: unavailable
this is the /mnt/usbdisk

Again, all I'm looking to do is load books into my internal storage like I had with the original Nook Rom, and I'd like to be able to drag and drop them from my computer via USB. Any suggestions would be greatly appreciated.


If it's too complicated I may go back to the stock rom, I just wanted the option of using a better web browser and having access to more apps with full android.
9th November 2011, 06:54 AM |#2  
OP Junior Member
Thanks Meter: 2
 
More
on a side note, in win XP file explorer, I see two drives when my nook is connected to USB, but neither has any data, and simply tells me to insert a drive/card when I click on them
11th November 2011, 06:54 AM |#3  
OP Junior Member
Thanks Meter: 2
 
More
Problem Solved
I messed around a bit and finally got things working. I wasn't getting USB mode, because you need to open the tray and click on USB Connected, then you get the "Turn on USB storage" dialogue. Yes, I'm a CM7 newbie. My stock nook, and stock Nexus One do not require this step. I also went into settings->CyanogenMod->Applications and checked the "Use internal storage" box, which switches your internal and SD card names in the system (requires a reboot). I'm not sure if this last step is necessary.

As for sideloading books to read, you have to figure out where your reader app wants to have them located on your device. For the Nook app, you put them in the "Nook/MyDocuments" folder. It could not find my ePub books unless I put them there. Then they still don't show up at the normal library page, I have to go to "My Files" in the drop down menu. On a side note, I'm liking the Nook app, which has page turn animations (the stock nook reader app does not). When you enter your B&N account, it should automatically sync books you have purchased.

Next thing to try is other reader software. I installed kindle and google books, but all my books are currently ePub. I'm going to try Blio and Aldiko next.

Hope this research helps someone else out moving from Nook Color as an ereader to Nook Color as an android tablet still used as a reader.
The Following 2 Users Say Thank You to m0nsieur2 For This Useful Post: [ View ] Gift m0nsieur2 Ad-Free
11th November 2011, 02:42 PM |#4  
patruns's Avatar
Senior Member
Thanks Meter: 103
 
More
I wondered this myself and when I was having issues with the app I uninstalled it, changed the CM7 settings to install all apps internally as to the default of "auto", rebooted and reinstalled the app and then changed the settings back and rebooted. While that fixed my problem, the app still wanted a memory card installed. The reason is this is not a tablet app and it is looking for a card because most (or at least many) phones do not have enough internal memory. Since I used a card for backup, updates, etc this was not a big deal for men.
12th November 2011, 03:37 AM |#5  
Senior Member
Springfield, Mo
Thanks Meter: 19
 
More
ive tried moving the book to the MyDocuments file and still am not finding the book i have downloaded.. it is in pdf file format so would this prob be the issue? ive selected the my files icon and it shows (0) files... not for sure what all im still doing wrong to get my book to read on the Nook app
12th November 2011, 11:02 PM |#6  
Senior Member
Flag Sheridan
Thanks Meter: 158
 
Donate to Me
More
Why aren't you using the setting to use your Emmc partition as your sdcard? It's an option to in CM7.

Sent from XDA Premium app CM7.1
16th November 2011, 07:56 PM |#7  
OP Junior Member
Thanks Meter: 2
 
More
Bmar08, I'm not sure if the nook app will read PDF files. You can use file manager to find your PDF files, then open them with your browser. I also started using the free Aldiko reader, which will read ePub and PDF files. It has a lot of nice options such as font size, brightness, background color, etc. so you may try that. Aldiko will also let you browse your directories to indicate which ones you want to include in your library!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes