Remove All Ads from XDA

USB OTG (USB host functionality) on Razr - Working!

95 posts
Thanks Meter: 5
By Karmarock, Member on 16th November 2011, 01:23 PM
Post Reply Email Thread
3rd February 2012, 08:28 AM |#51  
Thanks Meter: 1
Hi, i'm having small problems with this otg. I've done otg cable from nokia micro usb to usb, works on nokia e7. I connected razr like this, otg cable-usb connector(female usb from both sides)-hub. Hub is modecon ufo with 7 usb ports, on begining it didn't worked bcs it didn't give +5 on cable that is usually conected to pc. So i soldered +5 from one of povered ports to this vire. When it's connected to razr phone starts to charge, after connecting mouse to hub it's working, but after connecting any usb memory stick ar disk im getting error "sorry, aplication usb (procedd com.motorola.usb) was stopped suddenly. try again". Mouse is still working but storage devices no. My phone is only rooted. I'm on
3rd February 2012, 10:16 PM |#52  
Flag Santa Rita do Sapucai
Thanks Meter: 12
what is your USB HUB IC part no?
4th February 2012, 09:47 AM |#53  
Thanks Meter: 1
It's based on alcor au6256 . I installed USB Host Controller and it detects both logitech controller for mouse, and and pendrive. Mouse is still working but after connecting any storage device still getting same app crash (app usb).
Working perfectly fine now, after updating from 651.73.30.
3rd March 2012, 04:34 AM |#54  
Junior Member
Thanks Meter: 3
I was finally able to hook up a usb hub to my bionic and read usb drives. But for the sake of portability i made a rechargeable battery powered usb hub. It works great.
5th March 2012, 05:52 PM |#55  
Thanks Meter: 0
I have some ideas and problems to bring into this thread.
Maybe someone can shed some light on my thoughts.

I have a rooted Razr XT910 and a car dock.
Also, i have a (in fact, more, but that is not part of the problem) 4-port USB Power supply for car and mains (Ansmann 5211013).
I'd like to use this power supply at home and in my car to charge my phone and have the ability to play movies and music from external USB storage. (I know it does not with the car dock cable because in there data lines are used for the audio.)
The reason for this power supply is simple: my wife and also the kids have devices with USB charge, and our car only has one outlet. So this handy thing allows me to use my Razr as Nav, while wifes phone can recharge and kids have power to play all the way to wherever we drive.
(Side note: it has 2 sockets noted "for iphone", 1 for "Samsung, Philips, Creative", 1 for "Navigation". Razr originally showed "AC" in iphone sockets, "USB-charge" in Samsung socket and did not charge in "Nav" socket. Sockets have different resistors on data lines: iphone has divider, Samsung has pull downs, Nav has open data lines. I removed resistors on my experiments. I used a battery monitor app to see the charge info.)

Also, i am able to solder, i earn my money in a electronics factory building all kinds of stuff, so electrically spoken i know what i am doing.
But, i am new to Android and Razr.

Experiment 1: I have bought a no-name USB-OTG cable ("micro B male" to "A female") and noticed the razr won't do anything, nor does the stick.
Trying a externally powered HDD did nothing also.
Conclusion: Power missing.

Experiment 2: I then modified a hub (D-Link DHub7) to "backpower" the host on his USB-B-Female, and upon plugging the Razr with its OTG-Adapter into the upstream cable of the hub, the Razr shows it's charging, also the hub powers the downstream plugs (usually upon recognition of the host). Plugging my stick into the hub makes it blink and appear on my Razr.
Conclusion: Works, but has too much of plugs, cables and additional hardware.

Experiment 3: I soldered 2 of the 4 sockets of the Ansmann power supply in parallel. I then plugged the hub in one of these ports (power on, ports off) and connected my phone to the other via the standard cable (micro B male to A male, the supplied data/charge cable). Phone showed "AC charge", but did not recognize Hub/stick (all lights were off).
Conclusion: There is some magic in the OTG adapter, so it's needed.

Experiment 4: connected hub with stick to bridged power supply ports, soldered A-male-to-A-male USB cable, plugged it into the other power port and the other end to my OTG-Adapter, then into the phone. Razr charged and recognized hub and stick.
Conclusion: works, but needs "special" cable and also too much of it.

I want to get rid of the Hub, so i started
Experiment 5: Stick to bridged port. A-A-cable to other bridged port, other end to OTG adapter, adapter to Razr. Razr charged, no USB recognition.
Conclusion: Hub is needed.

I do not want to carry all those things:
- power supply (with mains and car cable)
- hub with host cable
- OTG adapter
- standard data cable (to charge with minimum plugging)

My goal is to have the power supply and a data cable ready, plug it in (into iphone sockets = AC charge) and simply charge.
Or use the other sockets, plug stick/hdd in the other bridged port and use it.
I can live with having a second data cable (with pin 4 set to GND = OTG-Mode). I can also solder this data cable myself, i have the plugs at hand.
I don't want that OTG adapter (only 10cm and god knows why it's angled), because it's too short and dangly, and it does nothing because i need the hub to initiate data transfer and have the ability to supply power to the phone and peripheral. Using the hub on an PC would "divide by zero" because it powers the PC back, leading to at least unwanted results, if not burning something.
I want a nice solution, throwing the supply under my chair, connect 2m cable from there to my phone so i can handle it easy, connecting the stick or HDD also to the supply (out of my feets/hands range and on the ground, so it won't fall off the sofa or kill the USB plug on my phone) and maybe 5m HDMI to my TV, but that's another story.

Anybody out there who knows how to make OTG work without the hub?
Functionality is ok, cables are no problem, but the phone recognizes the Stick only behind the hub, i don't want that.

Sorry for the post being a novel, but i wanted to give you all my info.
I am sure i missed something, so please ask if you need to know something.

Regards, Jens
28th March 2012, 05:36 PM |#56  
Junior Member
Thanks Meter: 0
I've got the Y cable and OTG cable I got from ebay and started my own testing. I'm using a fairly weak battery as a power sources (5.6V 350mAout 900mAh). These are the devices I tried so far and their functionality
-Keyboard - I tried it today after updating to 65.1.40.Retail.en.IL (Israeli) , set the external keyboard to Hebrew (language and settings menu) and it worked well including switching language to English using alt-shift .
- Mouse - supported natively like bluetooth. I had a problem with one mouse that didn't fight well with the phone for power.
- Disk on key - No problem sandisk 8GB (that's the brand they sell here)
- 500GB external Hard drive (WD elements 2.5" ) - I had to plug in the hub to a 2A~ power supply (it doesn't push power into upstream port so the battery was still there ) and format the drive to fat32 (using fat32formater program). the phone didn't like exFAT for some reason and it didn't recognize the drive when it was NTFS.
- Ethernet - We tested it here at work but it didn't work. Someone told me it works. I know you can connect Ethernet through an HDMI adapter .

My current problem is that my battery is weak and the phone likes to gobble up current from it not leaving much to the devices. Is there a way to limit the current draw from the phone?! I'm going to get a more powerful 2A output battery soon and I bet I can run a hard drive with it but it would be kinda bulky to haul around compared to what I have now .
18th July 2012, 03:47 AM |#57  
Junior Member
Thanks Meter: 3
I had the same problem with the battery draw all I did was put a resistor inline with the power wire running to the phone I use a 4ohm. The resistor cuts down the amperage draw but not the voltage. The phone doesn't actually need to charge just a power signal coming in.
19th August 2012, 11:08 AM |#58  
Junior Member
Thanks Meter: 1
Guys need help.. I followed the instructions to prepare a custom otg cable and managed to build one.. MiniUSB male to USB male(power) and USB female.. I checked all the connections and everything seems to be alright. Now wen I connect the male USB to power, mini USB to phone and female USB to pen drive/ hdd, the phone seems to go to charging mode and the light of my pen drive/hdd starts glowing.. And that's it.. nothing seems to happen. But wen I connect my mouse, my razr detects it and seems to work flawlessly... I dont know what seems to be the problem. By the way am using 5v 1A wall charger for power.
21st August 2012, 02:39 AM |#59  
arisgoku's Avatar
Senior Member
Flag Lemesos Greece
Thanks Meter: 17
now with ics are there any bumps on this?
27th August 2012, 07:37 PM |#60  
Junior Member
Thanks Meter: 0
Originally Posted by kholk

Can't you all read what someone writes prior you?

Have y'all come across a battery setup for this? I want too be able to tether to my canon 7d camera and use dslr controller app. Thanks!

Sent from my DROID RAZR using xda app-developers app
6th October 2012, 07:17 PM |#61  
Senior Member
Flag RIchmond, Virginia
Thanks Meter: 19
Originally Posted by asheg

guys so can any1 sell on ebay working OTG cable for droid razr, pls?
just make and sell it, we will buy ))

This works just fine. Comes with a power cable, mount more than one at a time.
Post Reply Subscribe to Thread

razr, usb host, usb otg

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes