Remove All Ads from XDA
Honor 9 Lite

Droid 2 Global, Unlocking + Rooting Success, Canada

5 posts
Thanks Meter: 1
By isosphere, Junior Member on 16th November 2011, 11:50 PM
Post Reply Email Thread
I had trouble finding information on this variant of Droid, so I thought I'd share my own findings now that I have it working the way I wanted.

I ordered a brand new, Verizon Wireless locked version of this phone off eBay. I'm in Canada, so I was unable to activate the phone as it requests after the "touch the droid" screen. The nearest Verizon tower is very far away.

I found out (maybe this is common knowledge about Android phones, my searches were probably too specific) that I could bypass that activation by touching each corner of the screen.

I used SuperOneClick to root the phone, which went completely painlessly; seems like a great tool. This isn't a necessary step to unlock it, I just wanted it rooted.

I gave $30 USD and my phone's IMEI to CellUnlocker, and they got a working unlock code to me in 2 days. Some people have had problems unlocking the phone, but it worked immediately for me, maybe it's luck.

I haven't tried a brand unlock, since I don't plan on using my phone in the states soon!

I followed these instructions to improve my signal strength, but I haven't thoroughly tested it.

I am now using the phone without a hitch on Telus' network, data included. I had to set up an APN for them, with information from here.

I applied a fix mentioned by Kositch here to prevent Google Maps from crashing my phone. The min free KBytes setting was 2845 by default, as reported by the sysctl config *root* tool. It seems to have worked.

Unfortunately my battery doesnt last more than a day with moderate use. I've setup setcpu to underclock the processor based on battery life in hopes that it helps. It's hard to tell if it does or not without any kind of benchmarking. Based on the built-in battery usage app, I would say it probably does not affect my battery life much to underclock the phone, it is mostly the display that drains it.

One bug I have had is that my Internet connection will stop working after the phone has been out of use for some time or in airplane mode. A restart of the phone seems to solve this every time, though I'd rather not have to do that.
18th November 2011, 03:35 AM |#2  
Senior Member
Thanks Meter: 141
I am having a nasty bug when using my D2G on Telus - every time I dial out, immediately call drops and then reconnects in background. Very annoying and prevents you from dialing conference bridges automatically. I have tried with both normal sim that came with my Telus milestone at the time as well as a fresh new microsim and experienced this in both cases. On Fido and Rogers it is fine. Haven't tested on Bell as I don't have active account with them.

Sent from my XT860 using Tapatalk
9th December 2011, 05:45 AM |#3  
OP Junior Member
Flag Toronto
Thanks Meter: 1
My phone does the same, but it does not cause me problems as I only make ordinary calls. It's certainly a bit weird.

Sent from my DROID2 GLOBAL using XDA App
Post Reply Subscribe to Thread

canada, droid 2 global, root, telus, unlock

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes