Remove All Ads from XDA

[ROM][ICS][IML74K] teamhacksung's CM9 ALPHA for Captivate (BUILD 17)

2,189 posts
Thanks Meter: 3,725
By atinm, Retired Recognized Developer on 13th November 2011, 12:55 PM
Post Reply Email Thread

Teamhacksung has been porting ICS (to be CM9) for the Galaxy S and Captivate we feel that it has reached a state where it would benefit from public testing. However this is still a very early versions and there will be bugs. Bug reports are allowed in this thread only. Please check the known issues section before reporting a bug. The most minor bugs are welcomed (we'd love to know them, but we may not fix them instantly).

ROM: BUILD 17: / / (md5: bcf40f901b2ae6d758b40ac8d43163c2)
Google Apps: Download from ROM Manager. (Or
Google Apps Fixer: MultiUpload / / (md5: af8bcaf5f8158e8e1be7097fc86b6b28)
Google Apps Fixer will fix your problem with not being able to add Google Account or Calendar Sync, but will also reset your Google Apps data. Only flash if you're having problems. If Google Apps Fixer does not work for you, do a factory reset from CWM (or Android Settings) and do not restore system data via TitaniumBackup.

Older Downloads

ROM: BUILD 16: / (md5: 4bcccf2f665988ab5bd40fa88b0f7621)
ROM: BUILD 15: Mediafire / / (md5: 7d1fbe508999cab6af5b831955a19a17)
ROM BUILD 14: / (md5: 4ee4fd346b9f7ba22663ecc4a8ceb336)
ROM BUILD 13: / (md5: 803f2612d272a1420362d3faddbb0327)
ROM BUILD 12: / (md5: 9eb4952a7434bf6fc961edbdc8769062)
ROM BUILD 11: / (md5: 64271bde12dc64b7c9ea316b7b4be86a)
ROM BUILD 10: / (md5: 4ada7a9349da509f8a4936fb3d9ccb9a)
ROM BUILD 9: / (md5: ad1b821950fa875e301a0fa7a177fd1f)
ROM BUILD 8: / (md5: 119cc76944b938aeca47a2d9ffd142c9)
ROM BUILD 7.1: / (md5: 491f0ae9324d20d4c4ef8cb7b6536219)
ROM BUILD 6: / MultiUpload / (md5: 2fec3022f673af490f6c9535a677eaa5)
ROM BUILD 5: Multiupload / (md5: 0e8b66f9cdcbd58a5d0d6aa193af4edb)
ROM: BUILD 4: (Skipped on Captivate out of laziness)
ROM: BUILD 3: (md5: ecbe29d46af07b6030bb357aae87a11b)

Google Apps
v7.1: MultiUpload / / (md5: 8bf66137f18de45657f29c129a8f4d52)
v7: MultiUpload / / (md5: 1888fbb15f36a076cb3908acaf1bd15a)
v6: MultiUpload / / (md5: 6f51ded731d173c31b8c47395ca580b7)
v5.3: MultiUpload / / (md5: e7d69d98a633b646e4f14e6a43208e66)
v5.1: MultiUpload / (thanks! Kaik541) (md5: 87415730a1db2e90d3588bc895f239e5)
v5: MultiUpload (thanks! Kaik541) (md5: 8667c9ddca581a98867fc02db29a2326)
v4: MultiUpload (thanks! Kaik541) (No longer include apps downloadable from Market.) (md5: 8b2dad009bc2f8724d27f78bca162495)
v3: internal
v2: MultiUpload (thanks! koush)
v1: MultiUpload (thanks! koush)

- First time flashing ICS to your Captivate (or coming from another ROM)?
  1. Root your device and install ClockworkMod Recovery.
  2. Reboot into Recovery using 3-button-combo
  3. Do a Nandroid backup!
  4. WIPE (wipe data/factory reset + wipe cache partition)
  5. Install the ROM from internal sdcard using ClockworkMod Recovery
  6. Optionally install the Google Addon
- Upgrading from CM7?
  1. Do a Nandroid Backup!
  2. WIPE (wipe data/factory reset + wipe cache partition)
  3. Install the ROM from internal sdcard using ClockworkMod Recovery
  4. Optionally install the Google Addon
- Coming from another ICS build?
  1. Do a Nandroid Backup!
  2. Install the ROM from internal sdcard using ClockworkMod Recovery
  3. Optionally install the Google Addon
  4. Reboot into recovery and WIPE (wipe data/factory reset + wipe cache partition)
  5. If radio doesn't work, go back to Samsung ROM and flash from there.
- Upgrading from another build of ICS by teamhacksung?
  1. Do a Nandroid Backup!
  2. Install the ROM from internal sdcard using ClockworkMod Recovery
  3. Optionally install the Google Addon
Note: The upgrade process from CM7 to ICS is automatic, but downgrading from ICS to CM7 (or restoring Nandroid) requires flashing twice. Once from ICS and again from CM7's recovery.


Kernel Source:
Userspace Source: Patches are being integrated into CM's mainline tree. Device tree are available on teamhacksung's github, but may not be buildable. No support for the source code, do not post that you are not able to build it.

Known Issues
  • Camera does not support scene modes
  • Phone unnecessarily gets data connection on device encryption password enter screen.
  • Cannot format external SD *
  • Android OS battery usage display higher than normal.
  • Sometime wrong SMS selected for forwarding
  • Format internal instead of external SD when requested to format ext. SD
  • Transfer speed slows down when screen off
  • Screenshot shutter sound
  • TV Out using HW-decoding (probably won't be fixed)
  • Sim Toolkit (probably won't be fixed)
  • No camera focus mode setting
  • Compass doesn't work in Google Maps v6
  • Unable to dial "0001" in some regions
  • Slow USB transfer speed for some people
  • Camera still photos problem after recording video
  • Note: there are a lot of new options in Settings, but many of them are not implemented yet. DO NOT REPORT THEM AS BUGS. Additionally, some users has reported boot failure after disabling boot animation.
  • Empty wifi icon when using juice defender / sometimes on boot
  • Unused bottom bar in landscape dialer
Fixed Issues

  • Top of widget selection selector says "Select screen lock" (Upstream fix)
  • Chrome not working
  • Various other upstream fixes
  • Regression in BUILD 15: Superuser application crashes
  • Regression in BUILD 15: Data Roaming enabled by default
  • Back camera does not record geotagging
  • Camera crashes when changing resolution
  • New: WM8994 Extensions (aka "Voodoo Sound") is now configurable from DSP Manager
  • Duplicate entries in MediaScanner (will only prevent new duplicates, need to clear data to get rid of old duplicates)
  • Regression in BUILD 14: Screen flicker while turning off
  • Regression in BUILD 14: adb turns off every reboot
  • Mute-unmute needed on some calls (hopefully)
  • Notification power widget uncustomizable (now integrated into Settings)
  • Reboot into recovery on crash (it will still reboot, just not into recovery)
  • Unreliable Wi-Fi on screen off (hopefully)
  • Laggy video recording in low light
  • "sin" does not work in calculator in Spanish
  • Laggy playback of some video in .mkv container (same video works in the .mp4 container) (Recommendation: Dice Player from market. Does its own mkv extraction and has hw decoding support)
  • New Feature: Gamma tuning (equivalent to Voodoo Color's "v1 gamma hack")
  • 720p Video Recording laggy
  • No camera zoom
  • Timelapse video recording crashes
  • TV Out broken on sleep
  • TV Out black video
  • Broken encryption (regression in BUILD 11) (WARNING: users with already encrypted phone will have their data cleared (for real this time))
  • Compass, accelerometer broken in certain apps
  • Random force closes (hopefully)
  • Missing camera touch to focus (thanks to havlenapetr)
  • GPS does not work (regression in BUILD 11)
  • Off-charging does not show progress
  • /datadata cache not cleared when space is low
  • Slow mass storage transfer speed
  • Automatic brightness not working
GApps v7.1
  • Network location broken
GApps v7
  • Market purchase broken
  • Encryption not working without a data wipe (WARNING: users with already encrypted phone will have their data cleared)
  • Cannot authenticate new apps for root
  • Data sometimes get disabled on boot
GApps v6 / Face Unlock v6
  • Updated: based on IML74K
  • Face Unlock not working on BUILD 10+
  • No hardware composition (but hardware acceleration works)
  • Video recording does not work.
  • Video playback is not hardware-accelerated.
  • Photo taking does not work with the front camera.
  • Some camera options FC. (The camera is a temporary hack, when the Nexus S ICS source is released, there will be a proper fix.)
  • Movie Studio does not work.
  • WiFi automatically turns on after quitting airplane mode if WiFi was used during airplane mode.
  • Data Roaming is enabled by default
  • Can select widget on launcher without being on the widget screen *
GApps v5.3
  • Updated: Market apk
  • Removed: unneeded GoogleLatinIME
  • WPA Wifi Tethering broken (regression in BUILD 8)
  • Audio recording by android app crashes (phone calls still work) (regression in BUILD 8)
  • Phone crashes in landscape with T9 enabled
  • Reboot to recovery by default even though recovery not selected.
  • Slow T9 speed
  • CPU rarely scaling up to 1000 MHz
  • GMail sometimes fills up /datadata with attachments
  • USB Tethering on Windows requires the user go to to driver update and manually select the RNDIS driver.
  • Sketchy wifi tether (breaks if data connection comes up while tether is active) (it will still error, but you can now re-enable it)
  • Mounting external SD via USB broke in BUILD 7
  • Cannot accept many file types via bluetooth
  • Data activity icon sometimes gets stuck even data is off.
  • New feature: T9 Dialing by devatwork (Enable in Dialer Setting)
  • Cannot encrypt phone after restoring data.
  • Wi-Fi problems for Iran users
  • Market download temporarily goes to /datadata
  • Support for TV Out (in Galaxy S Setting application)
  • Screen appearing for a split second after screen off animation
  • Persistent "Removed SD card" message on external sd card removal.
  • Missing library for Android Open Accessory
  • Support for USB Mass Storage (see FAQ)
  • VPN does not work
  • Regression in device encryption
  • Large photos cannot be edited.
  • Missing Live Wallpapers
  • Bluetooth Reverse Tether does not work
  • Wi-Fi Direct not supported (it's supported in settings now, but apps are needed to use it as ICS does not come with any use-case for Wi-Fi direct)
  • Sometimes wifi strength won't show after boot if wifi is enabled. Toggle once to fix. (fixed, hopefully)
GApps v5.1
  • GApps: Missing TTS libs
GApps v5
  • GApps: Missing Picasa Sync
  • GApps: Unable to purchase apps
Build 3
  • Device encryption does not work. (Note: temporarily broken again in BUILD 4, works on BUILD 5)
  • User does not have write permission for external sd
  • A2DP bluetooth headsets do not work.
GApps v4
  • GApps: More missing libs for GoogleTTS
Build 2
  • Superuser.apk does not open.
  • Installer does not work on Samsung ROMs.
  • Factory reset (from settings menu) does not clear /datadata.
GApps v2
  • GApps: Missing voice chat, maps, text-to-speech libraries
  • GApps: Android Keyboard appears twice in Settings.
Frequently Asked Questions

My calendar sync isn't working!
Install the latest build and gapps and gapps fixer. If it still doesn't work, wipe your data.

App X isn't working!
Check the list at (unaffiliated with teamhacksung) first and check if it works on other ICS phones. Most likely, it's the application's problem, not ours.

Can I mount the phone as mass storage via USB?
Starting from BUILD12, mass storage is the default configuration (might not apply to existing installations). The below command can be used to change into USB Mass Storage mode. USB Mass Storage mode is always used in recovery.
setprop persist.sys.usb.config mass_storage,adb
If you want to switch to MTP mode use
setprop persist.sys.usb.config mtp,adb
Please reboot after executing the command.

I can't adb into the phone!
Please install Nexus S drivers from Google. (Or Galaxy Nexus's driver in MTP mode)

Can I flash other modems?
You may flash modem packages designed for CM7.

How do I take a screenshot?
The screenshot taking function is built into ICS. Hold volume down + power.

Can I use CM7 kernels?
No, the kernel has modifications to make graphics, camera, data counter and data limit work.

Can I disable LED Notification?
Yes. Untick Settings -> Display -> Pulse notification light.

Maps keeps asking me to sign in even though I'm signed in!
Ignore the sign in dialog and pull down the notification menu. Answer the request for permission. Do this a few times and Maps will work.

How do I enter Captivate Settings (Device Settings)?
Type "am start com.cyanogenmod.AriesParts/.AriesParts" from adb. Or starting from BUILD 7, it is available as an icon in your launcher.

How do I enter service mode?
Type "*#*#197328640#*#*" into the dialer.

Is there a Vibrant version?
We currently lack a developer/maintainer for Vibrant.

What's working? Why is there only a list of issues?
Everything else not listed are supposed to be working (aside from the usual CM7 bugs). If they're not listed, please post so that they can be added to the list of issues. A list of issues is far more useful from a development standpoint.

Why am I getting notified that my data partition is getting full when I have 1+ GB free?
Your /datadata partition, a smaller partition, is getting full.

#cmsgs on freenode

Q&A Thread:

Also, there is an additional FAQ by XDA forum user everest.deth that might be useful if your question isn't answered above.


syndtr: Updated touch and graphics driver
onecosmic: Being the first to successfully build the AOSP tree
Kaik541: Making GApps from v3 onward
ancdix: For hosting on
nikademus (_renaud_): For hosting on
CyanogenMod team: Setting up the infrastructure and being a great help in the porting process.
and everyone else involved in this port or CM7 for SGS.[/QUOTE]
The Following 112 Users Say Thank You to atinm For This Useful Post: [ View ] Gift atinm Ad-Free
14th November 2011, 11:50 AM |#2  
atinm's Avatar
OP Retired Recognized Developer
Thanks Meter: 3,725
The Following 17 Users Say Thank You to atinm For This Useful Post: [ View ] Gift atinm Ad-Free
26th November 2011, 04:10 PM |#3  
Senior Member
Flag Oklahoma City
Thanks Meter: 19
Wow, great news. Looking forward to trying this out!
The Following 3 Users Say Thank You to jjtitus098 For This Useful Post: [ View ] Gift jjtitus098 Ad-Free
26th November 2011, 04:11 PM |#4  
orlandoxpolice's Avatar
Senior Member
Thanks Meter: 242

Sent from my SAMSUNG-SGH-I897 using xda premium
The Following 3 Users Say Thank You to orlandoxpolice For This Useful Post: [ View ] Gift orlandoxpolice Ad-Free
26th November 2011, 04:15 PM |#5  
chrisrotolo's Avatar
Senior Member
Flag Corona, CA
Thanks Meter: 469
Donate to Me
Thank You Very Much!!!
The Following User Says Thank You to chrisrotolo For This Useful Post: [ View ] Gift chrisrotolo Ad-Free
26th November 2011, 04:15 PM |#6  
TRusselo's Avatar
Inactive Recognized Developer
Flag Edmonton
Thanks Meter: 2,936
Donate to Me
what does [ITl41D] mean in the title?
Wouldnt [CM9 beta] be more descriptive?

there are already 2 other ICS port threads.
The Following User Says Thank You to TRusselo For This Useful Post: [ View ] Gift TRusselo Ad-Free
26th November 2011, 04:22 PM |#7  
Senior Member
Thanks Meter: 182
The Following User Says Thank You to Gromlakh For This Useful Post: [ View ] Gift Gromlakh Ad-Free
26th November 2011, 04:22 PM |#8  
Thanks Meter: 8
Originally Posted by TRusselo

what does [ITl41D] mean in the title?
I think [CM9 beta] would be more descriptive

It is not Cyanogenmod 9 yet so why would it be a beta. This is no even an alfa of CM9.
The Following 4 Users Say Thank You to malbolgias For This Useful Post: [ View ] Gift malbolgias Ad-Free
26th November 2011, 04:25 PM |#9  
shopealope's Avatar
Senior Member
Flag College Station, TX
Thanks Meter: 32
Donate to Me
I'm definitely going to be flashing this today

Sent from my SGH-I897 using XDA App
The Following 2 Users Say Thank You to shopealope For This Useful Post: [ View ] Gift shopealope Ad-Free
26th November 2011, 04:26 PM |#10  
RichMD's Avatar
Senior Member
Flag CT
Thanks Meter: 775
That was fast! I look forward to trying it once it has some of the major bugs worked out. Thanks to teamhacksung for all the effort to get to this point.

Sent from my SGH-I897 using xda premium
The Following User Says Thank You to RichMD For This Useful Post: [ View ] Gift RichMD Ad-Free
26th November 2011, 04:26 PM |#11  
TheEscapist's Avatar
Senior Member
Flag Toronto
Thanks Meter: 357
Originally Posted by TRusselo

what does [ITl41D] mean in the title?
Wouldnt [CM9 beta] be more descriptive?

there are already 2 other ICS port threads.

Its the build number. All AOSP builds have them.

Additionally, this isn't CM9 yet, it hasn't been merged.
Post Reply Subscribe to Thread

cm9, icecreamhackish, ics, smooth, teamhacksung

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes