Remove All Ads from XDA

[Help needed] French azerty chacha s-offed and qwerty problems

20 posts
Thanks Meter: 2
By riorim, Junior Member on 26th November 2011, 07:43 PM
Post Reply Email Thread
First : hello everybody :)
I've been lurking around here for a long time without taking the time to register..
My primary phone is a nexus1 running CM7, but I recently bought, for work purposes, an Azerty HTC chacha because of its well-made hardware keyboard
I quickly decided to S-OFF it, mainly to be able to root it and remove memory-exhausting bloatware & unneeded apps such facebook etc..
So i got an XTC clip and S-OFFed it successfully, then flashed CWM following the adequate thread, then rooted it.

But I soon realized that the XTC clip had also set my CID to 11111111 (superCID) (previously : HTC__203 which is a French CID) and removed backupCID.
And from that moment, I've completely lost my azerty keyboard!

What I tried so far:

- pressing FN key + space bar and selecting French -> still on qwerty

- getting keyboard layout files / edit manually in /system/usr/.. -> didn't work (still qwerty layout),

- tried changing the CID with "fastboot oem writecid HTC__203" -> chacha fastboot seems to be unable to do that

- tried changing the CID with misc_version (misc_version -c HTC__203 from adb shell or terminal emulator with root permissions) -> didn't work ("error on input file")

I also tried to flash CM 7.1 from the "android developpement" thread but I still got qwerty layout although I selected a French layout on the CM welcome screen.
(I then reflashed to this ROM to come back on a sense ROM)

So, for the moment, my physical-Azerty-but-logical-qwerty chacha is quiete broken for me. I think the point is to succeed in changing back the CID from 11111111 to the french one (HTC__203), but I'm short of solutions so I call for help

Thanks a lot
27th November 2011, 12:02 PM |#2  
OP Junior Member
Flag Lyon
Thanks Meter: 2

I finally managed to get my azerty keyboard back, thanks to this thread:

In case someone needs some precisions:

I took "" from geek78 (huge thanks), extracted it and put the 2 files in /system/usr/keychars and /system/usr/keylayout.
Then I made a chmod 644 (that I had forgeotten before ) , and after reboot, azerty is back

My main problem is now solved
But I'm still stuck on SuperCID so I probably will miss next OTAs and still have problems the day when I need to flash some-coming alternative ROMs such a future stable CM.
Do some of you know a way to restore back the french CID other than "misc_version -c XXX" or "fastboot oem writecid" methods?
13th January 2012, 10:21 PM |#3  
Junior Member
Thanks Meter: 0
I have the same problem than you, riorim.
I wonder how did you made "chmod 644" and where ? Did you used "rootexplorer" and can you explain me the whole process ?
Thanks a lot.
13th January 2012, 11:11 PM |#4  
OP Junior Member
Flag Lyon
Thanks Meter: 2

- open root explorer
- change permission on the 2 files on rw-r--r-- (read/write for user, read only for group and others*)
- reboot and the job should be done :)

(*in the Unix world that means 644. 4=r, 2=w, 1=x. so 6=4+2=rw, and so on)
The Following User Says Thank You to riorim For This Useful Post: [ View ] Gift riorim Ad-Free
14th January 2012, 06:35 AM |#5  
Junior Member
Thanks Meter: 0
Thumbs up

It worked very well so a big thanks tou you riorim, it has been one week I'm on it... :s
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes