FORUMS
Remove All Ads from XDA
Honor 7x
Win an Honor 7X!

[Full Mod + Root + OTA block] Snowball-mod: Full Modification Root [1/6/2012]

267 posts
Thanks Meter: 97
 
By cfoesch, Senior Member on 29th December 2011, 01:18 PM
Post Reply Email Thread
I've been spending a long 3~4 days working on an install process to make applying /system changes quick, easy, painless, and automated. It then occurred to me that I could wrap it into a rooting process, and automate nearly the whole thing, to ensure that people don't accidentally trip up somewhere, and send their Nook Tablet into a bootloop, or lockup, or something like that.

The process was because a number of binaries that are typically standard with CM7 are not included in any of the roots so far. Having them around helps out a lot during development. (Like parted, vim, bash, sqlite3.)

So, I present to you the culmination of my work so far: Snowball-mod (thanks to dj_segfault on IRC for coming up with the name)

This borrows heavily from Indirect's Nook&Zergy root process. He deserves a ton of thanks for setting it all up, and bringing things together, and figuring stuff out. 100 internets to Indirect. (Don't kill me for stealing so much of your process, and .BAT coding wizardry. ... I stand upon the shoulders of giants.)

BIG WARNING:
THIS IS A FULL MOD, IT WILL REMOVE ALL BARNES & NOBLE CONTENT, DO NOT APPLY IT TO SOMEONE ELSE'S NOOK, OR A SHARED NOOK WITHOUT PERMISSION!


They really probably will freak out that their Nook Tablet looks far more like a CyanogenMod7 tablet than a Nook Tablet anymore. Especially, when they can't access their B&N content anymore. Don't say I didn't warn you, the process even warns you itself!

First, install the ADB drivers on your machine as has been explained in various other posts. Snowball-mod will work with Windows, Linux, or Mac. (I have not tried the later two, but if NARS works for you, then Snowball-mod should as well.)

Features:
* Installs extra packages from CM7
* Installs extra commands from CM7
* Installs busybox, with links. (BusyBoxInstaller.apk is also installed so you can update the binaries later, it can also be uninstalled.)
* Installs revcompgeek's hack that makes the soft buttons to always stay on, and the n button works as home, without homecatcher, and without bringing up the bar.
* Uses kenblat's hack to mount into the 12GB data area so you can recover some of that space for your own use. (/data/usrdata hack) It shows up at /mnt/internal (NOTE! Most apps still don't recognize this mount's existence.)
* Optionally, using my own hack, the command "setup-sd-ext" will let you setup a card image that is FAT32 formated, and appears at /mnt/sd-ext, similar to a secondary SD Card. (NOTE! Most apps still don't recognize this mount's existence.)
* Fixes the invisible submenus with white text on a while background
* Automatically applies OTA blocking to change your Version to report as 9.9.9 No further action required on your part to apply this.
* Supports both Windows, Linux and Mac with nearly the same process.
* Sets your browser homepage to "about:blank", and deselects "Remember form data" and "Remember passwords". (I think these are way more sane values.)

Includes:
* ADWLauncher (You can replace it the same as any CM7 install.)
* Android Terminal Emulator
* Button Savior

Needed files for root:
You need drivers first:
http://dl.dropbox.com/u/15069134/usbdrivers.zip

Here is an app to pull up usb debugging menu
http://li362-167.members.linode.com/...s_launcher.apk
Code:
<robertely> Also note, that while that box will remain checked, the setting is not persistant.
<robertely> So you have to flick the top 'Usb Development' box twice to get it working.
Download Link for rooting script:
http://dl.dropbox.com/u/54958574/snowball-mod.zip

Code:
MD5SUM: 7f0090051e6141d6bfeb280355a04b18 *snowball-mod.zip
Instructions to root:

0. Make sure that you have a 1.4.0 Nook Tablet. If you don't, then find one of the posts to recover to 1.4.0, and start from there. The less interference from Barnes & Noble involved the better... they've already done plenty enough.

1. Download the "usbdrivers" zip
2. Download the "snowball-mod.zip"
3. Extract both to a folder C:\ntroot\
4. Now you should see the following files and folders inside c:\ntroot:
5. Run "runmefirst.bat" and follow the instructions.

6a. When the batch file opens the device manager, If you don't see a broken device icon next to "NOOK Tablet" then you may have some other generic drivers taking over. Not sure how to remove them so you will have to move to another PC that has never had a tablet hooked up and start over.

6b. If you do see NOOK Tablet with a broken device icon.. then right click and choose "update driver". Choose "Let me specify where the driver is" and browse to the c:\ntroot\usbdriver folder and hit ok. It should install and you can click "OK" to the warning about unsigned drivers.

7. Run "snowball.bat" and follow the instructions
7a. If you see a long string of numbers/letters it's your device

8. After the rooting process is complete, your nook tablet will reboot, and should start up straight into ADW Launcher.

Want to install your own apps, too?
The rooting scripts will take care of all that needs to be done if you just put your .apk files into the "apks/" directory of the snowball-mod directory. They will be installed automatically at the end of the rooting process.


Should I install this?
I really wouldn't recommend this rooting process for anyone who wants to keep any Barnes and Noble apps on their Nook Tablet. Also, if you've been using your tablet for awhile already, then it might not be a good idea to install this root process as well. It is intended for a clean and fresh Nook Tablet, and I cannot take responsibility for it wiping out something important. You have been warned that this is a drastic full modification.


Instructions to update:

1. Download snowball-update.zip from http://dl.dropbox.com/u/54958574/snowball-update.zip

Code:
MD5SUM 572793e71a0715185e03de4248c09aa2 *snowball-update.zip
2. Extract onto your computer.

3. Plugin your Nook Tablet with USB debugging mode activated

4a. On Windows double click "update.bat"
4b. On Linux/Mac/Cygwin open up a Terminal, cd to the directory, and enter "sh ./update.sh"

5. If you see "INSTALLATION SUCCESSFUL", then it's all done, and updated.

Screenshot

Someone wanted to see a screenshot. Rather than reroot just to get it a silly picture of an empty stock ADW launcher, I just recreated the screen to the best of my ability. The background is weird, I don't think it's scaled right, and for some reason, it's showing up as purple here. But it's just the same blue background as your nook had at the first install.
Attached Thumbnails
Click image for larger version

Name:	snowball-mod-stock.jpg
Views:	4089
Size:	17.9 KB
ID:	843340  
The Following 31 Users Say Thank You to cfoesch For This Useful Post: [ View ] Gift cfoesch Ad-Free
 
 
29th December 2011, 01:20 PM |#2  
OP Senior Member
Flag Albuquerque, NM
Thanks Meter: 97
 
Donate to Me
More
INB4, this steals a lot from Indirect. I know this. You don't have to say it. His root is way better for a minimal rooting experience and keeping the B&N Nook Tablet much the way it is stock, for people who just want to protect sideloading, etc.

This is for people who would rather install a custom ROM. Until then, this is about as close as you will get.


BUGS:

* There seems to be a bug in setup-sd-ext right now. It is not taking into account the "M" in the count. This could be a problem of running the wrong dd. I'm investigating it now. *** RESOLVED WITH v2.0.2 ***

* Nook for Android app won't startup up, not even FCs, it just doesn't start up. This is possibly something to do with the B&N code preventing it from starting up. (internal app name: bn.ereader-1.apk)

* Get rid of the "book" button at the bottom in the status bar: Easy enough, just replace the graphics to get rid of it.

* Move the "adb push ___.zip" to move to /data/local/tmp rather than /mnt/media ... it seems some people are confused, and accidentally leave their device automounted while attempting to install. Moving the push to /data/local/tmp will allow itself to install even when this is done. *** RESOLVED WITH UPDATE TO INSTALL SCRIPTS ***

* adb shell "snowball-ver" seems to be reporting in DOS file format even on linux, which causes a spurious "\r" to end up in the file name. *** RESOLVED WITH UPDATE TO INSTALL SCRIPTS ***

* check to see if the user is already up-to-date, if they are, then report so, and exit out. *** RESOLVED WITH UPDATE TO INSTALL SCRIPTS ***

* detect if something went wrong with installation, and don't report "success" unless it actually did succeed! *** RESOLVED WITH UPDATE TO INSTALL SCRIPTS ***

* ensure that any local $adb in snowball scripts are a+x prior to using them.

* some /bin/sh implementations do not support $OSTYPE. Consider switching to the NARS script version of using "uname -o", as this will likely end up being more universally supported. (Rather than assuming everyone's /bin/sh is bash.)

CHANGELIST

2012-06-01: v2.1.1

* Install script updates to better detect the adb binary, and ensure that it is executable.

* ipctool and viewmem included from the "Basic Hacking Tools" thread

* Reduced snowball-mod size due to removing text-to-speech, wallpapers, and other spurious content. The update process will not remove these, but future versions will continue to not carry these files. This is intended to reduce the size of the binary to decrease the odds of another dropbox shut down for excessive traffic.

* This update is a trivial update and is predominantly only changes to the installer, and a reduction in package size. You do not have to apply this update for any real reason at all, which is good, because it won't be up for a couple days.
The Following 4 Users Say Thank You to cfoesch For This Useful Post: [ View ] Gift cfoesch Ad-Free
29th December 2011, 02:01 PM |#3  
ekennes's Avatar
Member
Thanks Meter: 12
 
More
Very nice, what is the risk of using this on a already rooted and ota blocked tablet, would going back to stock be the best bet? It rooted using the zergy method as well. The instrucstions seem simialar up until running snowball.bat could I just pick it up from there?

Sent from my BNTV250 using xda premium
29th December 2011, 02:05 PM |#4  
OP Senior Member
Flag Albuquerque, NM
Thanks Meter: 97
 
Donate to Me
More
The risks are fairly minimal, but still kind of there. About the biggest one would be clobbering your Browser.apk preferences.

Plus, just like the Nook&Zergy root, you can't run it on a system that is already rooted.

The nook-update-package.zip however in the snowball-mod pack can be extracted, copied to your Nook and executed by hand with a simple "sh install", which will do all the heavy lifting of the process. If you don't want it to wipe your browser preferences then you could delete the "data/data/com.android.browser" directory as well.

It's really barebones, and relies upon the filesystem structure to take care of just about everything.
29th December 2011, 02:13 PM |#5  
ekennes's Avatar
Member
Thanks Meter: 12
 
More
And the sh install is a terminal command correct? I've used Ubuntu so im somewhat familiar with doing things by hand lol

Sent from my BNTV250 using xda premium
29th December 2011, 02:19 PM |#6  
OP Senior Member
Flag Albuquerque, NM
Thanks Meter: 97
 
Donate to Me
More
Yes, indeed the "sh install" is a Terminal command. In fact, I suppose if I say "sh ./install" then it will make sure it only works in the proper directory as well, lol.

Actually, I had been using this method for the process up until yesterday, when I started working the rooting process around it.
29th December 2011, 02:58 PM |#7  
Junior Member
Thanks Meter: 6
 
More
Nice! What version does this work on?
29th December 2011, 03:07 PM |#8  
Senior Member
Thanks Meter: 5
 
More
Do you have any screen shots of this or even a video of how it looks after doing this? Also, just an assumption that the normal 1.4.0 file would take us completely back to stock if we so desired?
29th December 2011, 03:09 PM |#9  
OP Senior Member
Flag Albuquerque, NM
Thanks Meter: 97
 
Donate to Me
More
This only works on 1.4.0

The screen shot is basically just an empty ADW Launcher as if it were just a stock installed CM7, but with the nook status bar.
29th December 2011, 03:36 PM |#10  
Junior Member
Thanks Meter: 6
 
More
Quote:
Originally Posted by cfoesch

This only works on 1.4.0


May I suggest adding that somewhere in the first post?
The Following User Says Thank You to kusje For This Useful Post: [ View ] Gift kusje Ad-Free
29th December 2011, 06:16 PM |#11  
Elmar1801's Avatar
Senior Member
Flag NRW
Thanks Meter: 74
 
Donate to Me
More
Thanks for your work. I tried 3 times and every one looks the same:

Your device is a Nook Tablet meaning we can continue!
Now, just making sure you WANT to root it!
__THIS_WILL_WIPE_ALL_OF_BARNES_AND_NOBLES_STUFF_FR OM_YOUR_NOOK_TABLET__
__DO_NOT_INSTALL_THIS_ON_SOMEONE_ELSES_NOOK_TABLET __
(Y/N)? Y
1441 KB/s (0 bytes in 23056.000s)

[**] Zerg rush - Android 2.2/2.3 local root
[**] (C) 2011 Revolutionary. All rights reserved.

[**] Parts of code from Gingerbreak, (C) 2010-2011 The Android Exploid Crew.

[+] Found a GingerBread ! 0x00015118[*] Scooting ...[*] Sending 149 zerglings ...
[+] Zerglings found a way to enter ! 0x10
[+] Overseer found a path ! 0x000151e0[*] Sending 149 zerglings ...
[+] Zerglings caused crash (good news): 0x40119cd4 0x0054[*] Researching Metabolic Boost ...
[+] Speedlings on the go ! 0xafd193a3 0xafd3908f[*] Popping 24 more zerglings[*] Sending 173 zerglings ...

[+] Rush did it ! It's a GG, man !
[+] Killing ADB and restarting as root... enjoy!
Installing superuser and su...
1817 KB/s (0 bytes in 843503.000s)
1397 KB/s (0 bytes in 22364.000s)
1397 KB/s (0 bytes in 22364.000s)
Installing and setting up busybox...
1780 KB/s (0 bytes in 1994516.001s)
754 KB/s (0 bytes in 12066.000s)
Uploading nook-update-package...
2518 KB/s (0 bytes in 43198793.016s)
Extracting nook-update-package...
Installing nook-update-package...
Installing extra apps...
2868 KB/s (0 bytes in 413129.000s)
2772 KB/s (0 bytes in 1241892.000s)
2031 KB/s (0 bytes in 195032.000s)
Blocking OTAs...
1 KB/s (0 bytes in 1153.001s)
Setting up /data/usrdata...
Rebooting Nook Tablet...

Nothing happens / no reboot. After a manual reset nook stuck on boot.
Any idea?
The Following User Says Thank You to Elmar1801 For This Useful Post: [ View ] Gift Elmar1801 Ad-Free
Post Reply Subscribe to Thread

Tags
ota, root, snowball, systemui, whiteonwhite

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes