Remove All Ads from XDA

{Fix} CG:boot / Flash Failure / Status 7 / sideload/ /

10 posts
Thanks Meter: 2
By mrazwolverine, Junior Member on 1st January 2012, 03:12 AM
Post Reply Email Thread
Timmy10shoes - you are the man.

Over the last few years I have owned a few OG Droids, Droid 2, Droid 3, Droid X, Droid X2, and my Droid Bionic. Never during those years have I been in a pickle like I was with my Bionic, trying to rid myself of some cheesecake. I have traveled from end to end on the world wide web searching for the elusive fix to my nightmare.

Started out like many other days over the last few years of rooting droids, never satisfied always wanting more. I had 4ever root on cheesecake .893 and decided to install the .901 update from a zip. Bingo lost root, don't really use the benefits of root to often, but of course I wanted what I couldn't have. So I decided to use P3's one click and that's when me and my Bionic got to know each other inside and out.

Timmy10shoes your write up and links, were my reason for a happy dance today. Over the last 24 hours I have seen failed RSD flashes, failed updates, failed programs, failed dos commands, failed root, and my favorite - permenant in your face Fastboot screen reminding me of a Failed Flash with the awesome CG:boot error.

Timmy10shoes Original Post:

Thanks to Timmy10shoes, P3, BBB and all others that make tinkering with our big boy toys possible.

Here is a link to my file that fixed all my woes:

Its a zip'd file, 673.58 MB, of all the links in Timmy10shoes original post, with the modifications per hs instructions. Open RSD and point to default_flash_targa.xml and push start in RSD. May others experiences be as good as mine.

Some Errors This Should Fix:

Flash Failure / Invalid CG Version CG; boot

Installing Update...
assert failed: getprop ("ro.product.device") == cdma-targa" ||
getprop ("") == "cdma-targa ||
Error in /sdcard/
(Status 7)
Installation aborted.

Error load file: could not allocate 1397489664 bytes error: connot load grfs.img

No 3g or 4g

flash cdt.bin "cdt.bin" phone returned fail

Error in /tmp/sideload/ (status 7)

and many others

The Following 2 Users Say Thank You to mrazwolverine For This Useful Post: [ View ] Gift mrazwolverine Ad-Free
1st January 2012, 08:29 AM |#2  
Thanks Meter: 0
I get a
"Failed flashing process 1/14 erase cache"

My phone powers up to the
AP Fastboot Flash Mode (S) (Invalid CDT)
Battery OK
OK to Program
Transfer Mode:
USB Connected

Invalid CG Version (CG: cdt)
Invalid CG Version (CG: cdt)

It will not boot to recovery goes strait to Fastboot at power up .Any ideas?
1st January 2012, 08:36 AM |#3  
OP Junior Member
Thanks Meter: 2
I have had success fixing the CDT error with this file from BBB:

Plug your phone in via usb, click on 901fix.bat and it should reboot your phone.
1st January 2012, 08:15 PM |#4  
Thanks Meter: 0
figured out it needed the .901 cdt bin flashed with the help of others here. Now at least I have a working phone but no data. Doh! data back all good now.
4th January 2012, 07:04 PM |#5  
Senior Member
Thanks Meter: 347
Since this is really just a thank you thread I am posting the steps I will be following to update my second bionic from what I found worked consistently after my 14+ hour pathsaver marathon where I got all the errors in the title of the thread. Happy to also share my trial/error if anyone wants it.

Run pathsaver from p3droid with BBB fix2 files to replace default ones
Install 893 and 901 updates from stock recovery by pressing both volume buttons
Normal boot into 901
Rooted 901 = yes = awesome
No rooted 901 = continue on
Run pathsaver again with BBB fix2 files to replace default ones
Install 893 update only from stock recovery by pressing both volume buttons
CDT error on fastboot after 893 install = no = awesome
Normal boot into 893, rota 893 from BBB, reboot into recovery by holding both volume buttons, install 901 update, keep root
CDT error on fastboot after 893 only install = continue on
Manually flash boot.img (from “fastboot images” zip file for “Stock 5.5.1_84_DBN-55” ) and cdt.img (from BBB root fix2) using commands found in BBB post 3 of Invalid CG version thread
- “moto-fastboot flash cdt.bin cdt.901” and “moto-fastboot flash boot boot.img”
*OR flash 893 fxz which will fail at cdt (step 6) then manually flash cdt from BBB root fix2 (this will also clear both CG and CDT errors)
Hold power after flashing both to turn off
Hold power AND both volume buttons when turning on
Normal boot into 893, rota 893 from BBB, reboot into recovery by holding both volume buttons, install 901 update which should keep root

* I found all of the above to work consistently for me (whether it makes sense or not). YMMV
4th January 2012, 09:50 PM |#6  
Senior Member
Flag los angeles
Thanks Meter: 48
Thank you so much mrazwolverine for posting this

You are the saver of my bionic

I was having major problems with p3 1 click to a point that I don't have radio to setup the bionic and stuck at for awhile

Tried every method out there like forever root recover, fastboot files etc and nothing work, until I saw this post

Work like a charm

I do notice that after update from. 893 to. 901 I lost root

So I just went ahead and do it again

After .893 update I use forever root to root and install forever root before I update to. 901 and it kept root this time

So for anyone doing this to update to .901 I highly recommed you to forever root .893 before updating to .901 to keep root

Thanks again mrazwolverine
5th January 2012, 03:07 AM |#7  
OP Junior Member
Thanks Meter: 2
Happy to hear you were able to fix your issues.
9th January 2012, 03:17 AM |#8  
Nismo6921's Avatar
Senior Member
Flag Charleston, SC
Thanks Meter: 40
Talking Thank you!
This restored my phone it came from the factory and that's exactly what I was looking for! I really appreciate you posting this. Extremely useful!!!
9th January 2012, 05:01 AM |#9  
cb7tuner93's Avatar
Senior Member
Flag Y.O Baby
Thanks Meter: 2
How do we do this on a MAC?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes