FORUMS
Remove All Ads from XDA

Media player problems.

283 posts
Thanks Meter: 60
 
By yellowjacket1981, Senior Member on 9th January 2012, 03:16 AM
Post Reply Email Thread
I am having a problem with any media player except the stock one. I want to use a 3rd party media player, so that I don't have to convert my movies to something compatible with the stock media player. the problem is whenever I use a 3rd party media player, I hook the phone to my tv, and the movie plays for a few minutes, then it stops, and loses my place, this is very irritating. This doesn't happen on the the stock media player. Does anyone have any ideas? I have tried at least 6 third party media players, and they all stop every few minutes... For now I am just converting my movies for use with the stock player, but this is time consuming.
 
 
9th January 2012, 05:36 AM |#2  
moe.'s Avatar
Member
Flag richmond
Thanks Meter: 2
 
More
it depends on what app you're trying to use. you might want to see if there's an extra codec pack. i know that mobo player has a lot of add-on codec packs. if this is the case and the dev is smart, the codec packs are usually in the market, just like the original program.

also, you may want to try something with soft decoding included, if you're not already.
9th January 2012, 06:42 AM |#3  
yellowjacket1981's Avatar
OP Senior Member
Flag Tucson, Az
Thanks Meter: 60
 
More
Quote:
Originally Posted by moe.

it depends on what app you're trying to use. you might want to see if there's an extra codec pack. i know that mobo player has a lot of add-on codec packs. if this is the case and the dev is smart, the codec packs are usually in the market, just like the original program.

also, you may want to try something with soft decoding included, if you're not already.

Most of the players had soft decoding, and it isn't a codec pack, the videos play, but suddenly stop. The only one that doesn't do that is the stock one. Has anyone else had this problem? Do you all use the stock player?
9th January 2012, 06:55 AM |#4  
moe.'s Avatar
Member
Flag richmond
Thanks Meter: 2
 
More
does it only do it when using tv out or does it happen on the device screen, also? what rom/kernel are you using?
9th January 2012, 03:54 PM |#5  
Droidmoder's Avatar
Senior Member
Thanks Meter: 87
 
Donate to Me
More
Have you. Tried remote for vlc? I think you can play media on the sd card. Not sure haven't tried it but worth a shot if you haven't.

sent from my ice cream sandwhich MT4GS
9th January 2012, 05:11 PM |#6  
yellowjacket1981's Avatar
OP Senior Member
Flag Tucson, Az
Thanks Meter: 60
 
More
Quote:
Originally Posted by moe.

does it only do it when using tv out or does it happen on the device screen, also? what rom/kernel are you using?

So it seems to only do it when using the tv out function, which is really cruddy, because I don't want to watch movies on my tiny phone, I want to watch them on the big tv. I am using Bulletproof 1.0, and the stock kernel. I am going to try remote for vlc right now, but I am thinking the problem is something to do with the tv out function.
9th January 2012, 06:49 PM |#7  
moe.'s Avatar
Member
Flag richmond
Thanks Meter: 2
 
More
I understand the frustration. My educated guess would have to be that it has something to do with a kernel conflict. Try a different rom and/or kernel. There are, also, some updates for bulletproof now, too.

Sent from my myTouch_4G_Slide using XDA App
9th January 2012, 07:04 PM |#8  
yellowjacket1981's Avatar
OP Senior Member
Flag Tucson, Az
Thanks Meter: 60
 
More
Quote:
Originally Posted by moe.

I understand the frustration. My educated guess would have to be that it has something to do with a kernel conflict. Try a different rom and/or kernel. There are, also, some updates for bulletproof now, too.

Sent from my myTouch_4G_Slide using XDA App

If I remember correctly this happened on other roms too, but I will try again. I tried the new bulletproof, but I liked the old one better. I haven't tried a different kernel though, so I will start flashing different kernel/rom combos, to see if it makes a difference.
9th January 2012, 07:39 PM |#9  
Blue6IX's Avatar
Senior Member
Thanks Meter: 1,144
 
Donate to Me
More
Quote:
Originally Posted by yellowjacket1981

So it seems to only do it when using the tv out function, which is really cruddy, because I don't want to watch movies on my tiny phone, I want to watch them on the big tv. I am using Bulletproof 1.0, and the stock kernel. I am going to try remote for vlc right now, but I am thinking the problem is something to do with the tv out function.

Sorry, I missed this thread. I'm kinda skimming over the boards while i'm doing paperwork and such, so i'm skipping over things and not realizing it. (hate januaries, always so busy)

Anyways, it's a codec issue. You'll only get the problem when outputting to tv - and soft-decoding only solves part of the problem.

What's happening is your file format is too far away from what the hardware can handle easily while it's also trying to feed the video out and keep the screen active on the device.

Even though you check soft-decoding in the app, without proper codecs installed it defaults some or all of the work back to the hardware.

I use Mobo Player, free video app and is hands-down my favorite one on Android. It lets you choose soft-decoding in the settings menu, but they also supply a codec you can find in the market.

I'm using the ARM V7_VFP codec from the same author as Mobo Player, and don't have a problem with it. When I do reflash and forget to install it then it goes back to randomly cutting out while i'm enjoying my movie/show or whatever.

Edit: This Google Market Link will get you to the right codec for our device.

I suppose I should have mentioned something about it in my ROM thread, since I included it in Bulletproof for that reason - but, there's a lot going on here lol.

I should have seen this thread yesterday, but I suppose i'm looking at it the wrong way since I get to skim the forums while i'm getting work done. (as opposed to not being able to browse them at all.)

Anyways, Mobo Player is free, and so is the codec, so all you lose for trying is time - give it a shot and see where it gets ya.

---------- Post added at 02:39 PM ---------- Previous post was at 02:33 PM ----------

Quote:
Originally Posted by moe.

I understand the frustration. My educated guess would have to be that it has something to do with a kernel conflict. Try a different rom and/or kernel. There are, also, some updates for bulletproof now, too.

Sent from my myTouch_4G_Slide using XDA App

Nah, I haven't made any updates to Bulletproof recently, though i'd like to squeeze one out around work soon.
9th January 2012, 09:32 PM |#10  
moe.'s Avatar
Member
Flag richmond
Thanks Meter: 2
 
More
Quote:
Originally Posted by Blue6IX

Sorry, I missed this thread. I'm kinda skimming over the boards while i'm doing paperwork and such, so i'm skipping over things and not realizing it. (hate januaries, always so busy)

Anyways, it's a codec issue. You'll only get the problem when outputting to tv - and soft-decoding only solves part of the problem.

What's happening is your file format is too far away from what the hardware can handle easily while it's also trying to feed the video out and keep the screen active on the device.

Even though you check soft-decoding in the app, without proper codecs installed it defaults some or all of the work back to the hardware.

I use Mobo Player, free video app and is hands-down my favorite one on Android. It lets you choose soft-decoding in the settings menu, but they also supply a codec you can find in the market.

I'm using the ARM V7_VFP codec from the same author as Mobo Player, and don't have a problem with it. When I do reflash and forget to install it then it goes back to randomly cutting out while i'm enjoying my movie/show or whatever.

Edit: This Google Market Link will get you to the right codec for our device.

I suppose I should have mentioned something about it in my ROM thread, since I included it in Bulletproof for that reason - but, there's a lot going on here lol.

I should have seen this thread yesterday, but I suppose i'm looking at it the wrong way since I get to skim the forums while i'm getting work done. (as opposed to not being able to browse them at all.)

Anyways, Mobo Player is free, and so is the codec, so all you lose for trying is time - give it a shot and see where it gets ya.

---------- Post added at 02:39 PM ---------- Previous post was at 02:33 PM ----------



Nah, I haven't made any updates to Bulletproof recently, though i'd like to squeeze one out around work soon.

And another job well done.

Sent from my myTouch_4G_Slide using XDA App
9th January 2012, 11:46 PM |#11  
yellowjacket1981's Avatar
OP Senior Member
Flag Tucson, Az
Thanks Meter: 60
 
More
Quote:
Originally Posted by Blue6IX

Sorry, I missed this thread. I'm kinda skimming over the boards while i'm doing paperwork and such, so i'm skipping over things and not realizing it. (hate januaries, always so busy)

Anyways, it's a codec issue. You'll only get the problem when outputting to tv - and soft-decoding only solves part of the problem.

What's happening is your file format is too far away from what the hardware can handle easily while it's also trying to feed the video out and keep the screen active on the device.

Even though you check soft-decoding in the app, without proper codecs installed it defaults some or all of the work back to the hardware.

I use Mobo Player, free video app and is hands-down my favorite one on Android. It lets you choose soft-decoding in the settings menu, but they also supply a codec you can find in the market.

I'm using the ARM V7_VFP codec from the same author as Mobo Player, and don't have a problem with it. When I do reflash and forget to install it then it goes back to randomly cutting out while i'm enjoying my movie/show or whatever.

Edit: This Google Market Link will get you to the right codec for our device.

I suppose I should have mentioned something about it in my ROM thread, since I included it in Bulletproof for that reason - but, there's a lot going on here lol.

I should have seen this thread yesterday, but I suppose i'm looking at it the wrong way since I get to skim the forums while i'm getting work done. (as opposed to not being able to browse them at all.)

Anyways, Mobo Player is free, and so is the codec, so all you lose for trying is time - give it a shot and see where it gets ya.

---------- Post added at 02:39 PM ---------- Previous post was at 02:33 PM ----------



Nah, I haven't made any updates to Bulletproof recently, though i'd like to squeeze one out around work soon.

Thanks, I am flashing bulletproof 1.1 again, and hoping to get things running well. I will keep you updated. I was running bulletproof 1.0, so I think that was what they were talking about , when they said there was an update.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes