FORUMS

[Solved]Wifi problem with all Motorola Android 2.3.6 rom

4,099 posts
Thanks Meter: 4,673
 
By walter79, Recognized Developer on 17th February 2012, 09:50 PM
Post Reply Email Thread
How can help with this problem?

Code:
 Sending a DHCP renewal

D/WifiStateTracker( 2717): Disable Bluetooth co-ex mode

V/WifiStateTracker( 2717): AutoIP is disabled

D/WifiStateTracker( 2717): DhcpHandler: DHCP request started

E/wpa_supplicant(11431): ERROR - wpa_driver_tista_private_send - error sending Wext private IOCTL to STA driver (ioctl_cmd = 8000305,  drv->errors = 1, errno = 95 - Operation not supported on transport endpoint)

E/wpa_supplicant(11431): ERROR - Failed to handle rx data filter command!

D/WifiStateTracker( 2717): DHCP renewal started
- wifi disconnect on some router every 5-8 min.

- no problem with the same router on Android 2.3.4

- kernel problem?



Solution for this problem

- it is a problem with android >2.3.6
- there is no fix from google

- Change lease time for IP adress at your router from unlimited to 2 weeks or 2 year or 2 month ....
The Following User Says Thank You to walter79 For This Useful Post: [ View ]
17th February 2012, 10:56 PM |#2  
walter79's Avatar
OP Recognized Developer
Thanks Meter: 4,673
 
Donate to Me
More
Question
Code:
 --------- beginning of /dev/log/main
D/alogcat (12049): stopped
D/alogcat (12049): starting ...
--------- beginning of /dev/log/system
W/InputManagerService( 2717): Window already focused, ignoring focus gain of: [email protected]
D/RadioSignalLevel( 3382): Gsm Radio Signal level: 4
D/RadioSignalLevel( 3382): Gsm Radio Signal level: 4
W/InputManagerService( 2717): Window already focused, ignoring focus gain of: [email protected]
D/WifiStateTracker( 2717): Sending a DHCP renewal
D/WifiStateTracker( 2717): Disable Bluetooth co-ex mode
V/WifiStateTracker( 2717): AutoIP is disabled
D/WifiStateTracker( 2717): DhcpHandler: DHCP request started
E/wpa_supplicant(11431): ERROR - wpa_driver_tista_private_send - error sending Wext private IOCTL to STA driver (ioctl_cmd = 8000305,  drv->errors = 1, errno = 95 - Operation not supported on transport endpoint)
E/wpa_supplicant(11431): ERROR - Failed to handle rx data filter command!
D/WifiStateTracker( 2717): DHCP renewal started
I/ActivityManager( 2717): Starting: Intent { act=android.intent.action.MAIN cat=[android.intent.category.HOME] flg=0x10200000 cmp=com.motorola.blur.home/.HomeActivity } from pid 2717
V/alogcat (12049): save instance
V/alogcat (12049): paused
I/ActivityManager( 2717): No longer want com.android.settings (pid 10969): hidden #21
D/battery_widget_monitor(10800): onReceive:Intent { act=android.appwidget.action.APPWIDGET_UPDATE cmp=ccc71.bmw/.lib.bmw_widget (has extras) }
W/battery_widget_monitor(10800): total active Widgets:4
I/ActivityManager( 2717): Resumed Activity: org.jtb.alogcat/.LogActivity totalTime: 182 ms
D/alogcat (12049): stopping ...
W/InputManagerService( 2717): Starting input on non-focused client [email protected] (uid=10099 pid=12049)
D/alogcat (12049): stopped
I/EventLogService( 3514): Aggregate from 1329512002062 (log), 1329512002062 (data)
I/ActivityManager( 2717): Starting: Intent { act=com.motorola.blur.apps.ACTION_APPS flg=0x10200000 cmp=com.motorola.blur.home/com.motorola.blur.apps.AppsActivity (has extras) } from pid 3414
I/ActivityManager( 2717): Displayed com.motorola.blur.home/com.motorola.blur.apps.AppsActivity: +621ms
D/dalvikvm(12049): GC_EXPLICIT freed 902K, 64% free 3238K/8967K, external 2939K/3671K, paused 70ms
I/ActivityManager( 2717): Starting: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=org.jtb.alogcat/.LogActivity } from pid 3414
V/alogcat (12049): started
I/alogcat (12049): new intent: android.intent.action.MAIN
D/alogcat (12049): stopping ...
D/alogcat (12049): canceling periodic saves
V/alogcat (12049): resumed
D/alogcat (12049): starting ...
I/ActivityManager( 2717): Resumed Activity: org.jtb.alogcat/.LogActivity totalTime: 217 ms
W/InputManagerService( 2717): Starting input on non-focused client [email protected] (uid=10141 pid=3414)
W/KeyCharacterMap(12049): Can't open keycharmap file
W/KeyCharacterMap(12049): Error loading keycharmap file '/data/usr/keychars/qtouch-touchscreen.kcm.bin'. hw.keyboards.65537.devname='qtouch-touchscreen'
W/KeyCharacterMap(12049): Can't open keycharmap file
W/KeyCharacterMap(12049): Error loading keycharmap file '/system/usr/keychars/qtouch-touchscreen.kcm.bin'. hw.keyboards.65537.devname='qtouch-touchscreen'
W/KeyCharacterMap(12049): Can't open keycharmap file
W/KeyCharacterMap(12049): Using default keymap: /system/usr/keychars/qwerty.kcm.bin
The Following User Says Thank You to walter79 For This Useful Post: [ View ]
19th February 2012, 11:43 AM |#3  
Junior Member
Thanks Meter: 0
 
More
Hi,

I found this with TPLINK routers (firewalls, etc.). I think the problem is about TPLINK's DHCP server implementation. I have a TPLINK firewall since 6 month ago, and I have this bug too.

TPLINK's DHCP server deamon (and sometimes their client) has some known incompatbility with ISP's DHCP solutions.

Of course, something is changed in 2.3.6 compared to 2.3.4, because same router is perfectly work with older version.

My workaround about this is disabling DHCP: I use manual IP, or use a "wifi profiler", which turns on/off predefined Fix IP on specified WIFI SSID.
I know it is not a perfect solution in foreign places.

I tried to replace dhcp deamon, wifi drivers, wifi configuration files from 2.3.4, but no success. (I am not a linux expert, so maybe I didn't change every dependent modules, etc.)

DHCP bug is allways present, whenever I'am using open, wep and wpa/wpa2 wireless link - if same DHCP server used.

(OFF: However I have another Wifi bug on CM7/MIUI ROMs with WPA2: after some minutes or transferring a few megabytes, the connection will "stuck" - no more dataflow, I have to reconnect.)
20th February 2012, 12:31 PM |#4  
LeopardSurd's Avatar
Senior Member
Flag Cluj-Napoca
Thanks Meter: 165
 
More
Quote:
Originally Posted by walter79

How can help with this problem?


- wifi disconnect on some router every 5-8 min.

- no problem with the same router on Android 2.3.4

- kernel problem?

As a Defy+ user, I'd like to report this bug to official Motorola forum. I've already reported the search bug FC in app drawer. Please tell me how to report.
20th February 2012, 12:59 PM |#5  
walter79's Avatar
OP Recognized Developer
Thanks Meter: 4,673
 
Donate to Me
More
Quote:
Originally Posted by LeopardSurd

As a Defy+ user, I'd like to report this bug to official Motorola forum. I've already reported the search bug FC in app drawer. Please tell me how to report.

Copy the Logfile. For me the problem can find on router from Vodafon. (Vodafon Easybox 803 and 903) This router can only buy with a DSL-contract from Vodafon in germany. Maybe it is a kernel problem. I can`t test v3 kernel from motorola. I use a Android 2.3.4 kernel. I tried all v2 gingerbread kernels.
20th February 2012, 01:16 PM |#6  
LeopardSurd's Avatar
Senior Member
Flag Cluj-Napoca
Thanks Meter: 165
 
More
Quote:
Originally Posted by walter79

Copy the Logfile. For me the problem can find on router from Vodafon. (Vodafon Easybox 803 and 903) This router can only buy with a DSL-contract from Vodafon in germany. Maybe it is a kernel problem. I can`t test v3 kernel from motorola. I use a Android 2.3.4 kernel. I tried all v2 gingerbread kernels.

ok, thanks!
21st February 2012, 11:12 AM |#8  
oSandmaNo's Avatar
Senior Member
Flag Bangalore
Thanks Meter: 505
 
Donate to Me
More
Any way of using CM's WiFi driver on stock ROM?
Cm7 wifi is way faster than stock!
22nd February 2012, 03:56 PM |#9  
walter79's Avatar
OP Recognized Developer
Thanks Meter: 4,673
 
Donate to Me
More
Can someone test to change ip adress lease time from unlimited to 2 weeks. You have to change this in your router
22nd February 2012, 04:50 PM |#10  
cdlq456's Avatar
Senior Member
Thanks Meter: 280
 
More
I found this in the Motorola forums, might help.


https://forums.motorola.com/posts/6808fc89ae
The Following User Says Thank You to cdlq456 For This Useful Post: [ View ] Gift cdlq456 Ad-Free
22nd February 2012, 05:52 PM |#11  
walter79's Avatar
OP Recognized Developer
Thanks Meter: 4,673
 
Donate to Me
More
Quote:
Originally Posted by cdlq456

I found this in the Motorola forums, might help.


https://forums.motorola.com/posts/6808fc89ae

This a different problem. I think only changing router DHCP settings will work.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes