Remove All Ads from XDA
Honor View 10

HTC DUMLOCK - Flash boot from recovery without fastboot! (Updated 2012-02-28 v2)

1,692 posts
Thanks Meter: 12,939
Post Reply Email Thread
HTC Dumlock

HTC Dumlock is a workaround for devices with HTC's unlock that cannot flash boot from recovery. Put simply, we make backups of recovery and boot, then we flash the backup of recovery to boot. When you reboot normally, you'll be in your recovery, but since your recovery is flashed to boot, you can make changes to boot. Head on over to our website for download links and instructions.

New v2 version scans / compares the backups of boot and recovery to help ensure that you don't run it twice and wipe out your backup of boot.
The Following 26 Users Say Thank You to Dees_Troy For This Useful Post: [ View ]
21st February 2012, 09:39 PM |#2  
SolsticeZero's Avatar
Senior Member
Flag Houston
Thanks Meter: 412
Hooray for Team Win! Here's my contribution:
The Following 2 Users Say Thank You to SolsticeZero For This Useful Post: [ View ] Gift SolsticeZero Ad-Free
21st February 2012, 09:40 PM |#3  
guitardoc64's Avatar
Senior Member
Flag Lake Charles,LA
Thanks Meter: 520
Donate to Me
Awesome work guys!

Sent from my Clean and MeanROM 3D
21st February 2012, 09:43 PM |#4  
Senior Member
Flag Nashville
Thanks Meter: 264
Can we flash custom roms with unlocked phone and hboot 1.5 with s-on directly from recovery now?

Edit: Nevermind the answer is yes. you guys are awesome.
21st February 2012, 09:52 PM |#5  
mteezey's Avatar
Senior Member
Flag Detroit
Thanks Meter: 755
this is awesome if i ever get hboot 1.5 again. Wish this was out a week ago i wouldn't of sold my phone so i could buy one with hboot 1.4
21st February 2012, 10:39 PM |#6  
jamexman's Avatar
Senior Member
Thanks Meter: 116
Kernels ok, but are we able to flash radios and such with this method?
21st February 2012, 10:42 PM |#7  
Senior Member
Thanks Meter: 21
I just htc unlocked, flashed the updated twrp via fastboot, then backed up, flashed su, installed HTC DumLock. When I try to use the app it finishes within a minute but does not reboot, rebooting to system reboots doesn't boot into TWRP. I gave the app root permissions, what else should I try?
21st February 2012, 11:33 PM |#8  
budeone's Avatar
Senior Member
Flag Lombard IL
Thanks Meter: 2,041
Real cool news
21st February 2012, 11:37 PM |#9  
elektrik2001's Avatar
Senior Member
Thanks Meter: 8
Thumbs up
This is awesome! Kudos! I'm a little squeamish to try it yet (I'm still android noobish ;) ); I'll wait a bit until the more seasoned folk work the kinks out, but I'm extremely encouraged.

Edit: Changed notification
21st February 2012, 11:58 PM |#10  
benny3's Avatar
Recognized Contributor
Flag Rosommon, MICH
Thanks Meter: 3,548
Donate to Me
i tried twice to flash a kernel and i get is the progress bar sits there, i let it go for 10 minutes each time but it never flashed the zip

UPDATE: I got it i had to restore the backup

Everything went fine for me until i try to boot to system from recovery,it just reboots back to recovery
I even tried powering down and do a normal start and it go's into recovery
22nd February 2012, 12:31 AM |#11  
DomSim's Avatar
Senior Member
Thanks Meter: 207
Can the recovery be made to recognize when it is booted using dumlock app and restore original boot automatically? Something like this,
Run dumlock app, writes recovery to boot but also sets a flag in your config file on the sdcard,
reboot to recovery in boot partition,
recovery sees flag in config file, then before allowing any interaction flashes your boot partition back to original and then allows you to flash away and reboot normal afterwards.
This to me would seem to make it a seemless process. I would think a modification could even be made to CM9 code that would execute the same type of commands to rewrite recovery to boot whenever you select "reboot to recovery" from the reboot menu by holding the power button to make this 100% seemless, no?
Post Reply Subscribe to Thread


Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes