FORUMS
Remove All Ads from XDA

Fastboot cant find device in linux? Try this...

7 posts
Thanks Meter: 24
 
By fizban9, Junior Member on 25th February 2012, 11:43 PM
Post Reply Email Thread
I wanted to post this as a reply to some peoples problems in this thread but the posting rules dont allow me access to development forums.......

I was trying to use fastboot but it kept hanging saying it was waiting for the device.
Quote:

> ./fastboot flash recover recovery-Tiamat-R4c-100611-1150-cwm.img
< waiting for device >

using "fastboot devices" gave me the clue
Quote:

> ./fastboot devices
no permissions fastboot

TO FIX IT: I ran the command as root.
Quote:

> su
> ./fastboot devices
028841444160c3d7 fastboot

and then my device showed up and as root I could continue flashing my Xoom.

Hope this helps someone else.


And completely as a side note, does it take anyone else 20 tries to pass every damn captcha on this site?
The Following 24 Users Say Thank You to fizban9 For This Useful Post: [ View ] Gift fizban9 Ad-Free
 
 
2nd September 2012, 02:38 PM |#2  
Member
Flag Verona
Thanks Meter: 4
 
More
had same problem, used same fix.

thak you for posting an update, most of the user put just solved, without thinking that other people may need the same solution
The Following User Says Thank You to mal93 For This Useful Post: [ View ] Gift mal93 Ad-Free
7th December 2012, 09:20 AM |#3  
Senior Member
Thanks Meter: 8
 
More
thx,

but how can use i fastboot without root ?
7th December 2012, 10:12 AM |#4  
dreamcwli's Avatar
Senior Member
Flag Taipei
Thanks Meter: 773
 
Donate to Me
More
Quote:
Originally Posted by rabiny

thx,

but how can use i fastboot without root ?

You can use udev rules to make fastboot accessible for normal users.
9th December 2012, 12:04 PM |#5  
Senior Member
Flag Cape Town
Thanks Meter: 25
 
More
Quote:
Originally Posted by dreamcwli

You can use udev rules to make fastboot accessible for normal users.

Could you please post a link of this "udev" software? My friend's Xoom updated to 4.0.3 via OTA and he can't get any USB connection recognised by the computer. We've tried everything. It's not rooted and fastboot doesn't work because his bootloader is still locked.
9th December 2012, 04:15 PM |#6  
Senior Member
Thanks Meter: 8
 
More
Quote:

Could you please post a link of this "udev" software? My friend's Xoom updated to 4.0.3 via OTA and he can't get any USB connection recognised by the computer. We've tried everything. It's not rooted and fastboot doesn't work because his bootloader is still locked.

udev is not a software (it is but not like you think)
in this context is just bunch of lines you need to add to file (under linux OS)

see: http://developer.android.com/tools/device.html
and here: http://wiki.cyanogenmod.org/wiki/udev
22nd June 2013, 11:22 PM |#7  
Junior Member
Flag North Jersey
Thanks Meter: 3
 
More
Red face I love you
I have spent 4 hours trying to fix this whole lack of rom on my device thing. You rock.
2nd December 2013, 01:52 PM |#8  
Junior Member
Thanks Meter: 0
 
More
Thumbs up
You are a legend! This solved my problem straight away!
24th September 2014, 06:40 PM |#9  
Junior Member
Thanks Meter: 0
 
More
????????
when i use root (sudo) it just sends me back a reply with like a ton of ?

I type in sudo fastboot devices and i get
????????????????? fastboot

what do i do
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes