Remove All Ads from XDA
Honor View 10

[Q] Can't flash doomkernel, waiting for device

131 posts
Thanks Meter: 19
By juzza87, Senior Member on 4th January 2012, 03:07 PM
Post Reply Email Thread
Hey all,

Just nuked my phone set up so I could install the latest doomkernel (first time wanted to try it out) on my GSM play running latest SE software, but it refuses to flash the boot.img file to the device.

I unlocked (after a re-lock a while ago) the boot loader and can access fastboot (blue LED on phone, "fastboot.exe -i 0x0fce getvar version" brings a version 0.3)

fastboot.exe flash boot boot.img ---> stuck on "< waiting for device >" message

I tried with the latest flashtool and I got this from the log:

05/046/2012 00:46:31 - INFO  - Device connected in fastboot mode
05/046/2012 00:46:42 - INFO  - Selected kernel (boot.img or kernel.sin): C:\boot.img
05/046/2012 00:46:42 - INFO  - Flashing selected kernel
05/046/2012 00:46:43 - INFO  - FASTBOOT Output: 
 sending 'boot' (7330 KB)...
FAILED (remote: The Device must be rooted first)
finished. total time: 0.001s
I then rooted the phone using zergrush and it's rooted properly, but I can't for the life of me figure out why I can't push the kernel, since I know the fastboot process is working because I used it to unlock the boot loader

C:\Users\Access\Downloads>fastboot.exe -i 0x0fce oem unlock 0x
< waiting for device >
                              ... INFOUnlock phone requested
INFOErasing block 0x00000d00
INFOErasing block 0x00000e00
INFOErasing block 0x00000f00
Is there something I'm missing or will I never be able to have a custom kernel?

Any ideas and suggestions appreciated thanks
1st March 2012, 04:55 AM |#2  
Junior Member
Thanks Meter: 0
I have the exact same problem with my Arc S, can`t figure out why is getting stuck on "< waiting for device >"
1st March 2012, 07:21 AM |#3  
Michealtbh's Avatar
Senior Member
Flag Belfast
Thanks Meter: 855
Try fastboot -i 0x0fce flash boot boot.img
The Following User Says Thank You to Michealtbh For This Useful Post: [ View ] Gift Michealtbh Ad-Free
1st March 2012, 12:16 PM |#4  
Junior Member
Thanks Meter: 0
Originally Posted by Michealtbh

Try fastboot -i 0x0fce flash boot boot.img

Thx alot man, it worked like a charm !

C:\Android>fastboot.exe -i 0x0fce getvar version
version: 0.3
finished. total time: 0.001s

C:\Android>fastboot -i 0x0fce flash boot boot.img
      sending 'boot' (7922 KB)... INFOUSB download speed was 9187kB/s
OKAY [  0.892s]
                writing 'boot'... INFODownload buffer format: boot IMG
INFOFlash of partition 'boot' requested
INFOS1 partID 0x00000003, block 0x00000280-0x000002e3
INFOErase operation complete, 0 bad blocks encountered
INFOFlash operation complete
OKAY [  1.532s]
finished. total time: 2.424s
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes