Remove All Ads from XDA

[Q] ODin is ALWAYS stuck in 'SetupConnection' no matter what.

484 posts
Thanks Meter: 135
By leijonasisu, Senior Member on 28th February 2012, 03:47 PM
Post Reply Email Thread
I have tried everything on my wife's I9001 but I cannot get Odin to get past SetupConnection.

Here is a picture:

I have tried:

Redownloading Odin 1.3 and 1.85 and also tried using Multi Downloader 4. (Which says that the .md5 file isn't supported).
Changing USB ports.
Using a Jig to boot Download mode.
Booting into Download mode normally.
Installing MobileODin except that I9001 is not supported.
Trying to flash a different rom other than 'I9001XXKQ1_I9001XXKPI_I9001DBTKP1_HOME.tar.md5'
Rebooting the computer over 9000 times.
Rebooting the phone over 9000 times.
Pulling the battery over 9000 times.
Reinstalling the drivers from Kies.
Turning USB Debugging mode off (was worth a try)
Using a different computer.
Reinstalling my OS (seriously, I had to do that anyway)
Leaving the phone plugged in for 30 minutes anyway just to see if it was working but not updating.

I am unable to boot into 'Recovery Mode' also the phone sh!ts itself and boots into 'RAM Dump' instead... where it requires a battery pull to reboot. So I can't even put the rom file on the internal memory and use recovery mode to flash it from there...

Basically nothing works at all. Odin 1.35 fails, Odin 1.85 fails, Multidownloader fails. I have tried rebooting, restart, and re-bloody everything I can. I have no idea why it won't get past setup connection. I've even tried using my second USB cable. It used to work fine, I used to be able to flash the phone fine.

Kies is NOT running in the background... there are no processes open or anything. I have googled and yahooed and everything to find a solution to this. NOTHING works..

Please help. I need to flash this dhfshfgdshgfshs phone as soon as possible. It's not working properly and it's really unstable..
If someone has any suggestions I am so willing to hear them..

Thanks a lot. - From a really frustrated dude
29th February 2012, 08:34 AM |#2  
Romino_'s Avatar
Junior Member
Thanks Meter: 2
Originally Posted by leijonasisu

I have tried everything on my wife's I9001 but I cannot get Odin to get past SetupConnection.

When you booted your phone, are you REALLY sure that you go into Download-mode?

When i was doing the same thing as you, i just enter Android Recovery (pressed Home+Vol Up+Power instead of pressing Home-Vol DOWN+Power)

Im not sure what buttons on your phone because im having a Note.

If you find this helpful, you could click Thanks
The Following 2 Users Say Thank You to Romino_ For This Useful Post: [ View ] Gift Romino_ Ad-Free
29th February 2012, 08:47 AM |#3  
leijonasisu's Avatar
OP Senior Member
Thanks Meter: 135
Thanks mate but I worked it all out. For some reason my I9001 wasn't being flashed in Odin properly like I explained. I accidentally screwed up my download mode. Sometimes I could get into Download mode by holding the corresponding keys. Volume Down + Home + Power. Sometimes the phone would just go black with a white dot at the top left corner.

Using a Jig I was able to boot into download mode without hassle. I then used Multi Flasher 4 to flash my phone seeing as no matter what Odin 1.85 and 1.3 would not work.

After that I did a factory reset so the phone was basically flashed twice. Everything seems to work well now. Before the factory reset the phone would just get into a boot loop.

Thanks anything. FeMod or whatever the clockworkmod for the I9001 is, wasn't working either. It would just go blank when I chose an option.

It's ok now. Thanks anyway but this can be closed.
3rd February 2013, 03:07 AM |#4  
Junior Member
Thanks Meter: 5
Make sure Kies is not running. That was preventing me from connecting.
The Following 5 Users Say Thank You to edwin_chenyh For This Useful Post: [ View ] Gift edwin_chenyh Ad-Free
27th February 2013, 04:18 PM |#5  
Junior Member
Thanks Meter: 1
Odin and xdadevelopers suck
Odin is buggy. Works on and off.
xda sucks because the owners of the site will have a single applicatoins dependencies spread across as many pages as possible in order to increase views and click through rates and sell ads to say, Bell Telecom perhaps?
F*n dicks at xda far as I'm concerned.
Wasting everyone's time and polluting the search results space.
10th March 2013, 02:05 PM |#6  
Junior Member
Thanks Meter: 1
just do that
just enable usb debbuging
The Following User Says Thank You to samiz82 For This Useful Post: [ View ] Gift samiz82 Ad-Free
12th May 2014, 12:58 AM |#7  
Junior Member
Thanks Meter: 0
Smile thanks
Originally Posted by edwin_chenyh

Make sure Kies is not running. That was preventing me from connecting.

Thank you alot bro. i was searching problem about half a year. you saved my life
18th June 2014, 02:19 PM |#8  
Thanks Meter: 1
I have the same issue with my Samsung Galaxy s2 (GT-i9100).

- Yes, Its really in download mode
- Have tried alot of diffrent versions of odin

My phone suddenly stopped working, can't start recovery and it doesnt boot at all.
The only thing I can do with it now is to enter download mode.
I might have flash something bad... dont really remember at all.
Had kies installed both the first version and klies3, all uninstalled now without any change...
29th September 2014, 06:04 PM |#9  
Junior Member
Thanks Meter: 0
Talking THX
you're great, thank you very much bro : Iyi:: Iyi:: Iyi:
Post Reply Subscribe to Thread

download mode, odin, stuck, stuck at setup connection

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes