Remove All Ads from XDA

[Q] Problem while downgrading Desire Z

12 posts
Thanks Meter: 0
By ammm84, Junior Member on 4th March 2012, 11:03 PM
Post Reply Email Thread
6th March 2012, 10:59 PM |#21  
Thanks Meter: 18
Try and install the ES File Explorer from the Market. Open it and by pressing menu>Settings
Scroll down to Root settings and select root explorer function, after that, allow root acces, asked by superuser and select Mount File System
Scroll up to Path Settings and select Up to Root
Go back to the File Explorer (which should be at /sdcard/) and press Up
Open up adb and redo the code like this:
adb shell
su -
cd /system/usr/
chmod -R 777 keylayout
(in this way you make sure the system folder is mounted read/write while you're executing the adb shell)

also the -r schould have been -R, my bad.. sorry
Then you can alter the necessary files with ES File Explorer, by opening them as text and add those lines and remove the #

You can save the file with menu>Save

If that worked, reboot your phone and your trackpad should be working again.
If it doesn't you can try to alter the other *.kl files.
6th March 2012, 11:45 PM |#22  
Junior Member
Thanks Meter: 0
Red face
Originally Posted by lineaira

I don't mind questions , besides, stupid questions don't exist, only stupid answers.

just follow it by heart and don't panic if you do not understand something. If you just copy paste the commands all should go well.
After that use the links I posted in my previous post for rooting..

ThankQ... already downgraded!
7th March 2012, 02:32 AM |#23  
Junior Member
Thanks Meter: 0
Originally Posted by lineaira

and change again.

Follow for Desire Z (only from Froyo or Gingerbread, but as you said you're on Froyo already) this tutorial to install HBOOT and gain root:

hi i already try until this step.. but.. when enter into recovery / factory reset
it jump to ClockworkMod then.. when i click for any selection like full wipe or else...

my ClockworkMod look like freezing.. did i do any mistake here?
7th March 2012, 02:49 AM |#24  
Nipqer's Avatar
Senior Member
Thanks Meter: 394
Your probably using the power button to select, don't
Use the trackpad or camera button.

7th March 2012, 03:52 AM |#25  
Junior Member
Thanks Meter: 0
Originally Posted by Nipqer

Your probably using the power button to select, don't
Use the trackpad or camera button.


thank you.. but.. yes im using power button to select.. but after select only appear circle icon (ClockWork background icon)

then it freezing... when i press power button back.. it turn back to menu.. when i choose the menu same thing happen.. it freezing with clockwork background ..

7th March 2012, 04:45 AM |#26  
Nipqer's Avatar
Senior Member
Thanks Meter: 394
So use the camera button. Don't ever use power button in recovery.

7th March 2012, 07:16 AM |#27  
Thanks Meter: 18
Originally Posted by syaiful_86

hi i already try until this step.. but.. when enter into recovery / factory reset
it jump to ClockworkMod then.. when i click for any selection like full wipe or else...

my ClockworkMod look like freezing.. did i do any mistake here?

Or try to flash this recovery, it's clockworkmod with full touch support, powerbutton in this one is back button:

Put the img in your fastboot folder on your pc, rename it to recovery.img and turn off your phone.
Start your phone by holding volume down and power together, it starts in HBOOT.
Select FASTBOOT, using your volume keys and confirm with the power button. (and connect your phone to your computer by usb, obviously)
If fastboot has started you can open an cmd window on your pc.
cd the folder where your fastboot.exe and recovery.img are.
then type in the cmd:
fastboot flash recovery recovery.img
If this is done, select BOOTLOADER on your phone using the volume keys, confirm with power.
Then select RECOVERY and it loads the new ClockworkMod recovery.
You can now select things by just pressing them, power button is back to previous menu.
7th March 2012, 08:52 AM |#28  
Nipqer's Avatar
Senior Member
Thanks Meter: 394
Yup that'll also work, so long as you have the eng hboot.

7th March 2012, 02:41 PM |#29  
OP Junior Member
Thanks Meter: 0
Hi friends,

I'm not able to get the trackpad working. I have modified all the .kl to add the trackpad keys. Here I show one of them:
key 116   POWER             WAKE_DROPPED
key 107   ENDCALL           WAKE_DROPPED

# column 0
key 185   USER3            WAKE_DROPPED
key 100   ALT_RIGHT         WAKE_DROPPED
key 217   SEARCH            WAKE_DROPPED
key 28    ENTER             WAKE_DROPPED
key 38    L                 WAKE_DROPPED
key 14    DEL               WAKE_DROPPED

# column 1
key 184   USER2            WAKE_DROPPED
key 50    M                 WAKE_DROPPED
key 214   QUECHAR           WAKE_DROPPED
key 37    K                 WAKE_DROPPED
key 24    O                 WAKE_DROPPED
key 25    P                 WAKE_DROPPED

# column 2
key 52    PERIOD            WAKE_DROPPED
key 49    N                 WAKE_DROPPED
key 35    H                 WAKE_DROPPED
key 36    J                 WAKE_DROPPED
key 23    I                 WAKE_DROPPED
key 22    U                 WAKE_DROPPED

# column 3
key 57    SPACE             WAKE_DROPPED
key 47    V                 WAKE_DROPPED
key 48    B                 WAKE_DROPPED
key 34    G                 WAKE_DROPPED
key 20    T                 WAKE_DROPPED
key 21    Y                 WAKE_DROPPED

# column 4
key 51    COMMA             WAKE_DROPPED
key 46    C                 WAKE_DROPPED
key 32    D                 WAKE_DROPPED
key 33    F                 WAKE_DROPPED
key 19    R                 WAKE_DROPPED
key 18    E                 WAKE_DROPPED

# column 5
key 183   USER1            WAKE_DROPPED
key 44    Z                 WAKE_DROPPED
key 45    X                 WAKE_DROPPED
key 31    S                 WAKE_DROPPED
key 30    A                 WAKE_DROPPED
key 17    W WAKE_DROPPED

# column 6
key 42    SHIFT_LEFT        WAKE_DROPPED
key 56    ALT_LEFT          WAKE_DROPPED
key 139   MENU              WAKE_DROPPED
key 150   FUNC_3            WAKE_DROPPED
key 215   AT            WAKE_DROPPED
key 16    Q WAKE_DROPPED

key 114   VOLUME_DOWN       WAKE
key 115   VOLUME_UP         WAKE

key 211   FOCUS
key 212   CAMERA
key 158   BACK
key 102   HOME

key 2     1
key 3     2
key 4     3
key 5     4
key 6     5
key 7     6
key 8     7
key 9     8
key 10    9
key 11    0

key 108   DPAD_DOWN         WAKE_DROPPED
key 103   DPAD_UP           WAKE_DROPPED
key 105   DPAD_LEFT         WAKE_DROPPED
key 106   DPAD_RIGHT        WAKE_DROPPED

# not use in vison
# key 12    MINUS             WAKE_DROPPED
# key 13    EQUALS            WAKE_DROPPED
# key 39    SEMICOLON         WAKE_DROPPED
# key 40    APOSTROPHE        WAKE_DROPPED
# key 43    BACKSLASH         WAKE_DROPPED
# key 53    SLASH             WAKE_DROPPED
# key 54    SHIFT_RIGHT       WAKE
# key 59    MENU              WAKE_DROPPED
# key 60    SOFT_RIGHT        WAKE
# key 61    CALL              WAKE_DROPPED
# key 62    ENDCALL           WAKE_DROPPED
# key 68    F10               WAKE_DROPPED
# key 87    F11               WAKE_DROPPED
# key 107   ENDCALL           WAKE_DROPPED
# key 116   POWER             WAKE
# key 127   SEARCH            WAKE_DROPPED
# key 155   ENVELOPE          WAKE_DROPPED
# key 189   FUNC_7            WAKE_DROPPED
# key 223   CANCEL            WAKE_DROPPED
# key 227   STAR
# key 228   POUND             WAKE_DROPPED
# key 229   MENU              WAKE_DROPPED
# key 230   SOFT_RIGHT        WAKE
# key 231   CALL              WAKE_DROPPED
# key 399   GRAVE
I have restarted the phone, but still doesn't work. However, pushing the trackpad works fine (also do it before modifying kls)

Any idea?
Thanks for all!
7th March 2012, 05:13 PM |#30  
Thanks Meter: 18
Can you boot your phone while doing logcat and write it to a file, so you can post it here, I'd really like to know witch kls your rom loads.

Here's how:
Open a cmd window and cd your platform-tools folder on your pc (the folder adb is in)
Type the following in the cmd window and hit enter
adb logcat > logcat.txt
(If you want to actually see what's happening, open up a second cmd window, place them next to each other and cd the platform-tools in there as well. Then type the following and hit enter:
adb logcat

The cmd window(s) will tell you it's (or they are) -waiting for device-
Power on your phone and quickly connect the USB cable.
In the second cmd screen you can check if something is running.
Wait until your phone is fully booted and unplug the USB cable, by doing so, both cmd windows will stop doing something and come back with the folder you issued the commands at.

If you go to the platform-tools folder now, in explorer, then there should be a file there called logcat.txt
If you want to post it here, I can tell you which kl files are used in your rom during boot.

I'm afraid that, if all these modifications don't work, you should try another rom. If it then still doesn't work... Then your trackpad might be broken, but I don't want to say that out loud, cause there might be more hope than disappointment. Btw, wich rom are you running??

Sent from my HTC Vision using XDA
7th March 2012, 11:01 PM |#31  
OP Junior Member
Thanks Meter: 0
I have done te log:
I/EventHub( 1301): New device: path=/dev/input/event6 name=lightsensor-level id=0x10002 (of 0x3) index=3 fd=56 classes=0x0

I/SystemServer( 1301): Bluetooth Service

I/EventHub( 1301): New keyboard: device->id=0x10003 devname='vision-keypad-esn' propName='hw.keyboards.65539.devname' keylayout='/system/usr/keylayout/vision-keypad-esn.kl'

I/EventHub( 1301): New device: path=/dev/input/event5 name=vision-keypad-esn id=0x10003 (of 0x4) index=4 fd=58 classes=0x3

I/EventHub( 1301): New device: path=/dev/input/event4 name=proximity id=0x10004 (of 0x5) index=5 fd=59 classes=0x0

I/EventHub( 1301): New device: path=/dev/input/event3 name=atmel-touchscreen id=0x10005 (of 0x6) index=6 fd=60 classes=0x14

I/EventHub( 1301): New keyboard: device->id=0x10006 devname='projector-Keypad' propName='hw.keyboards.65542.devname' keylayout='/system/usr/keylayout/qwerty.kl'

I/EventHub( 1301): New device: path=/dev/input/event2 name=projector-Keypad id=0x10006 (of 0x7) index=7 fd=61 classes=0x1

I/EventHub( 1301): New device: path=/dev/input/event1 name=projector_input id=0x10007 (of 0x8) index=8 fd=70 classes=0x4

I/EventHub( 1301): New keyboard: device->id=0x10008 devname='h2w headset' propName='hw.keyboards.65544.devname' keylayout='/system/usr/keylayout/h2w_headset.kl'

I/EventHub( 1301): New device: path=/dev/input/event0 name=h2w headset id=0x10008 (of 0x9) index=9 fd=71 classes=0x1

I/KeyInputQueue( 1301): Device added: id=0x10008, name=h2w headset, classes=1

I/KeyInputQueue( 1301): Device added: id=0x10007, name=projector_input, classes=4

I/KeyInputQueue( 1301):   X: min=0 max=480 flat=0 fuzz=0
I think that lines are enought. qwerty.kl and vision-keypad-esn.kl are the files of interest. Isn't it? Must the h2w_headset.kl must be modified too? Appears to be the calling profile.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes