Remove All Ads from XDA
Honor 9 Lite

[USB Drivers] Galaxy S GT-I9000 (Working on ICS)

164 posts
Thanks Meter: 41
By METEMEDO, Senior Member on 12th March 2012, 08:16 AM
Post Reply Email Thread

And bacon and spam:
I've recently upgraded my SGS to ICS (ICSSGS ROM) and started to develop a simple application.
So, now i've got to the point that the emulator starts to show its limitations, so i need to debug directly on the real device.
Well, i've been trying to make ADB recognize my phone, tried several usb drivers from several sites, none of them worked.
After several hours spanking windows, it's finally working (yes! almost 6 AM in the morning!).

What matters:
So, to anybody who have the same problem as i had, do the following:

0. Uninstall any drivers that you've tried before.

1. Extract the zip file that i've uploaded to anywhere you like.

2. Enable debugging on your phone and connect it to PC throught the USB cable
(Just connect it, don't mount)

3. On your computer, click Start -> Right click on "Computer" -> Manage
This will open the "Computer Management" window (it might take some seconds to load).

4. Click "Device Manager". Now you should find your device in the list. It must be really easy to find. It's called something like "GT-I9000" or "GalaxyS" and it has a yellow warning sign next to it.

5. Right click on it and choose "Update Driver Software". In the window that appears, choose "Browse my computer for driver software". It then asks you where is the driver.

6. Click the "Browse" button and choose the folder you extracted from my zip file.
(If you didn't change it, it must be called "Android Composite ADB Interface")

7. Click "Next" and cross your fingers. If you're lucky, it may work for you.

Final notes:
1. I'm not responsible for ANYTHING. Whatever you do, it's your own choise to do it. I guarantee absolutely nothing.
2. This is was tested on Windows 7 - 64 bits with Team ICSSGS RC4.2 ROM and Semaphore ICS 0.9.1 Kernel.
3. Have fun.
4. If you try this, please answer the topic and tell everybody if it's working for you (mentioning your Windows version and what ROM you use).

Driver file:
The Following 5 Users Say Thank You to METEMEDO For This Useful Post: [ View ] Gift METEMEDO Ad-Free
15th March 2012, 02:31 PM |#2  
Junior Member
Thanks Meter: 0
Missing file when installing driver on windows 7 x64

I have recently installed the most recent Dark Knight ICS 4.0.4 build to my Samsung Galaxy S. The ROM seems very good but I'm an android app developer and need to be able to debug my applications on the device via USB.

I have tried the driver provided in the thread which won't install due to a missing file according to the Windows 7 x64 driver install wizard. The exact message is displayed after step 7 and says:

"Windows found driver software for your device but encountered an error while attempting to install it."

"Android Composite ADB interface"

"The system cannot find the file specified".

Is there a file missing in the package? Has anybody managed to get this driver working?


15th March 2012, 09:22 PM |#3  
OP Senior Member
Thanks Meter: 41
Does it say that it doesn't find a controller or that is there a missing file?

Anyway, please try this installer and let me know if it works for you:
17th March 2012, 11:54 PM |#4  
Senior Member
Thanks Meter: 393
What's wrong with the Nexus S drivers available with Android SDK?

Google USB driver, R4

The SGS will present it self like that when it is running ICS/CM7/CM9.

Sent from my GT-I9000
22nd March 2012, 11:23 PM |#5  
JusthaveFun's Avatar
Junior Member
Flag Vienna
Thanks Meter: 0
Originally Posted by METEMEDO

Does it say that it doesn't find a controller or that is there a missing file?

Anyway, please try this installer and let me know if it works for you:

Dont work for me.

System: Windows 7 x64
Android 4.04 Dark Knight

Nevertheless thanks for your approach. I'll test if it works with the SDK Updater.
23rd March 2012, 02:07 PM |#6  
OP Senior Member
Thanks Meter: 41
I'm going to test in my desktop this weekend to check if it works with it.
23rd March 2012, 09:47 PM |#7  
Junior Member
Thanks Meter: 0
I have the same problem, but with WIndows 7 32 bit. Drivers from discusion doesn't work. Don't you have some for 32 bit?

I found SDK Components on, where is Android driver which suppose to work, but unfortunately ODIN still do not see phone.
25th March 2012, 10:02 PM |#8  
bestjsg's Avatar
Senior Member
Flag Toronto, Ontario
Thanks Meter: 2
I also have the same problem but mine is worse because my phone is completely down after I tried to restore from a GB ndriod backup failure , phone won't boot , cannot boot into recovery only in download mode but no way my 4 x computers would detect the phone now ....tried using heimdall in linux as well as sdb, no

Sent from my Dell Streak using XDA
1st April 2012, 01:38 PM |#9  
Junior Member
Flag Jyväskylä
Thanks Meter: 2
Using Google USB drivers finally worked for me. They can be optionally installed with Android SDK using SDK manager (extras). After installation drivers can be found in <sdk>\extras\google\usb_driver.

Just follow the instructions in the first post to find your device from device manager with exclamation mark. Need at least one reboot to work and I also redirected the driver installation process to Google usb driver directory but now ADB finally recognizes my SGS (MyICS, Android 4.0.3).

Edit: Operating system Vista 64-bit

[Currently stuck in "error: device not found" while trying adb push -command. I will update if I find a workaround. Probably something to do with inf-file.]

For alternate .inf -file (optional):

Google "usb-drivers-not-working-after-flash-latest-rom-ota" and see post #12 to see alternative inf-file. Some have managed to make adb recognize the device with that file, but I have at least this far been unsuccessful.

Edit: Problem above was caused by me being stupid and trying to use push in shell, which caused phone unable to locate host system folders. I don't know if that inf file has anything to do with drivers working now, but go ahead and try it if doesn't work with the original .inf
The Following User Says Thank You to RazorNova For This Useful Post: [ View ] Gift RazorNova Ad-Free
12th April 2012, 03:34 PM |#10  
Thanks Meter: 12
I got my i9000 recognized using the latest drives from the Google sdk
14th April 2012, 12:17 PM |#11  
Junior Member
Thanks Meter: 0
That‘s great
Post Reply Subscribe to Thread

drivers, galaxy s, i9000, usb

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes