Remove All Ads from XDA

[Q] Tried Heimdall One-Click. Never finished, now USB won't recognize. Bricked phone?

24 posts
Thanks Meter: 0
By NateTheGreatt, Junior Member on 20th March 2012, 12:56 AM
Post Reply Email Thread
26th March 2012, 03:36 AM |#11  
bradbusa's Avatar
Senior Member
Thanks Meter: 59
just wanted to chime in here and verify. had a similar problem with odin not working after using heimdall.. used another usb port and odin now sees my infuse.. no problems. thanks guys
28th March 2012, 10:03 PM |#12  
dde333's Avatar
Flag Atlanta
Thanks Meter: 96
Also, wanna say that, for some reason, I had better luck using different version of Odin. Can't remember exactly but I think 1.7 worked & 1.8 didn't - not at PC right now to verify.

Sent from my SAMSUNG-SGH-I997 using XDA
29th March 2012, 03:33 AM |#13  
Retired Recognized Developer
Thanks Meter: 4,511
once you install zadig...driver installation for heimdall, it takes over that 1 port.
you can always go back to that 1 port or designate it for heimdall.
odin will not be usable for that port unless you re install samsung drivers again.

I have an (old -6yrs) pc with 1 usb same cord ($1) and 1 usb back port...same 1 for 6 months with heimdall - never had to mess with anything else...successful restore everytime...
use what you're comfortable with.
save that 1 configuration as your rescue if possible.
8th July 2013, 08:54 AM |#14  
Junior Member
Thanks Meter: 4
Unhappy This topic was as close as I could find to my issue... Heimdall One-Click Kernel...
First of all, let me say that I appreciate all the work everyone has done on the Infuse forums. It has expanded my knowledge by leaps and bounds just by reading for about 5 hours today. I know this will be a long post, and I apologize. I am just trying to show that I have done everything (so far) that is within my ability to try.

I inherited a "mostly working" (sound doesn't work at all) AT&T Infuse 4G, and am trying to install CWM and root the bugger in order to use it on WiFi as a mini tablet. I Do Not have a SIM card for it (I am on SIMple Mobile, not AT&T), and do not plan to use it for calls (already have a phone for that). It was already running UCLB3, but I wasn't sure if that was how the phone came, or if it had been upgraded from Froyo at some point with or without the bootloaders. I had planned to play with this phone some and maybe try out some Jelly Bean since my T-Mobile G2x has lost most of the wonderful devs that it had.

First, I used the Settings>Privacy>Factory Data Reset to clear all the information on my phone and my internal SD card. I made sure that Java was the latest version on my laptop and DL'd qkster's [ROM] [2.3.6] Heimdall One-click Back-To-Stock UCLB3. I spent the next 2 hours reading and re-reading the OP and all the resulting posts to make sure I had a firm grasp on how to do everything. I first booted into stock Recovery and did another Factory Reset from there and also cleared Cache. I booted into Download mode on the Infuse 4G and ran Heimdall One-Click. Installed the Heimdall driver, closed all programs, rebooted the computer, went back into Heimdall One-Click, put the phone back into Download mode, clicked Flash, waited for phone to reboot, turned phone off, went back into Download mode and flashed again, this time with BL checked.

This entire process went off without a hitch. Phone boots into GB and all is glittery gold. It's when I come to the next step in the thread that I started having the issue. Again, from an overabundance of caution, I made sure that I read the thread again, absorbing all the information pertinent to loading the Kernels from One-Click. Deciding to try InfuZen-A16 Kernel, I downloaded it and ran it just as I had the previous One-Click. Opened the .jar, booted the phone to Download mode, clicked Flash, and let the phone reboot. Uh oh. Samsung splash screen is staying on my screen now...

Maybe it just needs a while to process. Left the phone plugged in so it wouldn't lose too much battery life and went and did some more reading on the forums. 5 minutes, still Samsung screen. 10 minutes, still Samsung... No biggie, I'll just read some more. Maybe this is just a longer process than I thought. 30 minutes later, still Samsung. Okay, something must be wrong... Hold down power button to shut it off. 3 minutes holding button, still on. Battery pull...

3-button workout for recovery... Nope, no such luck, still showing the persistent Samsung screen. Back to Heimdall One-Click for recovery to UCBL3. That works. Back into stock recovery. Again, Factory Reset, clear Cache. Download mode, try again. Flash InfuZen-A16 Kernel a couple more times (flashing back to Stock between attempts), using a different USB cable and different USB ports, but still same thing each time, leaving the phone for at least 15 minutes on the Samsung splash screen to see if it moves anywhere. I then tried the ENTROPY512's 4.4.2012 kernel, hoping for different results. Same thing. Tried it 2 more times with different cables and different ports. Each time that I flashed back to Stock, it worked on each USB port and cable I was trying, so I don't "think" it could be the cables or the ports that are causing the issue.

Any help is greatly appreciated. It is my understanding that to get root on UCLB3 and above, I need to have CWM installed, but other than Heimdall One-Click Kernels, the only way to get CWM on a phone is by having it already Rooted. If I am erroneous in this understanding, please point it out and I will happily do my due diligence to fix my own problem.

Thanks in advance for any help anyone gives me.
8th July 2013, 06:00 PM |#15  
Zen Arcade's Avatar
Senior Member
Haddonfield, IL
Thanks Meter: 3,437
The custom GB kernels for infuse start a file system conversion immediately upon reboot (from rfs to ext4). If your sound was working, you would hear a robotic female voice providing status updates. This process typically takes no more than 20 minutes to complete, usually less.

If the phone is just sitting there at a samsung logo, try leaving it longer to see if it completes and boots the phone OS.

If it still doesn't work, try the jscott30 Odin package instead:
Here are the custom kernels in Odin packages:

IMPORTANT: If you try Odin, use a different USB port than the one you set up for Heimdall. Reserve the Heimdall port for only Heimdall flashing.

For Heimdall, make sure you are using this one (kernels in posts 2 & 3):
(looks like you are based on the files you referenced above)

Regardless, make sure your USB connection is 100% reliable and you do not interrupt the flashing process - otherwise you may brick the phone.
The Following 2 Users Say Thank You to Zen Arcade For This Useful Post: [ View ] Gift Zen Arcade Ad-Free
8th July 2013, 11:28 PM |#16  
Junior Member
Thanks Meter: 4
Thanks for the reply, Zen. I'll try it again when I get home and just let it run for at least an hour.
I have a minor aversion to using Odin, just because it is closed source as opposed to open source for Heimdall. I will take it under advisement, though.
Thanks for all the words of wisdom you give to all the members of xda. :thumbup:

*edit* - Well, decided to just let it ride for over an hour. Took an extended nap after I got home, so after flashing, the phone has been on the Samsung screen for well over 3 hours. I am going to presume that the Heimdall kernel install packages are a no go for me. I will read up on Odin and give it a shot. Thanks again. - *edit*

Sent from my LG-P999 using xda app-developers app
The Following User Says Thank You to grtdrgn For This Useful Post: [ View ] Gift grtdrgn Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes