FORUMS
Remove All Ads from XDA

[PLAY][How-To] Enable Wifi, get Rooted/Google Apps/Recovery for Official ICS Beta

13,194 posts
Thanks Meter: 39,783
 
Post Reply Email Thread
the kernel threads and the official ROM release thread were getting spammed with the same questions so i thought this thread was needed...

this thread will tell u how to:
  1. get working Recovery
  2. Root the ICS Beta ROM
  3. enable WIFI
  4. get working Google Apps
  5. CDMA Fix (obviously only for R800x Verizon CDMA devices)


its is assumed that u have successfully flashed Official ICS Beta ROM and that u know how to use fastboot, recovery...



[ get working recovery ]

flash the advanced stock kernel using fastboot (fastboot flash boot boot.img)

OR

u can flash any of the other custom kernels for ICSBeta which have recovery


[ Root the ICS Beta ROM ]

some kernels have autorooting feature so just flashing the kernel and booting it will root the ROM

OR

download and flash this superuser fix via recovery (thanks to ChainFire for updated app/binary)



[ enable WiFi ]

download and flash this WiFi enabler via recovery (thanks to Bin4ry)



[ get working Google Apps ]

download and flash this ICS Google Apps via recovery (link thanks to KeiranFTW)


some users have recommended flashing this FaceUnlock addon AFTER flashing the GAPPS above... download and flash it via recovery...



[ CDMA Fix ] (R800x ONLY)

download and flash this this post via recovery (thanks to Leraeniesh, from this post)



thats it...


NOW PLEASE STOP SPAMMING THE THREADS WITH SAME QUESTIONS!!!
Attached Files
File Type: zip DooMLoRD-ICS-BETA-wifi-ENABLER-v01.zip - [Click for QR Code] (158.2 KB, 8036 views)
The Following 18 Users Say Thank You to DooMLoRD For This Useful Post: [ View ] Gift DooMLoRD Ad-Free
30th March 2012, 10:36 PM |#2  
Senior Member
Flag brampton
Thanks Meter: 66
 
More
THANKYOU SOOOO MUCH!!!

atleast sum1 cares about us noobs lol


edit: np wifi still dont work
31st March 2012, 06:55 AM |#3  
ozzmanj1's Avatar
Senior Member
Flag Utah - Somewhere in the Great Salt Lake
Thanks Meter: 1,850
 
More
wifi works for me but no data or calls still... I am aware its being worked on and am confident in the Geniuses here. Thank you for your efforts....
31st March 2012, 07:13 AM |#4  
Member
Thanks Meter: 0
 
More
Wi-fi and Calls are working fine! I can't test out Data yet because I am around 1 mb from my maximum data usage for this month

Downloading Google apps right now to check it out, Can't wait for an AOSP theme

Edit: When I download the archive from the link above for the google apps it doesn't flash from recovery, the face unlock flashes fine though. When I open the zip file on PC Win RAR gives me an error, is it a problem with the original uploaded file or just the download?
UPDATE: Nevermind fourth try got it to work
31st March 2012, 07:59 AM |#5  
ozzmanj1's Avatar
Senior Member
Flag Utah - Somewhere in the Great Salt Lake
Thanks Meter: 1,850
 
More
Quote:
Originally Posted by Yourmama

Wi-fi and Calls are working fine! I can't test out Data yet because I am around 1 mb from my maximum data usage for this month

Downloading Google apps right now to check it out, Can't wait for an AOSP theme

Edit: When I download the archive from the link above for the google apps it doesn't flash from recovery, the face unlock flashes fine though. When I open the zip file on PC Win RAR gives me an error, is it a problem with the original uploaded file or just the download?
UPDATE: Nevermind fourth try got it to work

So you tried to flash the above file in post 1 4 times before it worked? For me its been like 7 times, no calls, no face unlock... wifi is it and thats it.. no calls no data...
31st March 2012, 08:09 AM |#6  
Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by jgregoryj1

So you tried to flash the above file in post 1 4 times before it worked? For me its been like 7 times, no calls, no face unlock... wifi is it and thats it.. no calls no data...

It wasn't a problem with the flashing though.. It was the download I guess the file I downloaded was corrupt maybe because of a loss of connection towards the end, but the fourth time around it downloaded completely and I was able to view it in WinRAR without any errors.
1st April 2012, 02:33 AM |#7  
NeWCuLTKiNG's Avatar
Senior Member
Flag Upstate New York
Thanks Meter: 3,000
 
Donate to Me
More
I noticed many are having trouble with battery drain and busybox and many other weird things. After repeated installs through fastboot and starting from scratch I tried installing ka11 and it runs perfect. Maybe if someone with a good flash of ics could make a nandroid fresh from flash and upload it for us with bad fastboot installs. Anyone care to help? Thanks

Sent from my R800i using xda premium
4th April 2012, 02:45 PM |#8  
cornishronson's Avatar
Senior Member
Flag Cornwall
Thanks Meter: 36
 
More
Quote:
Originally Posted by hitman980206

I noticed many are having trouble with battery drain and busybox and many other weird things. After repeated installs through fastboot and starting from scratch I tried installing ka11 and it runs perfect. Maybe if someone with a good flash of ics could make a nandroid fresh from flash and upload it for us with bad fastboot installs. Anyone care to help? Thanks

Sent from my R800i using xda premium

I installed jrummys busybox installer and installed 19.3 (.4 wouldn't work, now my link2sd detects it. So if any one is having trouble with busy go to play store and search busybox installer an click jrummys 1 I've had problems with the stericson 1.

Sent from my R800i using xda premium
4th April 2012, 02:48 PM |#9  
Senior Member
Flag Hitchin
Thanks Meter: 43
 
More
I dont Think Root Installs BusyBox I may be wrong However it might be a Outdated one im ot sure ata all
4th April 2012, 10:04 PM |#10  
DooMLoRD's Avatar
OP Inactive Recognized Developer
Flag Pune
Thanks Meter: 39,783
 
Donate to Me
More
Quote:
Originally Posted by Xperia4life

I dont Think Root Installs BusyBox I may be wrong However it might be a Outdated one im ot sure ata all

Rooting and installing busybox are two different things
26th April 2012, 09:51 AM |#11  
ngavarta's Avatar
Member
Flag Shanghai, China
Thanks Meter: 0
 
More
Smile My Xperia Play works like a charm ...
Quote:
Originally Posted by DooMLoRD

the kernel threads and the official ROM release thread were getting spammed with the same questions so i thought this thread was needed...

this thread will tell u how to:

  1. get working Recovery
  2. Root the ICS Beta ROM
  3. enable WIFI
  4. get working Google Apps
  5. CDMA Fix (obviously only for R800x Verizon CDMA devices)


its is assumed that u have successfully flashed Official ICS Beta ROM and that u know how to use fastboot, recovery...

[ get working recovery ]

flash the advanced stock kernel using fastboot (fastboot flash boot boot.img)

OR

u can flash any of the other custom kernels for ICSBeta which have recovery


[ Root the ICS Beta ROM ]

some kernels have autorooting feature so just flashing the kernel and booting it will root the ROM

OR

download and flash this superuser fix via recovery (thanks to ChainFire for updated app/binary)



[ enable WiFi ]

download and flash this WiFi enabler via recovery (thanks to Bin4ry)



[ get working Google Apps ]

download and flash this ICS Google Apps via recovery (link thanks to KeiranFTW)


some users have recommended flashing this FaceUnlock addon AFTER flashing the GAPPS above... download and flash it via recovery...



[ CDMA Fix ] (R800x ONLY)

download and flash this this post via recovery (thanks to Leraeniesh, from this post)

thats it...

NOW PLEASE STOP SPAMMING THE THREADS WITH SAME QUESTIONS!!!

Marvelous, works like a charm. Some remarks, it's weird enough that I got some driver problems on my Win7 Machine, but not my Macbook Air (OSX 10.8).

It works, the recovery boot image were fascinating, loved it ... will test more with this ...
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes