FORUMS
Remove All Ads from XDA

 View Poll Results: Is this thread news worthy?

Yes, definitly!!
 
72 Vote(s)
54.55%
Hmm.. Maybe..
 
24 Vote(s)
18.18%
I don't know, I'm new here..
 
9 Vote(s)
6.82%
No, it's just for people, who actually need it..
 
9 Vote(s)
6.82%
No, and this poll is a stupid question!
 
18 Vote(s)
13.64%

[Solution]Windows 8 - ADB/fastboot driver problem solved!!

1,112 posts
Thanks Meter: 595
 
Post Reply Email Thread
Hello!!

First off; This is copied, from my thread, in the Galaxy Nexus forum... Sorry, if you find the words "Galaxy" or "Samsung". But, this works for pretty much every phone, (except, for the USB drivers)...


So, give it a go...

I haven't found another tutorial, like this at all... So, if you find something like this it's copied from me

Now, on to the actually interesting stuff ^^

I have found a solution, to the following problem;

After installing Windows 8, you cannot install fastboot drivers, but it recognizes the ADB drivers...

Solution:

Note: If you feel more comfortable using the Windows Power Shell, you can use that as well, it is, after all, only the Windows shell

Open the dev-manager, by typing following, in a command prompt window, or the run dialog. Whichever you prefer... :
Code:
devmgmt.msc
Now, the device manager, should pop up.
Install ADB drivers, (If you do not have them present, download them here
To prevent confusion: When I say install, it can mean unpack, or install... Quick tip: An installer does nothing, apart from unpacking files, to allocated space, on your computer
Download USB drivers, from here. (Link fixed. Again (-_-") ) (Note: These are the Sammy OEM drivers.)

Should you NOT have drivers installed:

Install the USB drivers, and download ADB/fastboot drivers.

Installation of ADB/fastboot drivers:
Open the device manager, and look for "Samsung Mobile Device", or "Unidentified Device". You can make your search easier, by unplugging the phone, whilst in device manager, then plug it back in, and see what's changed...

Once you have found your phone, Perform a right-click, on the device. Select : "Update device drivers", once the dialog has popped up, choose "Browse my computer" and goto your desktop, where you have installed the files to.
Open just the "drivers" folder, nothing else...
Select OK, then wait for installation to finish.

Once that has been done, you need to reboot your device, into bootloader mode; do this by typing
Code:
path=%userprofile%\Desktop\ADB\
adb reboot-bootloader
into the command prompt (download & install this, if you want to do it the cmd-way...)

Or, turn off your phone, and reboot i it manually into bootloader-mode, by pressing
Code:
VOL UP +DWM & PWR
together, untill phone vibrates...

Once the phone is in bootloader, go back to the device manager, and look for a device named "android 1.0". Perform a right-click on this and select "Update device drivers". Again, selct "Browse my computer", but, instead of clicking on "Browse" and selecting the folder, again, select "Let me pick from a list of drivers." Once the menu has popped up, select "Samsung Android ADB interface". Click OK, and wait for the drivers to install . Then, you're done. You have then successfully installed the ADB + fastboot drivers correctly, to test this, open a cmd window, and type following:
Code:
path=%userprofile%\Desktop\ADB\
fastboot devices
If your device shows up, then you have done it!!
Now type:
Code:
fastboot reboot
adb wait-for-device
adb kill-server
Note: while the phone is booting (If you typed "adb wait-for-device") A cursor will blink, wait for that, to stop blinking, then type the next command

I hope you learned, from this tutorial!! Check out Beatsleigher & M4gkman's Universal Android Toolkit, if you have enough time

Should you have problems, in recovery, open your dev. manager, and look for following device:
Code:
Full
Select, right-click. Update driver (blah, blah, witter, droan)
Browse my computer -> Let me pick -> Samsung ADB -> Done. You have enabled the ADB drivers, on your Android Device!!!!




So, apparently, if you're using Windows 8 and/or USB 3.0 ports, Windows installs its crappy drivers, so you should check out this link, posted by the awesome @tommy_riley and try it out for yourselves! Don't forget to drop him a 'Thanks'!
http://plugable.com/2012/12/01/windo...st-controllers <- Courtesy of @tommy_riley!



Wow. Over 40.000 clicks and downloads. I'm amazed at you guys!
It doesn't cost anything or hurt to hit that 'Thanks' button... Please be sure to hit it, it helps me out and also shows me what sort of content you want to see from me.

Do you like the effort I put into this? Then consider donating, by adding towards a new PC: http://www.gofundme.com/NewPC
With a new PC, I can create more one-click solutions and stuff and things!
The Following 83 Users Say Thank You to Beatsleigher For This Useful Post: [ View ] Gift Beatsleigher Ad-Free
5th April 2012, 06:29 PM |#2  
Beatsleigher's Avatar
OP Senior Member
Flag County of Osnabrück, Lower Saxony, Germany
Thanks Meter: 595
 
Donate to Me
More
Updates & other info!! (Reserved)
If you have a problem, I'll do it over TeamViewer, if you wish

Ok, here is some news, for you!

Well, according to some people, who have used this tutorial, Microsoft has done something new to their device driver signing.
I did not have note of this, as I was using Ubuntu most of the time and the laptop I was using broke, several weeks ago (It's gonna take me ages to get a new one, with which I can finally finish my ROM cooking..)
And Senior Member "purpler" has posted a link, which teaches you to turn device driver signing off, in the new bootloader, which Windows 8 is using/will be using, so; let's give him loads of thanks, for this!

here is his answer:
Quote:
Originally Posted by purpler

confirmed that it works but i had to diable driver signing from Windows8 bootloader (Shutdown.exe /r /o)
Use and Access Windows 8 Boot Loader and Advanced Boot Options

Many thanks to you, purpler!

Please, if you notice anymore changes, which interferes with this method, please let me know, how to solve the problem!
Every helpfull answer, with new solutions will be posted in this thread and thanked many times!



EDIT: If you don't want to donate, but still want to thank me, then use these links, instead of the links, in the tutorial.

Mod edit: No adfly links allowed.

Quote:
Originally Posted by 4lex96

I've solve the problem, in stead of usb 3.0 i used a usb 2.0 and it worked! Very strange, with 3.0 i had problem with 2.0 no. I hope this funny thing can help someone.
Best regards

Senior member 4alex96 has experienced some problems, while using USB® 3.0 ports.
If you are also experiencing these problems, or you have found a solution to this, be sure to post in this thread or write to me via PM and I'll be sure to quote and write this, so others also get to know and are able to get the most out of there Androids!



Creating a new tool!
Hey guys, I'm going to be creating a new tool or two, which will allow you to install ADB and Fastboot directly to the system root and which will install the Google drivers to your C:\ drive.

These tools will be available for a small donation, and they will save you a lot of work, i.e. you will never have to type in "path=<Whereever the ADB files are>" but you can just debug on

If you want to have the program, hit the "Donate to Me" button on the left of this post and donate a small amount. Then in the donation, write me a message, saying what it's for and give me your XDA username and I'll PM you the download link.
(Minimum of 5€)

Quote:
Originally Posted by tommy_riley

For Windows 8, I was having an issue getting my phone to be recognized in bootloader mode on an ASUS laptop that only had USB 3.0 drivers, I followed the procedures at the below URL (luckily I had an INTEL chipset) and once I replaced my native Windows USB 3.0 drivers with the Intel USB 3.0 drivers, I was able to work around a lot of issues:

http://plugable.com/2012/12/01/windo...st-controllers

(I cant post HTTP links yet, but you should be able to plug the above into a browser to find the instructions...)

hope this helps!

You get that, guys? Go check out that website, and try it out for yourselves!
The Following 6 Users Say Thank You to Beatsleigher For This Useful Post: [ View ] Gift Beatsleigher Ad-Free
22nd April 2012, 05:13 AM |#3  
thisiswar951's Avatar
Senior Member
Flag Riverside
Thanks Meter: 36
 
More
Tried using this fix keep getting an error saying the driver is not signed.

-Edit

Got it working had to go into advanced boot options and turn off device signing
The Following 2 Users Say Thank You to thisiswar951 For This Useful Post: [ View ] Gift thisiswar951 Ad-Free
22nd April 2012, 08:09 AM |#4  
Beatsleigher's Avatar
OP Senior Member
Flag County of Osnabrück, Lower Saxony, Germany
Thanks Meter: 595
 
Donate to Me
More
Quote:
Originally Posted by thisiswar951

Tried using this fix keep getting an error saying the driver is not signed.

-Edit

Got it working had to go into advanced boot options and turn off device signing

Ok, cool. I haven't been on my laptop, for a few days, so I wouldn't know, if MS has released any updates, yet...

I was thinking: WTF is he talking about? It's worked by so many people :eek:...
xD

LG familyguy59
The Following User Says Thank You to Beatsleigher For This Useful Post: [ View ] Gift Beatsleigher Ad-Free
16th August 2012, 09:27 PM |#5  
Senior Member
Flag Nova Pazova
Thanks Meter: 13
 
More
confirmed that it works but i had to diable driver signing from Windows8 bootloader (Shutdown.exe /r /o)
Use and Access Windows 8 Boot Loader and Advanced Boot Options
The Following 3 Users Say Thank You to purpler For This Useful Post: [ View ] Gift purpler Ad-Free
1st September 2012, 03:35 AM |#6  
Junior Member
Thanks Meter: 1
 
More
Hi, I'm using win8 pro 64bit rtm.
when I double click on the UsbDrv.exe from Samsumg nothing comes up.
even when I run it in compatibility mode it doesn't help...

any ideas? I have disabled signed drivers.

thanks!
The Following User Says Thank You to hshen45 For This Useful Post: [ View ] Gift hshen45 Ad-Free
4th September 2012, 02:03 PM |#7  
Beatsleigher's Avatar
OP Senior Member
Flag County of Osnabrück, Lower Saxony, Germany
Thanks Meter: 595
 
Donate to Me
More
Quote:
Originally Posted by hshen45

Hi, I'm using win8 pro 64bit rtm.
when I double click on the UsbDrv.exe from Samsumg nothing comes up.
even when I run it in compatibility mode it doesn't help...

any ideas? I have disabled signed drivers.

thanks!

You'll have to wait a moment, the system has to look for all the needed files, in the exe, and then needs to try to execute. If it then doesn't work, I'll upload an updated version, but as this seems to be working pretty much fine, I'll hesitate, not that the updated verison causes problems.

Anyways, I was running Win8 64x and it worked fine, just let the computer do it's work and it will work sooner or later, if nothing happens, even after waiting for 5-10 minutes, then try running it with administrative rights (Run as administrator).. Let me know if it works!
The Following User Says Thank You to Beatsleigher For This Useful Post: [ View ] Gift Beatsleigher Ad-Free
29th September 2012, 08:42 PM |#8  
leeznon's Avatar
Senior Member
Flag Taipei
Thanks Meter: 23
 
More
Doesn't work for me because I cant even see my S3 in the device manager.
The Following User Says Thank You to leeznon For This Useful Post: [ View ] Gift leeznon Ad-Free
29th September 2012, 09:22 PM |#9  
Beatsleigher's Avatar
OP Senior Member
Flag County of Osnabrück, Lower Saxony, Germany
Thanks Meter: 595
 
Donate to Me
More
Quote:
Originally Posted by leeznon

Doesn't work for me because I cant even see my S3 in the device manager.

Then try a different computer Doesn't mean that your S III is kaputt, does it?

If it then doesn't work, you've probably got dirt in the socket, or something else, like that.

And if you don't have dirt in the socket, then I don't know, whats wrong, but it'll definitely go over warranty
15th October 2012, 12:38 PM |#10  
Member
Flag Montreal
Thanks Meter: 42
 
More
Smile
I have find an easiest way to install adb driver on windows 8 : ( disabling driver signature )

- after BIOS on "choose Operating system" screen
-clic "change default setting"
-clic "choose other option"
-clic "troubleshoot"
-clic "advanced option"
-clic " startup setting"
-clic on "restart"
-Install the driver adb as if you were on Windows 7
15th October 2012, 02:33 PM |#11  
Beatsleigher's Avatar
OP Senior Member
Flag County of Osnabrück, Lower Saxony, Germany
Thanks Meter: 595
 
Donate to Me
More
Quote:
Originally Posted by dalien26

I have find an easiest way to install adb driver on windows 8 : ( disabling driver signature )

- after BIOS on "choose Operating system" screen
-clic "change default setting"
-clic "choose other option"
-clic "troubleshoot"
-clic "advanced option"
-clic " startup setting"
-clic on "restart"
-Install the driver adb as if you were on Windows 7

That's what the link in the first post is for. And you still need to follow the steps in the tutorial, otherwise it won't work properly.
I know the tutorial looks complex, but it isn't. You just need to read properly

LG familyguy59/Beatsleigher

EDIT: It's spelled "click"
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes