FORUMS
Remove All Ads from XDA

[q] problems with lg gt540

49 posts
Thanks Meter: 1
 
Post Reply Email Thread
hi guys.. could you help me with my problem.!
I have an LG GT540 android 1.6 firmware version(stock)

So here are my problems:
1. I tried to upgrade it from 1.6 to 2.1 using this tutorial http://forum.xda-developers.com/show...27&postcount=3 thanks to lavero.burgos for posting it, I was successful at first part, but I cant follow the next because my device wont go to fast boot,, I tried putting it off, then camera+poweron but it doesnt do anything. It doesn't light, no lg logo appears, just nothing although the computer can read the drive when I connect it through usb. So I cannot flash it to 2.3,2.3 because it just wont go to fastboot.

2. When I turn it on normally, It takes long before it response like after 30sec to light, but just light, no lg logo appears although it wasnt bricked because I can use it normally after just waiting to on.(annoying)

3. Since I upgraded it to 2.1, I lost all 3rd party application and the internal apps were the only left, so I copied all my saved apps (.apk) to my sd card but the problem is there is no saved app on my phone to read and install those apps from my sd card.(irritating)

4. My device wont read my sim card, when I start it it says "sim card unprovisioned" so basically I cant connect to mobile networks here in the philippines(im using globe telecom). I feel that Im stucked in the middle of nowhere since I cannot contact and txt all my family and friends.

5. I cant connect to wifi,, when my device detects wi-fi, I try to connect to it but from the log it only try to connect but doesn't obtain the ip address. Even when the wi-fi signal is strong, it does the same thing.

So please help me guys,,I want to hear from my fellow xda-developers badly,,,

PS. also those who have problems with their LG GT540 pls feel free to post and share it with us here... thank you all guys in advance....
 
 
29th April 2012, 09:40 AM |#2  
-Grift-'s Avatar
Senior Member
Flag Singapore
Thanks Meter: 2,009
 
More
hi so let me get it right the phone is working (can turn on and use but cant call) yes? hmmmmm..... try this

MUST DOWNLOAD THIS DRIVERS!!!!
http://dottech.org/android/26188/usb...ndroid-phones/

Quote:

Step one!


1.turn off phone.
2.hold the POWER button till you feel the beep.
3.let go of the POWER button when you feel the beep and hold onto the CAMERA button only.
4.hopefully it turns on to a blackscreen and nothing else(fastboot)
5.unzip this CLICK ME!! to desktop and open the flash all no wipe file

or......

1.turn on your phone.
2.go to settings>applications>development>tick the usb debugging
3.connect phone to computer (make sure phone is on)
4.unzip this CLICK ME!! to desktop and open the flash all no wipe file
5. phone should boot into blackscreen like the one above......


Quote:

Step 2!


both should flash a recovery image. Next
1.make sure the phone is off
2.press POWER button
3.when you feel the beep let go of POWER button and press the HOME button only.
4.phone should boot into recovery mode.
5.take out battery again
6. download a rom into the sdcard using computer
7.go to recovery again using the steps above (steps 1 to 4)
8.select wipe all data factory reset or something like that....
9.install zip from sdcard
10.select from sdcard
11.choose the file you downloaded
12.finish flash and reboot phone.

The Following 2 Users Say Thank You to -Grift- For This Useful Post: [ View ] Gift -Grift- Ad-Free
30th April 2012, 08:43 PM |#3  
manthos1978's Avatar
Member
Flag Thessaloniki
Thanks Meter: 0
 
More
excellent guide! big thanx
1st May 2012, 08:27 AM |#4  
just curious™'s Avatar
OP Member
Flag on earth
Thanks Meter: 1
 
Donate to Me
More
Quote:
Originally Posted by bs828

hi so let me get it right the phone is working (can turn on and use but cant call) yes? hmmmmm..... try this

MUST DOWNLOAD THIS DRIVERS!!!!
http://dottech.org/android/26188/usb...ndroid-phones/

Thanks,, Ive tried the 2nd option on step one and i think my phone successfully got to fastboot(just clean blank screen) so the cmd automatically run and states

C:\Desktop\adb rebootloader
* daemon not running. starting it now on port 5037 *
* daemon started successfully *
error: protocol fault <no status>

C:\Desktop\fastboot flash recovery recovery.img

< waiting for device >




Did I miss something???
1st May 2012, 08:48 AM |#5  
-Grift-'s Avatar
Senior Member
Flag Singapore
Thanks Meter: 2,009
 
More
ok try again this time with the phone turned on. and then run the script and did you install the drivers?
The Following User Says Thank You to -Grift- For This Useful Post: [ View ] Gift -Grift- Ad-Free
2nd May 2012, 03:23 AM |#6  
just curious™'s Avatar
OP Member
Flag on earth
Thanks Meter: 1
 
Donate to Me
More
Quote:
Originally Posted by bs828

ok try again this time with the phone turned on. and then run the script and did you install the drivers?

yeah I installed the drivers...
2nd May 2012, 07:59 AM |#7  
-Grift-'s Avatar
Senior Member
Flag Singapore
Thanks Meter: 2,009
 
More
hmmm maybe there are no fastboot drivers(main suspect....) there are a few ways to get it but for mine i just plug my phone in to my pc (windows 7 64bit) it just recognize it and tries to get the "google fastboot interface" drivers from windows update...
11th May 2012, 10:46 PM |#8  
CoolApps's Avatar
Senior Member
Thanks Meter: 607
 
More
Try Volume Up+Search Key+Power to go into Fast boot Mode, There's different keys to activate Fastboot Mode (There is different versions of Fastboot)

Sent from my LG GT540 CM9 PreRC Polish Blood using xda premium
21st November 2015, 01:46 AM |#9  
Junior Member
Thanks Meter: 0
 
More
Your phone is/was bricked
Hey, I'm sorry to bing back such an old thread, but I just wanted to say this for posterity: your phone has/had a soft-brick. This means: you can't see Android nor LG boot logos, can't enter Recovery and (maybe) can't access Fastboot, but I'm not too sure on that last one. Besides that, the phone works "okay", but you should try to fix it.

Basically this soft-brick is almost always caught when upgrading from 1.6 to 2.1, so everyone should have it, including me. It took me a whole year to realize how to friggin' fix it lol, but here goes what I did:

Thanks for your help everyone, I came to a solution after a full year lol. Here's my enlightenment, from another Thread:

------------------------------------------------------------------------------------------
Just wanted to leave my 2 cents here, I've been trying to do my best since around august 2014, no success. 2 days ago I retried this, and I DID IT! I will tell everyone what I did very shortly:

My problem that I solved: I can boot, device works like a charm. But: no boot logos, no recovery.
My solution for TL;DR: UNINSTALL ALL DRIVERS FROM DEVICE MANAGER 1ST, then reinstall. After that, flash a fastboot ROM and use it to WIPE ALL THE DATA IN YOUR PHONE! THIS was what I needed and was never explained: you had to WIPE the old data in order to get the boot screens back.

IN THIS ORDER (THANK YOU to those people from previous replies, gathering all your info was of great value):

Uninstall all of your phone drivers from your PC!!! This is what made most of my headaches go away, just use Device Manager and uninstall anything from LGE. After that, plug in your device in your USB ports (always BACK ports, not front ports, important). It should detect all drivers and download them.

IF it fails (it generally does with LGE USB Modem), you can go to Device Manager > Unknown Device (the one that wasn't recognized) > Right Click and Update > Choose 2nd option, then choose "choose from a list of local controllers" (or whatever the button says). After that, scroll down to LG Electronics, Inc. and install what didn't install.
I also found these drivers, but I did not test them: http://www.mediafire.com/download/p6...r_LG_GT540.zip
Huzzah!


Now you're set to begin:

FIRST thing you wanna do is a factory reset, this is something I'd forgotten with time, don't make the same mistake as I did. You can do it by turning your phone on and pressing Volume +/- & Home & Quick Search buttons all together for 5 seconds (it works, be patient and wait for it, even if you open the camera or any other stuff).

Download this Google SDK Tools (unzip and put the folder in C:\ drive) and this Fastboot drivers for GT540 (unzip and put the files inside the folder in C:\android-sdk).

Skip this next line if you know your ROM has fastboot.

Quote:

Now, if you don't have a ROM with fastboot, I recommend you use either European Open+Fastboot or V20C Orange France Fastboot ROM.

Since you have Fastboot enabled, now all you need to do is turn off your device (all this with its battery on it, no weird things) and hold the Camera button before turning it back on. This should take you either to a black screen, or simply to no display, like me. Either one will work anyways.
Now press the Windows key > Type cmd and open it with Right Click > Run as Administrator.
In it, type all this, command by command (you can paste by right clicking):

Quote:

cd C:\android-sdk
fastboot -w
fastboot erase boot
fastboot erase system
fastboot -w
fastboot reboot

And now it's go time! Do what everyone else says in here: Take out your phone's battery, SD and SIM cards, fire KDZ Updater up as Administrator (If your KDZ freezes, then it's either faulty or you did not install msxml, look for a good KDZ that comes with that file and delete your current one), choose CS_Emergency PhoneMode and:

Quote:

1-Plug your phone while holding the volume DOWN button (don't worry! My phone didn't show "Download Mode" either, if you hear the Windows "Somethingpluggedin" Bump noise, it's ok).
2-Flash French V20A
3-Unplug your phone once KDZ says "==FINISHED==".
4-Plug it once again, holding the volume DOWN button.
5-Flash out.kdz (remember! it's CS_Emergency).

THANK YOU XDA!
--------------------------------------------------------------------------------------
Also, if you look in here you'll find how to flash an awesome ROM, Cyanogen Mod 10 (should say "Final Version#2).
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes