FORUMS
Remove All Ads from XDA

How to/Solution to disable proximity sensor incall

160 posts
Thanks Meter: 32
 
By ginodp, Senior Member on 29th April 2012, 10:47 PM
Post Reply Email Thread
**Standard Disclaimer applies here: If you screw up your device trying the following steps in this thread, I cant be responsible. But thats old news**

If your phone stays black after a call you can fix it by a couple of ways.

First:
Code:
Q:Where is the proximity sensor?
A:Top left of the screen in opposite place to led, if you tily screen under the light you should see the sensor reflect back at you.
Install this app and test your proximity sensor to be sure, that it is not broken: Proximity Sensor Finder

Options you need to try first.
  1. The screen protector, yes it might be transparent but the sensor detects it. Using a sensor testing app from the market it suggested the sensor was covered almost all the time.
    So the solution was replace the protector with new one but cut an arc at the top just big enough around the sensor at the top left, easy fix now in call screen is more responsive.
  2. With a vacuum cleaner vacuum over the top area of the phone. This must suck all the dust out of there.

<-------------------------------------->
1 of the other option would be an app called Anyunlock which seems to have solved the problem for me. It seems to be able to wake up when the screen turns off after a call. The app allows you to unlock with the volume key and replaces the lock screen with its own screen.

This option works on my Desire S
<-------------------------------------->

If it's broken, you'll see 0.0 cm all the time.

Solution to disable proximity sensor incall is to put this line into build.prop and reboot:

you can edit the build.prop by pulling it first from the device by doing:

Code:
adb pull /system/build.prop c:\where\you\want\to\put\it\
open with wordpad and add the following line

Code:
gsm.proximity.enable=false
Then

Code:
adb remount
adb push c:\where\you\want\to\put\it\build.prop /system/
reboot so that the settings take effect

This option works on my Desire S


Credits
For disabling the proximity sensor in call go to Matri}{
Rest of the credits go to all the people that figured the other stuff out. (to many post on the net so I don't know who made them but thanks)

Thanks to myself for making this tutorial. (It's my first on xda)
If you have any other idea's just pm me or drop a post.

Thanks
The Following 10 Users Say Thank You to ginodp For This Useful Post: [ View ] Gift ginodp Ad-Free
 
 
29th April 2012, 10:47 PM |#2  
ginodp's Avatar
OP Senior Member
Flag Amsterdam
Thanks Meter: 32
 
Donate to Me
More
Reserved
30th April 2012, 03:25 PM |#3  
amidabuddha's Avatar
Senior Member
Thanks Meter: 2,459
 
More
Thanks for the guide, it seems that there are quite some people affected by this and I find it much useful. Just a suggestion - IMO more proper place for it will be the General section, so you can request moving it there from the moderators and also adding it to the Index thread (PM ben_pyett)

Sent from my Desire S
The Following User Says Thank You to amidabuddha For This Useful Post: [ View ] Gift amidabuddha Ad-Free
6th May 2012, 12:45 PM |#4  
Member
Thanks Meter: 5
 
More
Hey,

I just tried your fix but it didn't work for me. Screen still goes black when receiving a call and only reacts when I plug it in through USB. Could it be because my ROM is ICS?

Also tried removing the screen cover & sucking out the dust on the top.

The Anyunlock app works, but that's not ideal of course.
6th May 2012, 05:59 PM |#5  
ginodp's Avatar
OP Senior Member
Flag Amsterdam
Thanks Meter: 32
 
Donate to Me
More
Yes it could be that it's Rom related. I use Endymion. And matri}{ extracted it from the Rom.

Wich Rom do you use. I can take a look for you tonight when I get home.

The anylock works most off as between solution.

Sent from my HTC Desire S using Tapatalk 2
The Following User Says Thank You to ginodp For This Useful Post: [ View ] Gift ginodp Ad-Free
10th May 2012, 05:51 PM |#6  
Member
Thanks Meter: 5
 
More
Hey,

I tried it on MIUI ICS, Endymion which both failed. Now I'm using the Reaper ROM but it still doesn't work.
10th May 2012, 10:15 PM |#7  
ginodp's Avatar
OP Senior Member
Flag Amsterdam
Thanks Meter: 32
 
Donate to Me
More
It should work on Endymion. I used it and I even checked if it's the same proximity line in de file of update 3.5.

Did you changed it on the phone or with a text editor on the computer?

I tested it on Endymion just 5 min ago and it worked.

Does your screen still stays black after hanging up? If so can you only unlock with USB cable or power cable?

Sent from my HTC Desire S using Tapatalk 2
The Following User Says Thank You to ginodp For This Useful Post: [ View ] Gift ginodp Ad-Free
11th May 2012, 08:19 PM |#8  
Member
Thanks Meter: 5
 
More
Hm, you're right, it does work on Endymion (sorry). I'm having some stability problems with that ROM though...

Do you know how to enable it on MIUI or Reaper (CM based)?
12th May 2012, 01:52 AM |#9  
ginodp's Avatar
OP Senior Member
Flag Amsterdam
Thanks Meter: 32
 
Donate to Me
More
I'm going to check for you tomorrow ok. I'll get back to you.
The Following User Says Thank You to ginodp For This Useful Post: [ View ] Gift ginodp Ad-Free
12th May 2012, 03:26 PM |#10  
Member
Thanks Meter: 5
 
More
I just discovered that there is a setting in the MIUI dialer to disable the proximity sensor! This also works, sorry for taking up your time.

But maybe a new suggestion for people who don't want to edit the build file ? Try MIUI!
17th May 2012, 10:24 PM |#11  
rolfharris's Avatar
Junior Member
Thanks Meter: 4
 
More


Quote:

Solution to disable proximity sensor incall is to put this line into build.prop and reboot:

you can edit the build.prop by pulling it first from the device by doing:

Code:

adb pull /system/build.prop c:\where\you\want\to\put\it\

open with wordpad and add the following line

Code:

gsm.proximity.enable=false

Then

Code:

adb remount
adb push c:\where\you\want\to\put\it\build.prop /system/

reboot so that the settings take effect

This option works on my Desire S

if anyone could explain this in noob terms it would be much apprecited
The Following User Says Thank You to rolfharris For This Useful Post: [ View ] Gift rolfharris Ad-Free
Post Reply Subscribe to Thread

Tags
disable, disable proximity sensor, proximity, proximity sensor desire s, sensor

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes