FORUMS
Remove All Ads from XDA

Email "Connection Error" for Hotmail and Exchange when loading HTML

18 posts
Thanks Meter: 2
 
By crandallbk, Junior Member on 29th May 2012, 07:06 PM
Post Reply Email Thread
I recently bought the p6800 - amazing device! I loaded sk806's firmware, which is excellent! Ever since setting up my email accounts for my corporate exchange (2010) and hotmail, any time I try to pull down HTML formatted emails, even with "Load more details" or refreshing the email list, I get a "Connection error" for both my hotmail account and exchange account. I do get the emails, just no HTML content.

I have tried setting my mail to pull down all of each email message, rather than a part of the message, deleted and recreated my accounts various times, cleared the email data, tried only one account, etc, and no success. Once or twice (out of hundreds of attempts), I have been able to get the HTML, but those couple of times are not repeatable. I am thinking there is a problem with the exchange services from Samsung, as both accounts use these services. The same settings on my other tablet/phone work fine.

Any ideas or a replacement email.apk? Thanks all.
 
 
31st May 2012, 01:07 AM |#2  
OP Junior Member
Thanks Meter: 2
 
More
Sorry, my above was probably confusing:

Is anyone having problems downloading emails from exchange servers in html format using the Samsung email client? This gives me "Connection error", even though the emails come down in text format. Other mail clients like touchdown or enhanced mail work, but I like some of the features of the Samsung client.
3rd June 2012, 05:43 AM |#3  
Member
Thanks Meter: 0
 
More
im in the same boat here
my other email accounts seems to have the same problem with the email client
3rd June 2012, 03:08 PM |#4  
Junior Member
Thanks Meter: 4
 
More
I had the same problem - at first my two mail accounts (one pop3, one imap) were running fine and after about 3 weeks I always had a general connection error. After a longer research I found the solution in one forum:

There's a bug in the Samsung client, that when in airplane mode with wlan enabled this connection error occurs. and really - what I had changed was inserting a SIM card which was disabled. With 3G enabled the mail-client gets server connection, also over wlan. Stupid!

werich
The Following User Says Thank You to werich For This Useful Post: [ View ] Gift werich Ad-Free
3rd June 2012, 05:28 PM |#5  
OP Junior Member
Thanks Meter: 2
 
More
Wow! That looks like it may be it. Thanks. I took it out of airplane mode and no go, but when I added a sim card, the error was gone. It appeared to be a bug in the client, but now I know how to get around it. Time to get a cheap sim.

Thanks Werich!
4th June 2012, 11:39 AM |#6  
Junior Member
Thanks Meter: 4
 
More
You don't need a SIM card, just avoid the airplane mode (I takes some minutes or a restart to take effect). But as this mode uses alot of battery, even without SIM, this bug makes the build in Mail app practically useless for me. So I'm hoping for ICS...
5th June 2012, 04:18 AM |#7  
OP Junior Member
Thanks Meter: 2
 
More
I found that. Once it started working, even when I removed the sim card, it continued to work. I agree, for battery sake since I dont have a sim currently, I would rather leave it in airplane mode. At least there is a workaround. Hopefully we will get ICS soon. Thanks again.
6th July 2012, 05:14 PM |#8  
Junior Member
Thanks Meter: 0
 
More
I found a way to enable Airplane mode without connection error. I use app "Airplane mode modifier". I select "not disable WIFI" in Airplane mode. After that I can enable Airplane mode without this email issue.
8th July 2012, 02:18 AM |#9  
Junior Member
Thanks Meter: 4
 
More
Just for your information: the ICS update fixes that issue too.
8th July 2012, 02:45 PM |#10  
lucid's Avatar
Senior Member
Flag Amsterdam
Thanks Meter: 49
 
More
And on HoneyComb, I could enable airplane mode, then click wifi to turn it on.

Anyway Im on ICS now and it's the sweetest ice cream of all.
22nd July 2012, 12:06 PM |#11  
Member
cairo
Thanks Meter: 3
 
More
In Honeycomb i used to have "connection error " when using WIFI , but on 3G there was no connection error

but since ICS was released , I never got connection error on WIFI or 3G
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes