FORUMS
Remove All Ads from XDA

Confirmed temporary solution to game freezing and browser/system lag. Video Added!

793 posts
Thanks Meter: 218
 
By MRCANNADY, Senior Member on 4th June 2012, 03:54 AM
Post Reply Email Thread
Hey guys. I believe that the os21 update has a bad memory leak/background processing management(besides a kernal issue). When playing heavy 3d games like Nova 3 or Sonic, the framerates are really slow or stutter a lot until the games force-close. Well, for the past 2 days, I have not had this issue, both Nova 3 and Sonic play with no stuttering at all, and I have not experienced any more game crashes. My browser also seems much smoother. Please try the two fix options listed below, while noting that the 2nd option seems to work best with mass Efeect, and less "strict" on runnig processes than the first option:

Fix #1- What I did was push the soft reset button on the Prime (using a small paperclip), then waited for the Prime to reboot. Once it rebooted, DO NOT let the Prime load up anything, just immediately go into settings, developer options, select the kill all activities option, then for background processes, select "at most 1 process only" Delete all of your running task managers/task widgets an that's it. Now all of my games run, no crashes, and the framerates for Nova 3 and Sonic is MUCH better.

Fix# 2 - For those still having issues with Mass Effect, this alternate setting will definitely fix the problem. After soft rebooting, go into development settings, and then for background processes, select "at most 1 process only" and DO NOT select kill all processes after leaving them. This setting has been confirmed to fix the Mass Effect issue, as well as all other games while still keeping the Prime running a lot smoother.

Please try using the exact instructions that I have posted, and let me know if this works for you guys. If so, then it proves that the os21 has a memory management issue which is causing all the current issues we are having.

Also, I would like to share this post from Jaycustom, whom has also been using this method for a few days now and enjoying it more than myself lol. He ran a CPU test to test the differences before and after my fix. See his results below:

Default settings said I had about 19 user/ 29 system processes running.
Dev settings gave me 14 user/ 11 system processes running.

Default settings for system memory 600+mb used/300+ free
Dev settings for system memory 300+ used/600+ free
The memory usage was pretty much exactly reversed! So I assume this is where most, but not all, of the performance boost comes from. CPU usage was also lower, not by much though.

See the video that I made (link below)showing me using the default browser, which is now really fast and stable using this method. I also ran Mass Effect 3 and Nova 3 to show that I have no issues playing these games anymore. I used a Samsung Galaxy tab to record, so please re-frame from laughing at the quality of the vid lol! If you guys would like me to try more games/apps, please let me know.

http://www.youtube.com/watch?v=iperC...ature=youtu.be

Thanks guys
The Following 14 Users Say Thank You to MRCANNADY For This Useful Post: [ View ] Gift MRCANNADY Ad-Free
 
 
4th June 2012, 04:18 AM |#2  
Senior Member
Thanks Meter: 20
 
More
Nova 3 is still freezing and crashing, frame rate is still same.... I think tehere is no solution untill FailLoft will update the app for tegra 3.
4th June 2012, 04:33 AM |#3  
OP Senior Member
Thanks Meter: 218
 
More
Quote:
Originally Posted by mibo666

Nova 3 is still freezing and crashing, frame rate is still same.... I think tehere is no solution untill FailLoft will update the app for tegra 3.

Sorry to hear that it didnt work for you, but it seems to have resolved the issue for me entirely. I am not exeriencing any more gam crashes or white flashing screens. Are you sure that you followed the stes listed? Waiting for others to rely, but either my Prime just decided to play all my games correctly, or this is "fix" is working for me.
4th June 2012, 05:54 AM |#4  
Senior Member
Flag Cape Town
Thanks Meter: 284
 
More
This is not an acceptable fix, it is only a workaround.
4th June 2012, 02:46 PM |#5  
OP Senior Member
Thanks Meter: 218
 
More
Quote:
Originally Posted by leppie

This is not an acceptable fix, it is only a workaround.

Yes I agree 100%, but it works. At least we can play some of our games/browse without issue until the fix comes out. Did you try it, and did it work for you?
4th June 2012, 03:13 PM |#6  
Senior Member
Thanks Meter: 105
 
More
Quote:
Originally Posted by MRCANNADY

Yes I agree 100%, but it works. At least we can play some of our games/browse without issue until the fix comes out. Did you try it, and did it work for you?

I'll have to try this out tonight. To clarify, when you say "do not let it load up anything", do you just mean go into the settings as soon as possible and kill things? It must start running services as soon as it boots, no? I guess this just minimizes the "damage"?
4th June 2012, 03:58 PM |#7  
Member
Thanks Meter: 6
 
More
Hi, I've just tried this and it doesn't seem to have had much of an effect I'm afraid.

In the last 10 mins I've still had two spontaneous browser shutdowns, plus crappy streaming video playback from sites such as bbc iplayer.

The pages seem to load a little faster and scrolling may be a touch smoother but thats about it the best I can say.
4th June 2012, 04:11 PM |#8  
Member
Flag Denver
Thanks Meter: 4
 
More
This solution works well for me. I have been doing this for some time, except I have limited the processes to three. Limiting it to one seems to improve it even better. Widgets seem also to be a drain on the resources and limiting those works well for me. Much thanks for the post.
The Following 2 Users Say Thank You to ksharp4444 For This Useful Post: [ View ] Gift ksharp4444 Ad-Free
4th June 2012, 04:25 PM |#9  
Member
Flag Kansas City
Thanks Meter: 19
 
More
You might also try this solution from here post #118 :

http://forum.xda-developers.com/show...681469&page=12

It seems to have worked for me, I've only had one reboot since. It's at least worth a try. Good luck.
4th June 2012, 04:39 PM |#10  
OP Senior Member
Thanks Meter: 218
 
More
Quote:
Originally Posted by seeknom

I'll have to try this out tonight. To clarify, when you say "do not let it load up anything", do you just mean go into the settings as soon as possible and kill things? It must start running services as soon as it boots, no? I guess this just minimizes the "damage"?

yes exactly.. this is the way it worked for me. Just immediately go into setting, and select the options that i listed. This will only allow the essential programs to run. Please let me know if this works for you. Also, switch the prime to performance for graphic heavy games. Still testing this, but so far I have not have any crashes since applying.
4th June 2012, 04:41 PM |#11  
OP Senior Member
Thanks Meter: 218
 
More
Quote:
Originally Posted by ksharp4444

This solution works well for me. I have been doing this for some time, except I have limited the processes to three. Limiting it to one seems to improve it even better. Widgets seem also to be a drain on the resources and limiting those works well for me. Much thanks for the post.

Thanks for confirm this. Yes, my Prime is no longer lagging when browsing or crashing during gameplay..the difference is honestly night and day. Just confirms for me that .21 is not handling the background processes, or closing them correctly.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes