Remove All Ads from XDA

Empty /efs folder

9 posts
Thanks Meter: 0
By quitofire532, Junior Member on 4th July 2012, 08:59 PM
Post Reply Email Thread
Okay, so I have looked into the other posts about people not having anything in their /efs folder. So I bought an i957r from Rogers. Rooted it and have su and busybox installed. Astro shows that my /efs folder is empty. My IMEI is perfectly fine, all of my data services work, and I am sure root is installed. When I run the adb shell to pull my nv_data.bin, it tells me the file doesn't exist, and when I pull it from the sdcard, it is an empty file. Any ideas as to why that folder would be empty?

Also on a side note, if I was to factory reset it, with root installed, would it damage my device? The only reason I want to reset it is to get the /efs folder. Any help that can be given would be greatly appreciated. Thanks so much!!
5th July 2012, 09:41 AM |#2  
Senior Member
Flag Austin, TX
Thanks Meter: 215
Astro is lying to you. Astro also shows /efs to be empty on my ATT device, but if i get a root shell, it is NOT empty.

This is due to the default permissions on the /efs folder:

# ls -l | grep -i efs
drwxrwx--x system   radio             2012-06-15 10:04 efs
Note the lack of read permissions for other users (not user system or member of group radio). If you change the permissions on the folder, say via:

# chmod 775 /efs
# ls -l | grep -i efs
drwxrwxr-x system   radio             2012-06-15 10:04 efs
Astro would then should you the files in that folder. But that's probably not the best way to handle it... Just deal with the efs files from a root shell, not a user-level file browser like Astro.

Interestingly enough, my Tab 8.9, which has been through a hackathon and a half, doesn't have nv_data.bin file.. anywhere. I do have a /efs/redata.bin file, though.

I wonder if the lack of nv_data.bin is related to why my tab started displaying "Search Network Manually" when I turn LTE on, and sometimes randomly whines about an invalid SIM even though it then immediately connects and works like normal... I've been trying to root cause that change for a while, although it seems to have no negative effects. Probably leaving some whacky log entries on the carrier side of things, though... FWTW.

Do you all actually have an nv_data.bin in /efs?

Also, before someone else flames you... this thread does not belong in this forum... Use the main forum for non-development issues
5th July 2012, 09:07 PM |#3  
OP Junior Member
Flag Ontario, Canada
Thanks Meter: 0
Well thank you for not making me feel completely stupid, I wasn't really sure where to put it. Can you tell me how to move it? So I'm not "that guy"?

But as far as what I have, in the /efs folder, I have redata.bin, but no nv_data.bin and a couple of other files and folders.
I downloaded Root Explorer and it was able to show me what was in that folder. I also searched using that for nv_data... didn't find anything

But while I am already in the wrong forum, can you tell me if doing a factory reset will hurt my device? Also, if I don't have an nv_data.bin file, I can't unlock it, can I? Just hoping you could help. Thanks so much!
6th July 2012, 06:33 AM |#4  
Senior Member
Flag Austin, TX
Thanks Meter: 215
I could be wrong, but I believe only mods can move threads. Never tried, and don't see anything obvious.. Ah well, no big deal.

I wonder if these devices use something different than nv_data.bin? I mean, we both seem to get working LTE service without it, right? Other various posts found via gooogle show several folks that claim their corruption and/or lack of nv_data.bin results in no service.

I highly doubt a factory reset will do any damage, "factory reset" basically means wiping data and cache, which is quite safe. Factory reset doesn't touch /system, /boot, etc. The assumption is that the user never had access to modify /system, so wiping the cache and user data partitions results in a "factory fresh" condition.

No so much after you've haxxored up all sorts of stuff.

If you are looking to get back to as close to stock as possible, you are probably best off starting with the factory ODIN tarball, which I believe is still available on sammobile. It contains the boot, system, recovery, cache and two modem partitions (although it doesn't appear to contain an EFS image).

It would be interesting to see if a virgin device actually has this file. My suspicious is we are both missing this file because it never existed on the i957 in the first place. I believe another vector would be used to unlock the device, instead of the nv_data hack.

Futhermore, I believe the nv in nv_data means nvidia, who makes the Tegra chipset and associated radio modems which are used in devices based on Tegra. The i957 is based on the MSM8660 SOC, a Qualcomm part, which is an entirely different beast than the Tegra solution. Pretty much everything I can find online about hacking up nv_data.bin covers devices that are NOT based on Qualcomm SOCs, which in recent times is most devices not destined for LTE on AT&T or other similar carriers (Rogers/Bell/Telus).
6th July 2012, 01:41 PM |#5  
orlandoxpolice's Avatar
Senior Member
Thanks Meter: 242
The captivate had the nv data file and it was on a hummingbird chip which was the precursor to exynos

Sent from my SAMSUNG-SGH-I727 using xda premium
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes