FORUMS
Remove All Ads from XDA

[UTIL] Apktool - Tool for reverse engineering apk files

925 posts
Thanks Meter: 4,310
 
Post Reply Email Thread
3rd November 2019, 03:52 PM |#5861  
Spannaa's Avatar
Recognized Contributor / Themer
Flag Cardiff
Thanks Meter: 16,078
 
More
Quote:
Originally Posted by ALYSKY

I have this error
'apktool' is not recognized as an internal or external command, operable program or batch file.
How to fix it? What environment variable to copy? Enter? What?? The installation process is not explain. I don't know what to do to install it. Help me

There's a link to Help? FAQ? Wiki? in post #1
Follow this and you'll find everything you need including installation instructions.
The Following 2 Users Say Thank You to Spannaa For This Useful Post: [ View ] Gift Spannaa Ad-Free
28th November 2019, 01:55 PM |#5862  
joeherlev's Avatar
Senior Member
Flag Skovlunde
Thanks Meter: 129
 
More
APK not working on Android 10 ?
I have an APK for my EARPODS that makes popup like apple Airpods app.. But after phone is updated to Android 10, this app will no longer start up,,

Can anyone help please ?

LINK TO APP: https://drive.google.com/open?id=18a...Vo4-Sc25CT_owj
29th November 2019, 05:47 AM |#5863  
djdarkknight96's Avatar
Recognized Themer
Flag Springfield
Thanks Meter: 46,645
 
Donate to Me
More
Quote:
Originally Posted by joeherlev

I have an APK for my EARPODS that makes popup like apple Airpods app.. But after phone is updated to Android 10, this app will no longer start up,,

Can anyone help please ?

LINK TO APP: https://drive.google.com/open?id=18a...Vo4-Sc25CT_owj

Wait for the app dev to update maybe? Can't just add new OS support without building with it from original source.
The Following User Says Thank You to djdarkknight96 For This Useful Post: [ View ] Gift djdarkknight96 Ad-Free
30th November 2019, 12:32 AM |#5864  
iBotPeaches's Avatar
OP Recognized Developer
Flag Tampa
Thanks Meter: 4,310
 
Donate to Me
More
A new version has been released!

v2.4.1 (Released November 29th, 2019)

Quote:

  • Updated baksmali/smali to v2.3.4
  • Updated gradle to 5.6.2
  • [#2131] - Added support for Android Q (Android 10)
  • [#2086] - Fixed build issue with JDK9+ due to jmod change.
  • [#2058] - Fixed security issue with unpacking assets via directory traversal.
  • [#2027] - Fixed issue with api-level command not showing up.
  • [#2048] - Fixed issue with directory warning when not automatically making framework directory.
  • [#2045] - Fixed issue with mapping for codename "Q" release.
  • [#2046] - Fixed issue with raw qmg files not decoding properly.
  • [#2064] - Fixed issue copying assets to a directory that does not exist.
  • [#2063] - Fixed NPE with empty attributes during deserialization.
  • [#2084,#2018] - Fixed removal of META-INF/services. (Thanks adibfara)
  • [#2117] - Fixed support for "attr" bag type. (Thanks visigoth)
  • [#2093] - Fixed license headers on AOSP/Android4Me files.
  • [#2120] - Added enhanced wrapper for Windows. (Thanks Varstahl)
  • [#2051] - Added advanced command for skipping non-root dex packages.
  • [#2028] - Fixed issue with MIUI package names being renamed. (Thanks IgorEisberg)
  • [#1272] - Fixed issue with too long command due to uncompressed file list. (Thanks IgorEisberg)
  • [#2071] - Fixed issue with NPE on annotations.
  • [#1576] - Fixed issue with garbled attributes. (Thanks brianairb)
  • [#2226] - Fixed regression with --only-main-classes not usable. (Thanks realityJie)
  • [#2141] - Fixed issue with bugged Window aapt builds. (Thanks Furniel)
  • [#2105] - Fixed issue with JVM not knowing bitness on Windows.
  • [#1272] - Fixed issue with long path commands due to recording compression. (Thanks peret)

Download: https://bitbucket.org/iBotPeaches/ap...tool_2.4.1.jar
md5 - 8afe0ea0336139fd57eb504433d602e6
sha256 - bdeb66211d1dc1c71f138003ce35f6d0cd19af6f8de7ffbdd5 b118d02d825a52

Details of Release: https://connortumbleson.com/2019/11/...-4-1-released/
The Following 15 Users Say Thank You to iBotPeaches For This Useful Post: [ View ]
1st December 2019, 08:02 AM |#5865  
Quote:
Originally Posted by iBotPeaches

A new version has been released!

v2.4.1 (Released November 29th, 2019)



Download: https://bitbucket.org/iBotPeaches/ap...tool_2.4.1.jar
md5 - 8afe0ea0336139fd57eb504433d602e6
sha256 - bdeb66211d1dc1c71f138003ce35f6d0cd19af6f8de7ffbdd5 b118d02d825a52

Details of Release: https://connortumbleson.com/2019/11/...-4-1-released/

You are a true genius. I have had the longest time trying to decompile and recompile APK from nougat, and this release works perfectly. I am using Linux Ubuntu 16, and have had to use a much older version up until now, and even then it was 50/50. Now I am able to help alleviate some of the stress for the developer for the custom rom for my device by helping to fix some of the smaller things that don't work when porting or creating a new ROM for a new device.
1st December 2019, 09:36 PM |#5866  
[] AL []'s Avatar
Recognized Contributor
Thanks Meter: 4,630
 
More
yo! thanks for the update; much appreciated.

Now I did try 2.4.1 on Windows 8 with a couple famework_res.apk files of Oxygen OS, but it seems that I can't even get it loaded.

Getting: "Unsupported major.minor version 52.0"

Will go and re_read the last few pages here but puzzled...
2nd December 2019, 07:30 AM |#5867  
Spannaa's Avatar
Recognized Contributor / Themer
Flag Cardiff
Thanks Meter: 16,078
 
More
Quote:
Originally Posted by [

AL [];81074777]yo! thanks for the update; much appreciated.

Now I did try 2.4.1 on Windows 8 with a couple famework_res.apk files of Oxygen OS, but it seems that I can't even get it loaded.

Getting: "Unsupported major.minor version 52.0"

Will go and re_read the last few pages here but puzzled...

Are you using JRE 1.8 and is the same version set in your path environment variable?
The Following User Says Thank You to Spannaa For This Useful Post: [ View ] Gift Spannaa Ad-Free
3rd December 2019, 02:01 PM |#5868  
[] AL []'s Avatar
Recognized Contributor
Thanks Meter: 4,630
 
More
Quote:
Originally Posted by Spannaa

Are you using JRE 1.8 and is the same version set in your path environment variable?

No I believe I'm still on 1.7 Java due to SSD being completely full and unable to accommodate the update.

Good news is that new SSD should get here today: so once the cloning done, I'll give this a shot. Thanks.
3rd December 2019, 02:09 PM |#5869  
Spannaa's Avatar
Recognized Contributor / Themer
Flag Cardiff
Thanks Meter: 16,078
 
More
Quote:
Originally Posted by [

AL [];81090537]No I believe I'm still on 1.7 Java due to SSD being completely full and unable to accommodate the update.

Good news is that new SSD should get here today: so once the cloning done, I'll give this a shot. Thanks.

Hopefully it'll fix your issue - Java 8 (JRE 1.8) is listed under requirements on the apktool github
Post Reply Subscribe to Thread

Tags
apktool, apktools, customise apk, decompile, edit apk, recompile, reverse

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes