Remove All Ads from XDA

Samsung galaxy S3 stopped reading (32gb) SD card

1 posts
Thanks Meter: 0
By CHRiTTeR, Junior Member on 20th July 2012, 01:13 PM
Thread Deleted Email Thread

My brother got the new Galaxy S3 and its a verry nice phone. We got a 32gb SDcard for it and it worked perfectly for a few days, untill last week the phone suddenly refused to recognise/detect/read the SD card...

The card still works perfectly fine on a laptop, its only on the phone it doesnt work anymore. My brother doesnt recall doing anything special that could have caused this problem (last thing he did was updating the IMDB android app).

When we tried another (16gb) card and it reads just fine. So its not the phone either?!

Anyone has a clue what could be wrong here and how to fix it?

thank you!
27th July 2012, 06:33 AM |#2  
Senior Member
Texas, USA and Toronto,Canada
Thanks Meter: 55
use the fone to format the sd card
The Following User Says Thank You to cgigate For This Useful Post: [ View ] Gift cgigate Ad-Free
Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes