Remove All Ads from XDA

[SOLUTION] Samsung Mobile MTP Device -- CODE 10 error at Devicemanager

64 posts
Thanks Meter: 41
By LichtiMC, Member on 26th July 2012, 11:05 AM
Post Reply Email Thread
Hey people...
Just wanted to post a solution to a problem apparently a lot of users are experiencing...

When you first attach your phone to the pc by USB, the drivers have to be installed. (Here is a good ressource, where you can always dowload the latest drivers extracted from the Samsung Kies Package:

Now it could happen, that all of the drivers install successfully, but one of them, the "Samsung Mobile MTP Device", which cannot be installed, since there's always a CODE 10 (This device cannot start).

As I searched for quite a while for a working solution with no luck (there are different solutions, but none of them worked for me, as in my case it wasn't a faulty-driver problem...), i finally remembered a solution to a similiar case with a DVD-RW Drive. I tried the same process with my actual driver problem, and it worked right away...

  1. Go to the Registry Editor (Start --> Run --> "regedit" --> [ENTER])
  2. Search the following key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class\
  3. If you click one of the few subkeys in class (e.g. {4D36E965-E325-11CE-BFC1-08002BE10318}) you'll find the string value (Standard) on the right side with a value (e.g. DVD/CD-ROM-Drives)
  4. You have to find the value "Portable Devices" on the string value (Standard) (In my case {EEC5AD98-8080-425f-922A-DABF3DE3F69A}, but I don't know if they are called always the same.
  5. Once found, you see a string value called UpperFilters --> DELETE IT!
  6. Finished! Now your Samsung Mobile MTP Device should be recognized and even installed correctly right away. (The name of the device changed to GT-I9100 (Devicemanager) in my case...)
Here an explanation about UpperFilters and LowerFilters if you want to know more:

Maybe this short tutorial can save you some time... =)

Best regards to all of you!
The Following 40 Users Say Thank You to LichtiMC For This Useful Post: [ View ] Gift LichtiMC Ad-Free
16th August 2012, 10:45 AM |#2  
Junior Member
Thanks Meter: 0
Not solved
No such registry subkey as "Portable Devices"
What OS U use?
30th August 2012, 05:01 PM |#3  
Junior Member
Thanks Meter: 7
Thumbs up
Thank you for this, was trying to get a Samsung Galaxy Note to connect.
After having to manually point it to the drivers folder, they installed but would not start.

The registry keys seemed a little different to how you described, I am on Windows 7 64-bit, but found:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class\{EEC5AD98-8080-425F-922A-DABF3DE3F69A}\
Deleted the value "UpperFilters", plugged the USB back in, and it worked!

Now can happily sync using the Samsung Kies software.

( Note to others, backup first, right click the key tree you are editing, choose export. Run the .reg to restore any screw ups. )
The Following 7 Users Say Thank You to whoisrich For This Useful Post: [ View ] Gift whoisrich Ad-Free
2nd September 2012, 07:40 AM |#4  
Flag Oakland, CA
Thanks Meter: 3
I gave up trying to use Kies. I am using windows 7 64. I found the correct folder but there is no value "Upper filter" showing. I also have a Philips Go Gear Muse player and It uses the Songbird software. Songbird also works with the samsung galaxy 4.2 player in mass storage mode.
The Following User Says Thank You to kosenn For This Useful Post: [ View ] Gift kosenn Ad-Free
6th September 2012, 03:10 AM |#5  
Junior Member
Thanks Meter: 0
Thanks worked great!!!!
Kinda late though. haha
19th September 2012, 03:16 AM |#6  
orlandoxpolice's Avatar
Senior Member
Thanks Meter: 242
I have no UpperFilters Key
23rd September 2012, 03:20 PM |#7  
Junior Member
Thanks Meter: 0
Talking You legend!!!!
thank you so so much i signed up to this forum just to say thank you, i had tried everything and was reading solutions that i just knew before even trying that they wouldnt work.

anyway i read this seemed exactly what i needed and yes it did work

so thank you very much its been a long week of trying to find fixes for this!!!!!
24th September 2012, 07:12 AM |#8  
Thanks Meter: 8
Originally Posted by orlandoxpolice

I have no UpperFilters Key

Same here no UpperFilters key.
Any other suggestions?
The Following User Says Thank You to sb0 For This Useful Post: [ View ] Gift sb0 Ad-Free
13th October 2012, 07:41 PM |#9  
wwjoshdew's Avatar
Recognized Contributor
Thanks Meter: 1,402
Thanks for this guide, and Eric for linking me to it!
28th October 2012, 04:08 PM |#10  
cadcat's Avatar
Junior Member
Thanks Meter: 4
Talking Samsung MTP Driver fix
Thanks for your fix for this problem- it was driving me crazy!
I did find that the only UpperFilters key that needed to be removed was for the USBSTOR entries.
Also, I think that anyone trying this- Make a Reg backup first....
Thanks again.
31st October 2012, 02:55 AM |#11  
mr_ding's Avatar
Senior Member
Flag Toronto
Thanks Meter: 2
Use *#7284# to enter PhoneUtil mode, Press (Qualcomm USB Settings), and change it to 'MTP + ADB' mode.

Then MTP should work fine.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes