FORUMS
Remove All Ads from XDA

[SOLUTION] Samsung Mobile MTP Device -- CODE 10 error at Devicemanager

64 posts
Thanks Meter: 41
 
By LichtiMC, Member on 26th July 2012, 11:05 AM
Post Reply Email Thread
4th December 2014, 10:07 AM |#81  
Junior Member
Thanks Meter: 0
 
More
Damn! I have read the whole ticket! All registry and other things failed. But that simple Microsoft exe solved my problem
Thanks

Quote:
Originally Posted by as_usual150

ALTERNATIVE SOLUTION

1 - Remove MTP from device manager with exclamation mark
2 - Install the Microsoft User Mode Driver Framework for WinXP (I couldn't paste the link)
3 - Connect your phone and wait for windows to recognize your device

 
 
30th January 2015, 09:36 PM |#82  
Junior Member
Thanks Meter: 0
 
More
Thumbs up
It Dees Not Work,for me....
What worked for me is....


http://forum.xda-developers.com/show....php?t=1150211

please refer to the first post,if your using XP,and install Microsoft_User-Mode_Driver_Framework_Install-v1.0-WinXP_2.exe
This is what worked for me,Thank You Very Much!!!!!
13th March 2015, 08:37 PM |#83  
Junior Member
Thanks Meter: 3
 
More
Smile
Quote:
Originally Posted by wicpp

I am having Windows XP SP3 and I was experencing the same USB MTP installation failure, I updated my Windows Media Player and it fixed the problem. The option in Windows Media Player Help->Check for updates was not working, so I downloaded Media Player from Microsoft webiste and installed it and after that driver is now working fine.

I was searching for Motorola MTP driver, tried a dozen, not worked... but your trick worked for me. Thanks a lot...
16th April 2015, 01:43 PM |#84  
Junior Member
Thanks Meter: 0
 
More
Talking Thank you Thank you
Quote:
Originally Posted by hricardo

I've read all the 8 pages of this thread, and no solution was good for me (no UpperFilters, no clear data, no Kies reinstall, etc.).

But I ran into a very simple solution that finally allowed the S4 to be recognized:

- Disconnect your S4 from your PC.
- Unmount your SD card from the Storage menu.
- Turn off your phone and remove the SD card.
- Turn on your phone and after boot, reconnect the phone to your computer. Now it should be able to recognize your Galaxy S4.
- Disconnect your phone, turn it off and reinsert your SD card.
- Turn on your phone and after boot, reconnect the phone to your computer. Now you can see the SD content

Original thread I've found this answer (new user, not allowed to post a link yet):
answers.microsoft.com/en-us/windows/forum/windows_7-hardware/samsung-galaxy-s4-mtp-device-driver-wont-install/d2d011f8-d776-488e-b2f7-3eaf00c1031a

Hopefully this help other here!

After several hours of annoying dead ends, this solution worked.
I am so thrilled that I created an account just to say "Thank you".
Thank you!
5th May 2015, 10:03 PM |#85  
Member
Thanks Meter: 2
 
More
There are many weird claimed solutions to this, none of which worked for me, but i think most will find that it is because you have uninstalled, or never installed (n versions) windows media player, or something just screwed up something related up.

It appears that the samsung drivers are not stand alone, Shame on Samsung, and use stuff which in windows appears to be only in WMP.

First install the samsung usb drivers.

Then install windows media player, I assume like me you don;t want to use this POS so unselect all associations you can except mpt which is probably right at the bottom.

You will now find your phone and its storage is available.

New problem may be that you lose all your preview images when viewing folders. More WMP crap (although other multimedia programs also screw these up.
Get babelsofts free media preview program, select everything and apply and watch your previews reappear without losing access to your phone.

I'm not sure what the oldest version of WMP you can get away with is. (why - wmp gets more intrusive with later versions)
24th May 2015, 09:50 PM |#86  
Junior Member
Thanks Meter: 7
 
More
Tried everything in this thread.

I give up.
26th May 2015, 11:21 AM |#87  
Junior Member
Thanks Meter: 2
 
More
it's a typo , it's actually called 'Control'
2nd June 2015, 08:03 AM |#88  
Junior Member
Thanks Meter: 0
 
More
sometimes this command will solve problem. type it in CMD :

Net localgroup Administrators local service /add
5th June 2015, 12:36 AM |#89  
Member
Thanks Meter: 8
 
More
Quote:
Originally Posted by Robcr

It appears that the samsung drivers are not stand alone, Shame on Samsung, and use stuff which in windows appears to be only in WMP.

Not quite correct.

Samsung MTP mode- via their USB drivers installation for Windows- requires an installation of Microsoft .Net Framework 3.0 or later.

WMP requires the same .Net Framework prerequisite- you might not have seen it being installed (silent install mode) when WMP is installed or set up.
1st July 2015, 05:26 PM |#90  
vineet381's Avatar
Senior Member
Flag New Jersey
Thanks Meter: 158
 
More
I am getting code 10 on my LG G3 and dont see Upperfilter. Would these solution (creating Upper filter/ upgrade windows media player etc) work for any device or is it only specific to Samsung? My issue is I am stuck on bootloop and cannot go into recovery. I can go to download mode to go back to stock but flashing stock is failing may be due to this MTP error.
10th August 2015, 11:31 PM |#91  
Junior Member
Thanks Meter: 0
 
More
Thumbs down
Quote:
Originally Posted by GodsGift

Outstanding..... this worked perfectly.

Then I read this and BOOOM all good.

!

I am not sure why you do this, it could be that you are making money with adsense, we do not get any value from your simple work like the above.

What do you mean by "Then I read this and BOOOM all good."

We can not see the solution here!

We need solution here.

Thanks
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes