Remove All Ads from XDA
Honor 9 Lite

[Solved] bricked defy Step by Step Walkthrough

101 posts
Thanks Meter: 68
By rtk217, Senior Member on 1st August 2012, 01:13 AM
Post Reply Email Thread
Original message

:I need some serious help.
I tryed to flash custom 2.3.6 fixed sbf.
which didnt end well, after powerup i would go straight to bootloader with err codes.
so tryed to flash another stock SBF, that ended me in inifinte bootloop with android logo. after 20 minutes in bootloop i gave up and flashed another stock SBF this time it was cellcom israel sbf, it finished the flashing succesfully but now the phone wont powerup at all. not bootloader not recovey.

I really need your help here, any kind of insights will help. please this is urgent.

BTW: this is a red lense defy, last rom was JB 4.1.1 quarx 30.07 build.
the sbf was supposed to have the same rom.

update 1: managed to finally flash stock, cant enable 3g. phone is still rooted, installing superuser is succesfuly but doesnt control attributes. so 2ndinit currently does not work,

issue solved

UPDATE 16/11/2012: links check and updated everything should work.

1. first get these files as we'll need all of them: Rsd lite (download and install that),
Motorola drivers (download and install: Here)
JORDN_U3_97.21.51.rar(contains sbf file):
firmware.rar(contains another sbf file):
2ndinit 1.4.2, and 2ndinit 2.3 (can be found here:
also need the nandroid backup:

[Optional] file installing from recovery:

2. [Optional] I didn't have a router at my house and no signal at my phone and i needed internet for 2ndinit, so i installed a program that turns my wifi on the computer into a hotspot, it can be found here:

3.First shutdown your phone, hold the Vol down and boot the phone up keeping the volume down pressed. you should come up to a triangle android logo, press the vol up and down key and then tap the screen ( this is a touch screen gui), choose the wipe data/cache and press ok, this should take up to 5 minutes.

4. Now, shut down the phone (pull the battery out and return it back in), Hold the Vol Up button and power up your phone.
you will enter the Bootloader (or BL as its called in the forums) and you should see the phone stating that (usually 9.10 version)

5. after installing Rsd lite, launch it, extract the JORDN_U3_97.21.51.rar and firmware.rar files into root directory (C:\ or D:\ or whatever).
in rsdlite press the


button and choose the JORDN_U3_97.21.51.sbf file.
connect your phone via a usb cable to your computer, the phone should state its connected. and you should see on the rsdlite window that a device is connected, click on it and press the button :"start".
let it finish and boot on itself (it should do that).

6. [Optional] if you started with low battery now is a good time to charge your phone.

7. transfer the 2ndinit 1.4.2 apk and the 2ndinit 2.3 apk into a folder in your sd card (name it "A" for ease of use).
also extract the into this folder on your sd card "/clockworkmod/backup/"

8. extract the superoneclick on your computer and launch it, while the phone is connected (should also be in usb debugging mode), press the root button in the superoneclick window and watch the magic, make sure you also install busybox (should be installed automatically when pressing the ROOT button).

9. disconnect your phone, use the file explorer provided with this rom and make sure you check with a "V" to "allow 3rd party apps" in the settings. install the 2ndinit1.4.2.apk file.
open the app after installation and make sure you have internet connectivity, press the install bootmenu option.(now pop-ups should appear regarding permissions, choose "allow" for all of them).
after the green led has turned on, go to settings menu under application/development and turn off the "usb debugging mode".

10. restart your phone and make sure you press the vol down button when the led turns blue during the bootup.
when in bootmenu, choose recovery-> custom recovery.
when in recovery, choose "wipe data/factory reset", "wipe cache", "advanced-> wipe dalvik".
now return to recovery menu and choose "backup/restore"->"restore->2011-06-".
this should take a couple of minutes.
when its done, go back again to recovery menu, and choose again "wipe cache", "advanced-> wipe dalvik".
power off the phone.

11. hold the vol up button once again and power up the phone to go into bootloader screen.
connect your phone once again to your computer and on the rsdlite window choose the "firmware.sbf" file.
press start and flash it.

12. let the phone boot up, congrats you just revived your phone, root it once again using super one click (if needed), install the 2ndinit2.3.apk.
transfer whatever rom you like (dont try sbf's cause that's how I first got in this mess), reboot phone, go into stock recovery and install that zip after wiping data/factory reset. and ohh well you know the rest.

Good luck.
P.S if you can't or dont know where to find the files take a quick search in the forums and youll find most of them.
The Following 13 Users Say Thank You to rtk217 For This Useful Post: [ View ] Gift rtk217 Ad-Free
1st August 2012, 10:14 AM |#2  
OP Senior Member
Thanks Meter: 68
2nd August 2012, 12:16 PM |#3  
OP Senior Member
Thanks Meter: 68
3rd August 2012, 03:52 PM |#4  
Junior Member
Thanks Meter: 0
when i flash it takes me back to Android Bootmenu when it reboots please help. thanks
3rd August 2012, 06:08 PM |#5  
OP Senior Member
Thanks Meter: 68
Shouldnt happen, make sure you Wipe Data, and cache, before the nandroid backup and after the nandroid backup.
only then u can flash the firmware.sbf
if the bootmenu still comes up simply choose "Boot-> set default-> normal". and reboot.
if still comes back to bootmenu (and i hope you are talking about bootmenu and not bootloader). install through custom recovery your favorite ROM and don't forget the corresponding Kernel.
good luck!
28th September 2012, 07:52 PM |#6  
hessamx's Avatar
Senior Member
Thanks Meter: 10
Is that work with bl7 ???
9th November 2012, 05:55 PM |#7  
Junior Member
Thanks Meter: 0
I've been trying to restore my phone for weeks, up until this thread, I started to think the internet couldn't help me. You are a god amongst men.
16th November 2012, 12:31 AM |#8  
Senior Member
Thanks Meter: 35
OK, banging my head against a wall here; I have 2 defy's. Mine has been to a war zone 4 times, I've replaced the screen (and the waterproof gasket) once, It's broken (the case) but still works except for the fact that the last time I had to flash an sbf I messed up the charging ability with the "macguyver" method.
Now I recently got a pristine looking red lens defy from a friend who said it wasn't booting...It "tried" but never stayed booted long. I tried immediately flashing one of the fixed sbf's with CM10 on it, and ever since I get the bootloader 09.10 code corrupt message.
I've tried the method listed here (by the way the first firmware in OP won't download for me, something about violating some terms of agreement?) the one labeled simply "firmware" downloaded.
Still no joy. Every flash I get all the way through code group 32 checksums match. Everything after that fails. Have tried multiple CEE, Nordic, Chinese, even Defy+ sbf (the new defy has red lens) with no luck.
Likewise when I tried flashing via linux (sbf_flash). The other night after battery out for quite awhile it led me to believe it had started working, and allowed me to get into recovery and wipe everything, but it was all false hope. It still did not boot (motorola M boot loop) and likewise, it still did not flash.
Anyone have any ideas how I can proceed to fix this thing?
I thought I had this thing figured out but obviously I was mistaken.

thanks in advance
16th November 2012, 05:46 PM |#9  
OP Senior Member
Thanks Meter: 68
I just unbricked my phone again yesterday after trying the latest cm10 sbf with no luck, so i can guarantee this method still works, however the firmware.sbf file is really needed and also the nandroid backup, so here's what i'll do:
1. i'll check what links are broken and reupload the necassery files.
2. I'll clean the the first message and update the links
so check back in about an hour
The Following User Says Thank You to rtk217 For This Useful Post: [ View ] Gift rtk217 Ad-Free
2nd December 2012, 06:48 AM |#10  
Junior Member
Thanks Meter: 2
Thanks a lot for posting this. Tried to restore my phone using lot of other posts since the last 3 to 4 days days, but all in vain.

Was anybody able to install CM10 over this? After the installation, the phone is going into boot loop.
2nd December 2012, 11:06 PM |#11  
Senior Member
Flag Gold Coast
Thanks Meter: 44
Donate to Me
Thanks rtk217 for starting this guide very useful for noobs...

I've made some video tutorials using a few of the guides in the forums here...

hope it helps someone...

Its a complete step by step.

Part 1 of 4. This part deals with preparation of all the required files to successfully complete the custom rom installation.

Part 2 of 4. How to restore Defy to default

Part 3 of 4. How to root using SuperOneClick and install clockworkmod.

Part 4 of 4. How to install 2ndinit recovery and install CyanogenMod 10 Jelly Bean 4.1.2
The Following User Says Thank You to locn For This Useful Post: [ View ] Gift locn Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes