FORUMS
Remove All Ads from XDA
H10 Turbo

[Mod] Enable Shutter Sound Option [How To] JellyBean ;P

136 posts
Thanks Meter: 161
 
By s3.Zeke, Senior Member on 25th September 2012, 02:59 AM
Post Reply Email Thread
I have seen the how to enable thread (Thanks freeza!), but this is how I found to make the feature functional. Enable Shutter Sound (Working)

Note: In the Jelly Bean LIF Update, the build.prop no longer forces CameraSound, If you have updated to Jelly Bean, ignore step one.

Step One: First we make an edit to the build.prop file located in "/system/build.prop"

Edit the following line:

#add camera sound property for SPR concept
ro.camera.sound.forced=1

To look like this:

#add camera sound property for SPR concept
ro.camera.sound.forced=0


Step Two: So far we have changed the build.prop, now we will change an option in the feature.xml located in "/system/csc/feature.xml"

Edit the following line:

<CscFeature_Camera_ShutterSoundMenu>false</CscFeature_Camera_ShutterSoundMenu>

To look like this:

<CscFeature_Camera_ShutterSoundMenu>true</CscFeature_Camera_ShutterSoundMenu>

So now we will save these files and replace them with the originals.

Reboot and enjoy the ability to turn off the shutter sound when you please, and re enable it when you please as well!

Let me know if you need any help.

Hit the thanks button!
The Following 23 Users Say Thank You to s3.Zeke For This Useful Post: [ View ] Gift s3.Zeke Ad-Free
 
 
26th September 2012, 06:47 AM |#2  
Senior Member
Flag STL
Thanks Meter: 82
 
More
Quote:
Originally Posted by s3.Zeke

I have seen the how to enable thread, but this is how I found to make the feature functional. Enable Shutter Sound (Working)

First we make an edit to the build.prop file located in "/system/build.prop"

Edit the following line:

#add camera sound property for SPR concept
ro.camera.sound.forced=1

To look like this:

#add camera sound property for SPR concept
ro.camera.sound.forced=0


So far we have changed the build.prop, now we will change an option in the feature.xml located in "/system/csc/feature.xml"

Edit the following line:

<CscFeature_Camera_ShutterSoundMenu>false</CscFeature_Camera_ShutterSoundMenu>

To look like this:

<CscFeature_Camera_ShutterSoundMenu>true</CscFeature_Camera_ShutterSoundMenu>

So now we will save these files and replace them with the originals.

Reboot and enjoy the ability to turn off the shutter sound when you please, and re enable it when you please as well!

Let me know if you need any help.

Hit the thanks button!

Yes thats exactly what I figured out on the thread I linked below days ago but nobody really seen it.

http://forum.xda-developers.com/show...1771205&page=9
The Following 3 Users Say Thank You to E-POUND For This Useful Post: [ View ] Gift E-POUND Ad-Free
26th September 2012, 07:32 PM |#3  
s3.Zeke's Avatar
OP Senior Member
Thanks Meter: 161
 
More
Quote:
Originally Posted by E-POUND

Yes thats exactly what I figured out on this thread days ago but nobody really seen it.

http://forum.xda-developers.com/show...1771205&page=9

Yeah but it was missing the build.prop tweak. This show to get the menu and make it functional!

Sent from my SPH-L710 using xda app-developers app
The Following User Says Thank You to s3.Zeke For This Useful Post: [ View ] Gift s3.Zeke Ad-Free
26th September 2012, 07:40 PM |#4  
Senior Member
Flag STL
Thanks Meter: 82
 
More
Quote:
Originally Posted by s3.Zeke

Yeah but it was missing the build.prop tweak. This show to get the menu and make it functional!

Sent from my SPH-L710 using xda app-developers app

No it also has the build.prop tweak. Read my post on the link. 2nd post down. Your fix is the exact same fix I posted on that thread days ago. Take a look.
The Following User Says Thank You to E-POUND For This Useful Post: [ View ] Gift E-POUND Ad-Free
26th September 2012, 08:34 PM |#5  
s3.Zeke's Avatar
OP Senior Member
Thanks Meter: 161
 
More
Quote:
Originally Posted by E-POUND

No it also has the build.prop tweak. Read my post on the link. 2nd post down. Your fix is the exact same fix I posted on that thread days ago. Take a look.

Yeah all I saw is freeza's post...

Sent from my SPH-L710 using xda app-developers app
26th September 2012, 09:04 PM |#6  
s3.Zeke's Avatar
OP Senior Member
Thanks Meter: 161
 
More
Quote:
Originally Posted by E-POUND

No it also has the build.prop tweak. Read my post on the link. 2nd post down. Your fix is the exact same fix I posted on that thread days ago. Take a look.

So I read through and saw your comment. So the difference is this being a complete post specific to the shutter sound. Thanks any way bro.

Sent from my SPH-L710 using xda app-developers app
26th September 2012, 10:10 PM |#7  
Senior Member
Flag STL
Thanks Meter: 82
 
More
Quote:
Originally Posted by s3.Zeke

So I read through and saw your comment. So the difference is this being a complete post specific to the shutter sound. Thanks any way bro.

Sent from my SPH-L710 using xda app-developers app

Yes Zeke, I completely realized that. All Im asking is shouldn't the creator of the modification be giving proper acknowledgement? Or link to the original creators thread so pple will know who exactly had parts into the creation? Instead of making a new thread like the OP of the new thread is the original creator. When I created the SAME MOD thats in this thread 3 to 4days before you posted ur thread I even quoted Freeza for one part(/system/csc/feature.xml file edit) and Kitcar from a Epic Touch thread for the other part (the build.prop) edit.

All I did was take both parts, from two different forums and put them together and posted the solution on the same thread that was talking about the problem. I combined Freeza's mod with Kitcar's mod and the shutter on and off worked with the menu button. Then I posted the solution for everyone to see in the same thread. Im not trying to take props from u I just think pple should have been linked to that thread or my post if they wanted to know who had something to do with the modification instead of making a whole new thread about it, with out links to the orignal thread because the solution was in there. Freeza could of even updated the orignal post with the solution and gave proper acknowledgement when ever he had time.
The Following User Says Thank You to E-POUND For This Useful Post: [ View ] Gift E-POUND Ad-Free
26th September 2012, 10:24 PM |#8  
freeza's Avatar
Recognized Developer
Flag Pasadena, CA
Thanks Meter: 13,489
 
Donate to Me
More
Quote:
Originally Posted by s3.Zeke

I have seen the how to enable thread, but this is how I found to make the feature functional. Enable Shutter Sound (Working)

First we make an edit to the build.prop file located in "/system/build.prop"

Edit the following line:

#add camera sound property for SPR concept
ro.camera.sound.forced=1

To look like this:

#add camera sound property for SPR concept
ro.camera.sound.forced=0


So far we have changed the build.prop, now we will change an option in the feature.xml located in "/system/csc/feature.xml"

Edit the following line:

<CscFeature_Camera_ShutterSoundMenu>false</CscFeature_Camera_ShutterSoundMenu>

To look like this:

<CscFeature_Camera_ShutterSoundMenu>true</CscFeature_Camera_ShutterSoundMenu>

So now we will save these files and replace them with the originals.

Reboot and enjoy the ability to turn off the shutter sound when you please, and re enable it when you please as well!

Let me know if you need any help.

Hit the thanks button!

Nice find! Great job.
The Following User Says Thank You to freeza For This Useful Post: [ View ]
26th September 2012, 11:47 PM |#9  
s3.Zeke's Avatar
OP Senior Member
Thanks Meter: 161
 
More
Quote:
Originally Posted by E-POUND

Yes Zeke, I completely realized that. All Im asking is shouldn't the creator of the modification be giving proper acknowledgement? Or link to the original creators thread so pple will know who exactly had parts into the creation? Instead of making a new thread like the OP of the new thread is the original creator. When I created the SAME MOD thats in this thread 3 to 4days before you posted ur thread I even quoted Freeza for one part(/system/csc/feature.xml file edit) and Kitcar from a Epic Touch thread for the other part (the build.prop) edit.

All I did was take both parts, from two different forums and put them together and posted the solution on the same thread that was talking about the problem. I combined Freeza's mod with Kitcar's mod and the shutter on and off worked with the menu button. Then I posted the solution for everyone to see in the same thread. Im not trying to take props from u I just think pple should have been linked to that thread or my post if they wanted to know who had something to do with the modification instead of making a whole new thread about it, with out links to the orignal thread because the solution was in there. Freeza could of even updated the orignal post with the solution and gave proper acknowledgement when ever he had time.

Okie Doke. Don't get your panties in a bunch



Sent from my SPH-L710 using xda app-developers app
The Following User Says Thank You to s3.Zeke For This Useful Post: [ View ] Gift s3.Zeke Ad-Free
26th September 2012, 11:49 PM |#10  
s3.Zeke's Avatar
OP Senior Member
Thanks Meter: 161
 
More
Quote:
Originally Posted by freeza

Nice find! Great job.

Worked off of your thread freeza. And I will edit to link you in. My apologies freeza.


Now I hope all is squared.

Sent from my SPH-L710 using xda app-developers app
27th September 2012, 01:54 AM |#11  
Senior Member
Flag STL
Thanks Meter: 82
 
More
Quote:
Originally Posted by s3.Zeke

Okie Doke. Don't get your panties in a bunch



Sent from my SPH-L710 using xda app-developers app

Lol Boxer Briefs here Zeke... i just hate when people take credit for my work. U put 'Hit the Thanks button" below ur post like you should be given thanks for my MOD. I created this MOD with a little searching and you made a thread about it. That it.

Like I said im not trying to steal ur props Im just saying give credit where credit is due. Yes im just a Junior Member so maybe thats y u dont want to give me credit for being the original finder of this MOD but you will just credit Freeza because it was found in his thread. But i am the one who posted this Camera MOD/FIX in Freeza's thread before you made THIS thread about it.
The Following 2 Users Say Thank You to E-POUND For This Useful Post: [ View ] Gift E-POUND Ad-Free
Post Reply Subscribe to Thread

Tags
camera, how to, mod, s3.zeke, zeke

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes