HTC Desire z G2 WiFi produces Error when turned on -SOLVED

3 posts
Thanks Meter: 0
By e4services, Junior Member on 27th September 2012, 09:38 PM
Post Reply Email Thread
OK, I have been battling this problem for weeks now; Turning 'On' WiFi almost instantaniously produces "Error" below the button and it does not work.
First of all this device is an Oversea version that I purchased. Sold as "htc Desire Z a7272 1.5gb UNLOCKED"
Second, internally it represented itself as "T-Mobile G2"

I read all the people that had the same issue, no more WiFi. One user thought the this may have first occured when the phone updated to 2.2 over the air in the U.S.; and yes this device said 2.2 as the current OS. I tried very thing that was suggested #*#* stuff, RUU's of all kinds, even called HTC, which by the way were extremely helpful, but no solutions.
The HTC Update for the G2 by all accounts, including HTC, should be the one not WWE version of China TW.
G2RUU2012.exe is available direct from HTC for 2.3.4. I think in the update it show the phone was 1.19 then it show 1.22 (each ruu seemed to see it different)and was going to load 2.?? or something
Running RUU produced Error 156 Image error or Error 130 Model ID Error
Tried adb.exe and putting the renamed on the SDcard and HBOOT. Starts to load but also produces "ModelID incorrect"

Strangely enough my helpful HTC Tech pointed me back to this forum and suggested trying to root the phone and get an update loaded. He also suggested sticking with the G2 update for the s/n of the phone came back as a G2 not a Desire Z even though he said the IMEI was not attached to that s/n. Dang Chinese. Anyway I kept reading. Yes, reading the log file shows the WiFi drive failing to load so could be hardware or the 2.2 update had something wrong? My Bluetooth worked by the way. Ran into one post that suggested that he might not have had a SD card in the phone when the update hit and THAT caused an error in the update, I keep coming back to the strangeness of the phone, some cluge, 1.5GB, not 4GB of the US G2.
ANYWAY, after reading NOT to perminently root the G2 and hearing the HTC guy say the same, try and stick to the G2 flash for now not knowing what the board was exactly, I found the Visionary+ Temproot Method which sounded a good way to try and get to the current 2.3 from HTC. THe write up assumed you could get to Google Apps (I have no data plan) so how do I get apps to the phone. More searching.
Found and Installed CNET's Android Injector, SWEET, to push apps onto the phone. Works great
Found a Internet Download of ASTRO File Manager apk
Found the Internet Download for com.modaco.visionaryplus.r14.apk
Already had the G2RUU2012.exe from HTC (you need to run to the first screen, stop, go o your Windows TEMP directory, open the last folder made there adn the subfolder and find the, copy and rename
Connected the phone through USB and turn on USB Storage
Copied com.modaco.visionaryplus.r14.apk to the SD card.
Copied the G2RUU2012 to the SDcard (TMobile Android 2.3.4)
Now Turned off USB Storage.
Goto "Applications"
Check "Unknown Sources"
then select "Developement"
Check "USB Debugging"
Now you are good to go.
With Android Injector installed, double click on the ASTRO apk, opens Injector and go ahead and install it.
Go to the phone, start ASTRO, open the External SD Card, and run the Visionary apk
In Visionary check the Temproot on reboot, then press the Temproot Now
When it finished, I powered down the phone and restarted in HBOOT (hold Volume Down button and then press the Power button)
When HBoot screen came up, the G2 Flash ACTAULLY COMPLETED! All is working again and I am on the lasted Android version for the phone.
27th September 2012, 09:44 PM |#2  
OP Junior Member
Flag Boulder, CO
Thanks Meter: 0
Oh, Forgot
eek:H, I forgot, I was doing this on a GOLDCARD created from my SD Card using SImple Goldcard. From what I had read it was required, and this program created a correct goldcard easily.
30th December 2012, 04:37 PM |#3  
Junior Member
Thanks Meter: 0
good day bro. i need your help my bluetooth and wifi are not working too on my htc desire z. can u assist by mailing [email protected]. we need to talk. i will be expecting your mail
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes