Remove All Ads from XDA

[How-To] Update to Jellybean if you're having problems with OTA

19 posts
Thanks Meter: 22
By Protato, Junior Member on 28th September 2012, 01:55 PM
Post Reply Email Thread
So after trying multiple times to update my tablet an failing everytime. I checked the last_log file in /cache/recovery and found out that the reason the update was failing because I've deleted Netflix.apk from /system/app.
Since I did not backup the application I had no way to use the OTA, however after a few hours research I found out a method to completely restore the system to stock.

Part 1: Restoring Tablet to Stock
1. Download the system dump that matches your current software:
WW - - MD5 - 68D41197B399967B7F6789E47683A0D7
US - - MD5 - DF17D3129378E9A7F81C58AF7BF5396B
TW - MD5 - 3999B0E052211AA53ED1DB5D06A02AD3
2. Unzip the compressed firmware file to the root directory of a MicroSD card (external). Only extract this once so your sdcard should look something like this:
3.With your Transformer turned on, insert the MicroSD into the MicroSD card slot.
4. An exclamation mark should appear in the notification area.
5. Tap the mark and proceed with the update.
6. Your tablet should now reboot and proceed to update the tablet, if you get an error try redownloading the update and trying again.

Part 2: Rooting your Tablet
Voodoo root keeper didn't save my root after part 1, so to root it I used Debugfs automated root:
After your tablet is rooted you should use OTA root keeper to backup your root.

Part 3: Manual Update to Jellybean
1.Download the dlpkgfile for your system, I uploaded the US file: <--------------- US ONLY don't try if your tablet is not on US firmware, it might brick
WW version dlpkgfile <--------------- WW ONLY don't try if your tablet is not on WW firmware, it might brick
The WW update file (thanks for kikistans for uploading):

2. Place the dlpkgfile on your tablet's storage, MAKE SURE THE dlpkgfile does not have a .zip extension, the file has no extension!
3. Download ES File manager and go to settings>root settings and tick all the boxes.
4. Copy dlpkgfile to /cache
5. Go to /cache/recovery and create a new file named command
6. Open the file as a text and place the following code in it and save:
7. Turn off the tablet
8. Press and hold volume down+power until the tablet vibrates then release power and keep holding volume down
9 When a text shows on the boot logo screen release volume down and click volume up
10. The tablet should now start updating, it'll take about 30 minutes and once the tablet boots you'll have jellybean
11. Restore root with root keeper

This method should work for everyone with a locked bootloader

Sorry I've been busy, it seems like some people are missing 3 files, follow this thread if you're missing those files:
Also some people are reporting that their tablet is get bricked, MAKE SURE THAT YOU'RE USING THE RIGHT FIRMWARE UPGRADE
new-tilus has reported that this method worked for his stock unlocked tablet.
The Following 22 Users Say Thank You to Protato For This Useful Post: [ View ] Gift Protato Ad-Free
28th September 2012, 02:13 PM |#2  
Senior Member
Thanks Meter: 14
I used the last part more our less. Ota rootkeeper claims I have root. But I don't. Photocopier still keeps root access, but I cannot gain any new root access.

Sent from my SAMSUNG-SGH-I717 using xda premium
28th September 2012, 02:47 PM |#3  
lukcinek's Avatar
Senior Member
Thanks Meter: 9
It doesnt work for me. Im on .28 stock WW version. It starts but then appears android with red trangle
28th September 2012, 02:48 PM |#4  
Thanks Meter: 15
Originally Posted by lukcinek

It doesnt work for me. Im on .28 stock WW version. It starts but then appears android with red trangle

Same here, no success for me either...
28th September 2012, 03:14 PM |#5  
ridikolous's Avatar
Senior Member
Thanks Meter: 148
Didn't work

Sent from my Transformer Prime TF201 using xda premium
28th September 2012, 03:34 PM |#6  
Senior Member
Flag Pune
Thanks Meter: 15
Do we really need to go thru the hardship? Isn't ASUS going to fix it?
The Following User Says Thank You to sly.cooper For This Useful Post: [ View ] Gift sly.cooper Ad-Free
28th September 2012, 03:41 PM |#7  
pandaball's Avatar
Inactive Recognized Developer
Thanks Meter: 1,754
I think it must be noted that the OTA update for a WW variant will not work on a US variant, a DE will not work on TW and so on. The SKU for the OTA must match the SKU of the Prime in question.
28th September 2012, 03:42 PM |#8  
lukcinek's Avatar
Senior Member
Thanks Meter: 9
It works. It doesnt befor becouse I didnt delete .bin from name of the file
28th September 2012, 03:50 PM |#9  
Senior Member
Flag Duluth
Thanks Meter: 110
Uh, fix what? ASUS is in the business of doing firmware updates for stock + unlocked devices.
28th September 2012, 04:13 PM |#10  
Senior Member
Thanks Meter: 53
Thumbs up
Originally Posted by Spidey01

Uh, fix what? ASUS is in the business of doing firmware updates for stock + unlocked devices.

It seems to work here, I did exactly what "Protato" wrote and it's been loading the new JB for more than 10 minutes and no triangle yet

It worked I am on JB 4.1.1, forllow the instructions "literally" and it will work!
28th September 2012, 04:33 PM |#11  
Junior Member
Thanks Meter: 0
by far the simplest instructions to follow
i was having the same issue as most of you, i was (stock) rooted and applied the OTA update. i did have OTA root keeper, but my update failed and i lost root. i did a factory reset of (US version) after a backup, then i rooted using DebugfsRoot_Generic. i more or less performed part 3 of this thread although i had to add three missing files to /system/xbin/ (maybe if i would have applied the stock file i could have skipped this step). i forgot to restore my backup before i applied the update so i lost root. updating and keeping root may require SuperSU instead of SuperUser, from what i read last night. i hope this helps, thanx to all the people out there, especially @Wipeout and @Trekest from the post below, as well as @sparkym2 for Debugfs and @1wayjonny for Universal Naked Driver 0.7 and @Protato. good luck, i wish this thread was around yesterday evening, it would have saved me hours...

missing files from the below thread post #111
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes