FORUMS
Remove All Ads from XDA

[MOD][AOSP/CM10]Bluetooth Phone Audio Fix - Patch with Source

5,916 posts
Thanks Meter: 12,727
 
By krarvind, Senior Member on 5th October 2012, 01:44 AM
Thread Closed Email Thread
5th October 2012, 10:53 AM |#11  
krarvind's Avatar
OP Senior Member
Flag Saint John, NB
Thanks Meter: 12,727
 
Donate to Me
More
Quote:
Originally Posted by ManelScout4Life

So dafoxs, the zip fix is working on all the ROMs?

Kravind can I post links in my threads? You will get credit of course.

Sure

Sent from my SAMSUNG-SGH-I717 using Tapatalk 2
 
 
5th October 2012, 12:01 PM |#12  
dafoxs's Avatar
Senior Member
Thanks Meter: 8,656
 
Donate to Me
More
Thought this thread would have exploded with thanks. So many people complained about BT.
Thanks for your work, just hooked up to my friends Ford, works great.

Sent from my SAMSUNG-SGH-I717 using xda premium
The Following 2 Users Say Thank You to dafoxs For This Useful Post: [ View ] Gift dafoxs Ad-Free
5th October 2012, 03:05 PM |#13  
Member
Thanks Meter: 6
 
More
Thanks Krarvind!! Confirming that the fix allows my phone (slimbean) to pair with my XC60!! Kudos!!
5th October 2012, 09:35 PM |#14  
marcbsmoove's Avatar
Senior Member
Thanks Meter: 46
 
More
Thanks so much for this fix! You are the man!

G-Nizzle 4 Shizzle
7th October 2012, 02:40 AM |#16  
chappatti's Avatar
Senior Member
Thanks Meter: 293
 
Donate to Me
More
Volume ??
DELETED BY ME...

Eff-me, it was an app problem................ Sorry, krarvind !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

EDIT: The BT audio quality is better than sex........ Finally, I am where i wanted to be. THANKS, kr !
23rd October 2012, 05:07 AM |#17  
Johnsondr80's Avatar
Inactive Recognized Developer
Flag Tuscaloosa
Thanks Meter: 4,977
 
Donate to Me
More
Thankyou.
Confirmed on AoCP
:thumbup:

Sent from my SAMSUNG-SGH-I717 using Tapatalk 2
23rd October 2012, 02:06 PM |#18  
DAGr8's Avatar
Inactive Recognized Developer
Montreal
Thanks Meter: 6,372
 
Donate to Me
More
Quote:
Originally Posted by Johnsondr80

Thankyou.
Confirmed on AoCP
:thumbup:

Sent from my SAMSUNG-SGH-I717 using Tapatalk 2


hmm , i domnt need that fix anymore I figured it was , merged or something
23rd October 2012, 02:19 PM |#19  
Johnsondr80's Avatar
Inactive Recognized Developer
Flag Tuscaloosa
Thanks Meter: 4,977
 
Donate to Me
More
Quote:
Originally Posted by DAGr8

hmm , i domnt need that fix anymore I figured it was , merged or something

Let me be clear. I have no way to test my self. How ever I sent it to a local friend who flashed and called me back to say bluetooth was working in his ford ex.

We are going to look today at the source posted here in the op.

I have to assume your talking about your aokp, in which we based off however our project is not always inline with their progress.

Sent from my SAMSUNG-SGH-I717 using Tapatalk 2
23rd October 2012, 11:37 PM |#20  
joedoe's Avatar
Senior Member
Thanks Meter: 45
 
More
Quote:
Originally Posted by Johnsondr80

Let me be clear. I have no way to test my self. How ever I sent it to a local friend who flashed and called me back to say bluetooth was working in his ford ex.

We are going to look today at the source posted here in the op.

I have to assume your talking about your aokp, in which we based off however our project is not always inline with their progress.

Sent from my SAMSUNG-SGH-I717 using Tapatalk 2

The BT fix has been merged into CM10 source tree a few weeks ago.
19th December 2012, 05:41 PM |#21  
buffal0b1ll's Avatar
Senior Member
Flag Baltimore
Thanks Meter: 2,621
 
More
Quote:
Originally Posted by krarvind

Ok. BT phone audio finally seems to be fixed. I have done some testing on i717 using my jabra BT earpiece and my car built in BT audio system. Seems to work flawlessly. Moose0704 tested it on Liquid/C&C as well. So here is patch, flash in recovery. Here is the source for it, its more than the CM10's patch as that was the same fix i put in yesterday and didn't work on my car built in BT. Test and leave your feedback here.

NOTE: Only for AOSP/CM10 based roms. Flash at your own RISK. Don't blame me if something goes wrong. This patch has been tested by a few and has worked for all. If the patch doesn't work, get your rom devs/compilers to compile with the patch put in.

Link to patch is broken.
Thread Closed Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes