Remove All Ads from XDA
Honor View 10

Nook HD+ Google Play Store. GAPPS, modified 12/04.

701 posts
Thanks Meter: 280
By someone0, Senior Member on 15th November 2012, 09:50 AM
Post Reply Email Thread
If you have a new Nook HD/HD+ and want to root and get the GAPPS running, you should follow the guide at the All-in-One thread instead. That said, I won't copy all the information here to there, so you should continue to read on.


Okay this one is more interesting than the root I created. I don't think there will be a simple batch file for this one. I barely get this working and I'm going to try to write instruction for the people. I guess let me start off with the same disclaimer.

If something gone wrong, it's all your fault. I take ZERO responsibility for what happen to your device, your life, your wife/husband, your kids, your unborn child and etc. You get the idea.

I basically taking the installation process from the Kindle Fire HD and apply it it here. The original instruction which I "borrow" from is here. For the most part, the process is the same, but we have to be extra careful for writing into /system partition or we are toast.

What I found:
Well, since we didn't have "UNKNOWN SOURCE" option, we have to adapt and fix that first. You can thanks skyhawk21 for coming up with that idea. Since then, there have been other way to enable Unknown Source. LeapinLar have wrote an excellent here. And I have make it even simpler here. Also, I have found that trying to install Google Play store after some other stuff already installed is kinda pain and brought some error. So I would strongly start this fresh. I mean factory reset and apply root. If you don't know how to gain root on the Nook HD+, I wrote an excellent piece for it here.

Hugh big caution
I did all my stuff based off my root method. I also noticed that verygreen updated his root. While there are some similarlity in our methods, THERE ARE SOME DIFFERENCE ALSO. For example his root doesn't have a working superuser or he have busybox installed and symbolicly linked for all sub command. This mean the instruction I have may not work if you used his method to root.

Addendum 1: 11/19/2012@8:50PM Pacific
I have been told that the first set of instruction is no longer necessary by leapinlar. This mean that if you only want the ability to install app via Google Play, you can do the first set of instruction and be done with it. But this means you won't be able to utilize the rest of Google's services. On the other hand, you can skip the first instruction and purely do 2nd instruction and get most of the stuff working. Well I say most because it doesn't include Google Maps and Chrome.

Addendum 2: 11/19/2012@9PM Pacific

I have added Google Map below so you can download separately But Chrome Browser is like 20MB and over the filesize limit of the xda forum. Since most people don't use it, and there are many good alternative browser already, I won't bother. You can also look up both apk online if you want. they both should work on Nook. You don't have to make symbolic link on these two, but you can't have it on /system either. Either try install it via "adb install" command or open it using your favorite file browser. I forgot which method I use, probably the first.

Addendum 3: 11/30/2012@7:25AM Pacific
I rewrite and hide unnecessary stuff and streamline the guide.

Addendum 4: 12/01/2012@2:25PM Pacific
Adding which should be compatible for both my and verygreen root method.

Addendum 5: 12/02/2012@4PM Pacific
Adding troubleshooting tips

Addendum 6: 12/04/2012@9:45PM Pacific
Update with brand new easy to follow instruction.

Addendum 7: 12/07/2012@9AM Pacific
The Google Map will no longer install as part of the script. I think Maps may not function properly if google framework weren't installed correctly first.
So, you will just have to install it manually after the Google Play updated.

EXTREMELY OUTDATED NOT FULLY WORKING Instruction is hidden since it's no longer necessary.

  1. Optional, factory reset it. Seriously I cannot say this will work unless you start from scratch. If you already have rooted earlier, then install something like titanium backup and backup your porn(I mean data).
  2. Gain root access. Follow this guide.
  3. Follow my instruction here to enable "UNKNOWN SOURCE".
  4. Upload 3 files to /data/su/ using "adb push" command
    • GoogleServicesFramework.apk -
    • Vending.apk -
    • Play.apk -
      • If you have problem downloading this Play.apk I suggest try using this Vending_v3.9.17.apk instead. Be sure not to confuse with the earlier Vending.apk file, or better yet, rename it to something like Play3917.apk
  1. adb install $your_choice_of_file_manager(must support root), I prefer ES File manager
  2. using your file manager and browse to /data/su and install GoogleServicesFramework.apk (I'm not sure if you can just do adb install GoogleServicesFramework.apk from your PC, but since I didn't do it that way and this is a known result, so I recommend doing it this way)
  3. adb shell
  4. su
  5. mount -o remount,rw /system
  6. mv /data/su/Vending.apk /system/app/Vending.apk
  7. chmod 644 /system/app/Vending.apk
  8. chown 0.0 /system/app/Vending.apk
  9. mount -o remount,ro /system (not sure if this is necessary, but I better safe than sorry)
  10. using your file manager and navigate to /system/app and install Vending.apk
  11. mount -o remount,rw /system (only if you did step 11)
  12. rm /system/app/Vending.apk
  13. mount -o remount,ro /system
  14. using your file manager and go to /data/su and install Play.apk or Play3917.apk depending on what you download
  15. now you can delete both GoogleServiceFramework.apk and Play.apk in the /data/su folder.
  16. That's all, your Google Play Store should now be working.
  17. Login and have fun. I manage to install some stuff through that.
  18. Click the "THANKS" button below.
OK, now to get a more complete gapps. The below steps are to be only after you have Google Play Store, meaning all the above steps are done. The instruction below will let your other app sync and use google account. Meaning stuff like RSS reader sync with google reader or Youtube app access your personal account. Well, atleast those are the two I have tried and seem to be working.

OUTDATED Instruction:

  1. Download these two files. and (if you use verygreen root method use this , the one embedded on this post instead. This one should work universally but untested. I re-wrote it to adapt for verygreen root method also. If it works I'll rewrite this part of instruction again to use the new version of the shell script.)
  2. adb push /data/su/
  3. adb push /data/su/
    This step might take some time
  4. adb shell
  5. su
  6. cd /data/su
  7. chmod 755
  8. ./
    This step could take some time too, once it return to shell, then go to next step
  9. (optional delete installation file to save space) rm
  10. (optional delete installation file to save space) rm
  11. exit
  12. exit
  13. (you should be back to your OS by now, if not keep exiting until you are out of adb)
  14. adb reboot
  15. once your nook is rebooted, the screen may say updating some files, this is normal.
  16. enjoy, everything should work now.
  17. If you didn't hit that "THANKS" button, you better do now. If you did, do it again?

Thanks leapinlar for catching the typo, I have reupload the shell script file now. And thanks to him for hosting the

There have been some errors on my initial instruction. Certain things have been point out. I have updated the instruction accordingly. leapinlar have also fixed gapps files and the shell script for that in post #34. So big kudo to him. I haven't have much time to toy with this lately, but since people report that his script work. So here are the new instruction.

If you were using verygreen version of root, try running this first.
adb shell su -c "/data/su/busybox chown /data/su"
Q: I don't see the Google Play Market on the list of apps.
A: If you use the "Skip OOBE" aka Test mode, then (reboot first or go into shell and kill the app launcher and then) you have to hold down the Vol-Up key and tap the word Apps on the top to see them. After that I recommend installing other launcher, then they can see all the apps.

Q: Some people are saying after they install an adblock app, after reboot it get into bootloop and wipe everything.
A: The way most adblock apps work is that they modify the hosts file which usually located at /system/etc/hosts Well, as we have discussed before this is not a good idea to make change directly to /system folder(directory). The only adblock I know of that work is AdAway with a specific setting.
When installed, first you have to go to menu > preferences > target hosts file > /data/data/hosts, it will then ask to create symbolic link, say yes and then you can reboot.

Troubleshooting Tips:
I had a little problem today, unrelated to the GAPPS install mod here. But the problem involved Google Play not working correctly. I kept getting Google Play error pop up. So, I use Titanium Backup ROOT to wipe the data and then uninstall all the apps which names start with Google. I'm not sure if this is enough, it might but I didn't want to take any chance. This maybe unnecessary but I did it anyway; I delete all the files that I created in the /data/su/system that have anything to do with google. Basically anything that was unzip there. Rebooted, then re-apply the same google mod here. And problem solved. I did have to re-login again, but yes I clear up that Google Play error.

ADB + ROOT + Enable Unknown Source.
1. ADB: leapinlar wrote a post to help you getting ADB to work here.
2. ROOT: I wrote a guide on how to get root the easy way here.
3. Enable Unknown Source: Again, I make an easy little tool for you here.

Brand New and Improve Instructions:
  1. Download these three files. GoogleMaps.apk and
  2. Unzip (don't unzip
  3. run install.bat
PS: Now I know how hard it's to write a guide in xda. Prop to all those dev that have been there b4 and after, especially the one I have use their works.
Attached Files
File Type: apk GoogleMaps.apk - [Click for QR Code] (6.28 MB, 7364 views)
File Type: img - [Click for QR Code] (3.3 KB, 1373 views)
File Type: zip - [Click for QR Code] (1.9 KB, 1003 views)
The Following 44 Users Say Thank You to someone0 For This Useful Post: [ View ] Gift someone0 Ad-Free
15th November 2012, 01:34 PM |#2  
Thanks Meter: 15
That's it, I'm going out to buy one ASAP. Thanks for your hard work!
15th November 2012, 02:39 PM |#3  
Senior Member
Thanks Meter: 85
thanks for you Howto
after that is it possible to use Youtube and Google Maps apps?
15th November 2012, 05:21 PM |#4  
OP Senior Member
Thanks Meter: 280
Youtube can be install from Play Store but you have to sideload the Google Maps since it's not available for download in Play Store. GMail works, but the authentication through google account on other apps still aren't working. I guess this problem may be beyond my current level of tinkering knowledge.
15th November 2012, 05:49 PM |#5  
Senior Member
Thanks Meter: 28
Thumbs up
great job on getting google market somewhat working!!!! We need the manual nooter developer or author to make what we need for the Nook HD AND HD+. Anyhow I belwive you need more framework files to get google authentication working and unfortunately they need to be installed within root folders like the /system folders and sub folders... Also Barness and noble included frameworks for google authentication, probably just not working with google apps installed manually.... gotta figure it out...

---------- Post added at 05:49 PM ---------- Previous post was at 05:47 PM ----------

By the way youtube app works installed older version from my Motorola Droid 3 manually through es file explorer and it works and does HD fine
The Following User Says Thank You to skyhawk21 For This Useful Post: [ View ] Gift skyhawk21 Ad-Free
15th November 2012, 06:07 PM |#6  
OP Senior Member
Thanks Meter: 280
I have been thinking about that and wonder if we can put those lib files on diff folder and sym link them? I still afraid it might reset the thing.
15th November 2012, 06:35 PM |#7  
leapinlar's Avatar
Recognized Contributor
Thanks Meter: 3,870
Donate to Me
Originally Posted by someone0


[*]Optional, factory reset it. Seriously I cannot say this will work unless you start from scratch. If you already have rooted earlier, then install something like titanium backup and backup your porn(I mean data).

I was able to do this with root explorer after rooting with no problem.

Thanks for this (and your rooting zip - both are super!)
15th November 2012, 08:00 PM |#8  
Thanks Meter: 9
issue was fixed, removed obnoxiously long quote
15th November 2012, 08:30 PM |#9  
OP Senior Member
Thanks Meter: 280
Originally Posted by smatticus

still have the issue where i can't get the nookcolortools to run properly from /system/app. it just crashes. i googled this and it says that i need to reboot the nook to apply the system/app move BUT that supposedly creates the bootloop. i REALLY don't want to do that so can someone help me out here?

You probably shouldn't quote anything that big unless you very need to. As far as getting nook color tool to run, did you set the file to have proper permission, eg: chmod and chown the file? Your other option is factory reset and start from scratch. Sometime getting a clean slate to start with make things easiler to follow.
15th November 2012, 08:52 PM |#10  
leapinlar's Avatar
Recognized Contributor
Thanks Meter: 3,870
Donate to Me
Thank you for the Google Play Store. It works great for me. I want to install Google Voice. Before I installed your framework apk, I was not able to get the credentials to come up. Now since installing that, it comes up with my Google credentials and tries to authenticate them. But immediately Android System force closes and the sign in screen just sits there. Any ideas on this one? This is the last thing I need to make this my everyday device.

Sent from my Nook HD+ using Tapatalk
The Following User Says Thank You to leapinlar For This Useful Post: [ View ] Gift leapinlar Ad-Free
15th November 2012, 08:54 PM |#11  
Thanks Meter: 9
Originally Posted by someone0

As far as getting nook color tool to run, did you set the file to have proper permission, eg: chmod and chown the file? Your other option is factory reset and start from scratch. Sometime getting a clean slate to start with make things easiler to follow.

turns out i wasn't supposed to install the app via adb. my fault for not following instructions. thanks for your hard work
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes