FORUMS
Remove All Ads from XDA

Fuhu Nabi2 Backup - Recovery - Root - Gapps on Ubuntu Linux

193 posts
Thanks Meter: 188
 
By t499user, Senior Member on 27th November 2012, 01:51 PM
Post Reply Email Thread
Here are the steps required to backup the Fuhu Nabi 2, install a custom recovery, root, and gapps using Ubuntu(12.10) Linux.
This also works on Windows(other than installing adb and fastboot) if you just remove the 'sudo' from the commands.
For a scripted Windows install, check out Nabi Lab: http://forum.xda-developers.com/show...php?p=36758895
Original root from jmztaylor, Includes the new gapps(t499user) and the new TWRP 2.3.3.0 from aicjofs(thanks!)
You should do all of the OTA updates before rooting(otherwise you might lose WiFi) When I posted this the latest version was 1.9.37. Settings>About Tablet>Update>Check Update
Download the needed files then extract all of the files to your home folder to begin. http://dl.dropbox.com/u/6529005/Fuhu...cember2012.zip

Open a terminal(ctrl+alt+t) and run the following command to install ADB and Fastboot (Universe).
Code:
sudo apt-get install android-tools-adb android-tools-fastboot
On the device, enable USB debugging in Settings>Developer options, then connect USB cable.
Just in case the adb server is already running, lets kill it using:
Code:
adb kill-server
Now we will start the server and reboot the device:
Code:
sudo adb reboot-bootloader
Once the device has rebooted into the bootloader, we will flash the new recovery image using fastboot:
Code:
sudo fastboot flash recovery recovery.img
When fastboot is finished, boot the new recovery kernel on the Nabi2 by pressing vol+ then vol-(down to recovery) then vol+ to select.


We will push the follwing files to the device.
First we will push the Root file.
Code:
adb push root.zip /sdcard/root.zip
Now we will push the Google Apps File
Code:
adb push gapps.zip /sdcard/gapps.zip
This is the script that will backup then install Root and Google Apps onto the device.(you can also skip the script and do it manually if you like, but make sure you do a backup)
Code:
adb push backup-root-gapps.openrecoveryscript /cache/recovery/openrecoveryscript
Now we will reboot the device and let the script do it's thing.
Code:
adb reboot recovery
Once you log into your device, start up SuperSU to make sure that root 'sticks'.

Your Fuhu Nabi2 is now rooted, w/gapps, and a custom recovery, Now click on the "thanks" button

NOTE: The following is if you ever need to do an OTA update, which requires the original Nabi2 recovery.
Download the original Nabi2 recovery image to your home folder https://www.box.com/s/9ogqkk8uu71bqrnpz9w1
Reboot the device into the bootloader
Code:
sudo adb reboot-bootloader
Finally we will flash the original recovery image to the device
Code:
sudo fastboot flash recovery nabi2_original_recovery.img
Attached Thumbnails
Click image for larger version

Name:	nabi2-controls.png
Views:	60568
Size:	49.0 KB
ID:	1518165  
The Following 24 Users Say Thank You to t499user For This Useful Post: [ View ] Gift t499user Ad-Free
 
 
28th November 2012, 04:26 PM |#2  
Senior Member
Flag Little Rock, AR
Thanks Meter: 5
 
More
Thank you very much! In about 10 minutes, everything was the way things should be! Specifically, a nicely rooted tablet so that my son could thoroughly his tablet! Now if I can get XBMC working properly, then life would be perfect! Thanks again!!!!
28th November 2012, 10:36 PM |#3  
OP Senior Member
Thanks Meter: 188
 
More
Info 2 Fuhu Nabi2 Common issues and FAQ.
Glad it helped you out! It's a great little tablet.

To make Nabi2 more like a regular tablet now that you have Root and Google Play, you can prevent the tablet from starting Nabi Mode/Monarch UI by checking the box in Settings>Security>'Set Parent Mode as default mode'.

You can also remove the files in the /vendor/app/ folder if you want to free up some space. Just make sure to have 'Parent Mode as default mode' checked before you remove these files, or when you reboot the tablet it will give you a blank screen.
Code:
NvCPLSvc.apk, fuhu_AddApps.apk, fuhu_AppZone.apk, fuhu_Books.apk, fuhu_ChoreList.apk, fuhu_Crafts.apk, fuhu_Fan-a-tech.apk, fuhu_KidzMode.apk, fuhu_NabiCare.apk, fuhu_NabiCloud.apk, fuhu_NabiSpinletsPlusICS.apk, fuhu_NabiSpinletsPlusParentICS.apk, fuhu_NabiSync.apk, fuhu_OOBE.apk, fuhu_ParentalDashboard.apk, fuhu_SpinletPlusVideo.apk, fuhu_SwitchKids.apk, fuhu_TreasureBox.apk, fuhu_University.apk, fuhu_Videos.apk, fuhu_Web.apk, fuhu_nabiMD.apk
I used ES File Explorer to remove the files. First you have to go into the ES File Explorer settings and check all the boxes in 'Root Settings'. Alternatively you could use the file manager in the custom recovery we flashed in the first post or any other file manager with root capabilities.

If you need to get into fastboot or recovery manually, turn off the Nabi2 and then hold the vol+ and power button until the menu comes up. You use the vol- to navigate and the vol+ to select.


Nabi2 Teardown Thread: http://forum.xda-developers.com/show....php?t=2024105

Technical Specs for the Fuhu Nabi2
Display: 7-inch, Capacitive, Multi-Touch Display, 1024 x 600 Resolution
CPU: NVIDIA® Tegra® 3, Super 4-PLUS-1™ Quad Core with 5th Battery Saver Core
Storage: 8 GB, Expandable via MicroSD (Up to 32 GB); Plus 2 GB FREE Cloud Storage
Memory: 1GB RAM
Camera: 2MP Front Facing Camera; 720p Video
Battery: 3,850 mAh Rechargeable Lithium-ion Battery
Size & Weight: (with Drop-Safe Bumper) Width: 8.69 Inches (220.8 mm) Height: 6.05 Inches (153.7 mm) Depth: 1.14 Inches (29.08 mm)
Weight: 1.31 Pounds (596 g)
OS: Android 4.0, Ice Cream Sandwich
Network: Wi-Fi 802.11 b/g/n Bluetooth 3.0
Input / Output: Micro USB 2.0 Port, Mini HDMI MicroSD Compatible Cartridge Slot, 3.5 mm Standard Audio Jack, Built-In Microphone, DC Connector
Audio + Video Format:
Audio: MP3, AAC
Video: MPEG-4, H.263, H.264
Charger Output: 5vdc 2000mA
Charger Plug: 2.35mm OD and 0.7mm ID

Gmail App will force close if you don't have gmail checked in Settings>Accounts&Sync>Click on email>Checkmark Gmail.


Some games on the Fuhu Nabi2 use openfeint, to disable/block this you can install AdAway https://play.google.com/store/apps/d...?id=org.adaway and add the following to the blacklist. This prevents the program from contacting the openfeint servers.
Code:
openfeint.com
api.openfeint.com
scoreloop.com
Some Games that use openfeint:
Code:
Fruit Ninja, Tiny Wings, The Moron Test, Robot Unicorn Attack, Championship Manager series, Bomberman Touch 2: Volcano Party, Fieldrunners, geoDefense, geoDefense Swarm, Minigore, Pocket God, Rollercoaster Rush, Jetpack Joyride
Here is a copy of the build.prop http://pastebin.com/5hCHd4bb

If you really, really messed up and have to restore the device back to stock because you didn't follow directions and lost wifi etc etc, I created a thread for restoring to factory from scratch. http://forum.xda-developers.com/show...php?p=35287470

ANDROID UPGRADING MESSAGE:

If you used a different gapps other than the one posted above or http://forum.xda-developers.com/show....php?t=2065878 you will probably get an "Android Upgrading" message every time you reboot. This is caused by two stray odex files that need to be removed/deleted. You can just install the new gapps package or take care of the files manually.
Code:
/system/apps/Gallery2.odex
/system/framework/com.google.widevine.software.drm.odex
Attached Thumbnails
Click image for larger version

Name:	PC080022.JPG
Views:	62659
Size:	21.5 KB
ID:	1546905   Click image for larger version

Name:	gmailsync.png
Views:	20990
Size:	56.1 KB
ID:	1622254   Click image for larger version

Name:	parentmode.png
Views:	20855
Size:	30.4 KB
ID:	1630284   Click image for larger version

Name:	androidupgrading.jpg
Views:	23070
Size:	7.0 KB
ID:	1645412  
The Following 21 Users Say Thank You to t499user For This Useful Post: [ View ] Gift t499user Ad-Free
8th December 2012, 12:18 AM |#4  
codest3r's Avatar
Senior Member
Flag Orlando, FL
Thanks Meter: 59
 
More
Thanks for this man. The only thing I'd recommend is adding a piece, or a URL, on how to add the repo's for apt to pull those adb packages. These commands you step through are handy in *nix or Windows(-sudos). Thanks again!
8th December 2012, 02:39 AM |#5  
OP Senior Member
Thanks Meter: 188
 
More
Thanks, I didn't even notice that adb and fastboot were in the Universe repos as I had it enabled already.
9th December 2012, 09:25 PM |#6  
codest3r's Avatar
Senior Member
Flag Orlando, FL
Thanks Meter: 59
 
More
I'll go double check then. I am running Ubuntu 13 off USB stick now and had enabled universe repo but maybe didn't get a clean update before checking for pkg. Will try again and see what's up...

I thought it required some custom repos, nothing preconfigured. If it is in universe my bad.
10th December 2012, 05:36 AM |#7  
katinatez's Avatar
Senior Member
Flag Arizona
Thanks Meter: 18,779
 
Donate to Me
More
Thank you, for this thread was able to root daughter tablet with this tutorial. Tried the script in other thread but did not help. Thanks again

Sent from my NABI2-NV7A
10th December 2012, 07:53 PM |#8  
codest3r's Avatar
Senior Member
Flag Orlando, FL
Thanks Meter: 59
 
More
Yup, its in universe, my bad.

Sent from my SPH-D700 using Tapatalk 2
31st December 2012, 07:21 PM |#9  
OP Senior Member
Thanks Meter: 188
 
More
Here is a quote from tikiral on installing ADB and Fastboot on Windows.

Quote:
Originally Posted by tikiral

Speaking of posts
@shizzy t499's post is really an excellent guide. The only thing you'd change if you're on Windows is that instead of doing the 'apt-get' you'll just download and install the SDK Tools from Google (http://dl.google.com/android/install....1-windows.exe) > Start up the SDK Manager.exe file from the install directory > Scroll to the very bottom > Check off Extras>Google USB Driver > Click Install packages...

After install, you should be able to go into Device Manager and update the driver's on any stray android devices and bam, you should be all set to go.

Thanks again for all the info @t499.

31st December 2012, 09:04 PM |#10  
DarkAngel's Avatar
Senior Member
Flag Arizona
Thanks Meter: 359
 
More
Finally got a chance to perform this on my Nabi 2. Installed with no problems what so ever and was quick too. I performed the install using Ubuntu 12.10. I found it much easier and less stressful this way. Now I have to do this to both my daughters Nabi 2 tablets.

I just finished up removing the Monarch UI apps for a normal tablet. Man I really love this tablet. I have almost all my G apps installed which I have been wanting for some time now.

Just follow the instructions to the letter and you can't go wrong with Linux. Now if we could get Jelly Bean on this it would be awesome! I posted a question about the Nabi XD in the Q&A and posted specs comparing both if anyone caught it. I am pretty sure it's possible if someone can get a hold of the XD and port it over.

Thanks again t499user and all the devs that worked to make this tablet usable.
3rd January 2013, 03:57 AM |#11  
OP Senior Member
Thanks Meter: 188
 
More
Glad it worked for you! I would love to see some JB action on here.
Post Reply Subscribe to Thread

Tags
fuhu, gapps, nabi2, recovery, root

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes