Remove All Ads from XDA
Honor View 10

UMI X1 - Root, ROMS and some TWEAKS

29 posts
Thanks Meter: 16
By xexexexexexe, Junior Member on 23rd January 2013, 07:01 PM
Post Reply Email Thread
To help everyone getting the max out of UMI X1, I'm putting here the info that is spread over the internet.
Special thanks to people on the thread #1978103

NOTICE: If you have any questions, go directly to the source of information.
NOTICE2: Since some of the files were very slow downloading (eg: BAIDU), i present here some alternative links.

Main Specs:

Official website: (use GoogleTranslate)

================================================== =================================

OP1 - Windows drivers installation


(these drivers work with XP, and possibily with earlier Windows versions)<br>

OP2 - ROOT Access

First action: activate USB DEBUGGING mode.

a) Download and install SHUAME software

[Source -]
(it's in chinese, but the install is straight forward... next -> next, etc. )

b) Connect USB cable to the phone. Shuame will detect UMI X1, and you'll see a copy of your screen on the computer

c) Make this 2 clicks:

d) On next screen, click on the "blue" button to initiate the process. Phone will restart several times until finished

NOTICE: to un-root, just click the "root" button on the right (with the $ instead of the #)

OP3 - Install a Clockworkmod (CWM) based recovery console

With this step you'll be able to install non-official ROMS (not digitaly signed)

a) Download the new recovery image:

[Source -]

b) Execute SHUAME, and click on button "Recovery":

c) click on the "blue" button -> and choose our IMG file -> click on the "blue" button again

The new recovery console will be installed. To access it:
- turn off Umi X1
- press POWER + VOL.UP, until the UMI logo shows up
- if you see a dead Android -> click HOME
- use vol+ and vol- keys to navigate thru options, and the POWER key to select.
Notice: some pre-recovery consoles have other keys, but the instructions are explicit.

Notice: you can make full backups with this recovery console.

OP4 - Install a new ROM

Most UMI X1 comes with ROM Android 4.0.4 - 20120914-215024

Other ROMS most used by the community:
- 4.0.4 (ICS) - "Samsung" style (LINK) - Source:

- 4.0.4 (ICS) - 20121118 - Official with several fixes -

- 4.1.2 (JB) - 20130101 - Official -
- 4.1.2 (JB) - 20130109 - Based on Official, with several fixes -

- 4.1.2 (JB) - 20130118 - Based on Official, with several fixes -
Notice: this last one needs some additional tweaks:
-> Install GoogleApps via recovery console
(GoogleApps also available here: )
-> Copy these Calendar files to /system/app with root explorer and set correct permissions (same as the others) (Source: XDA-Developers - sonof)
-> Install the app "SmartHosts" from the GooglePlay/Market, and update your hosts file in order to make GoogleNews, Facebook, etc. working

[Source1 - ROMJZ.COM]

To install a new ROM:
a) copy the ROM ZIP file to the microSD card
b) enter recovery mode - look at the previous question
c) (advisable) make a full backup of the existing ROM
option Backup&Restore -> Backup (it will take long...)
the backup will be on the SD card, folder clockworkmod

d) select option "wipe data / factory reset" -> choose option "YES"

e) select option "install zip from sdcard" -> "choose zip from sdcard" -> choose the ZIP file -> "YES"

f) after "reboot system", the new ROM will be operational.

g) in case the ROM has "chinese" language by default, goto settings menu (the settings icon is easy to find) and choose your language:

OP5 - Readjust the internal storage size

Sometimes, after installing a new ROM, the ROM 4GB get wrongly shared between the "internal storage" and the "phone storage".
Since "phone storage" is a kind of SD which is less used than the "internal storage", is advisable to share the space like this:
2,5Gb: apps / internal storage
80Mb: phone storage
Remaining: ocuppied by the Android ROM

To do that, you just have to use one of these ZIP files:
2,5Gb (recommended)

a) copy the ZIP file to the microSD card
b) Enter recovery console
c) Make a full backup
d) Apply update from SDCard -> choose the ZIP (1,5gb or 2,5gb)
e) reboot and restart phone - (it will say that the storage is corrupted, but don't mind it for now)
f) if the space is not OK (eg: still 500Mb), power off -> enter console recovery -> restore your backup
i) after reboot, and after having the desirable space (2.5gb or 1,5gb) you can go with Android suggestion, and format the SDCard -> the error will disapear. (Notice: you are not formating the microSD card, just the "internal phone" storage


OP6 - Correct problems with GPS

There have been a lot of comments about the GPS functionality on this phone, including several tweaks and tutorials, some with hardware changes, etc..etc...

What I have acknowledged, after having 2 original (no modifications) UMI X1 side by side (one with a KFT antenna, and other without it):
1- It's advisable to do some things in order to make the GPS work faster when you need it
2- GPS reception is not extraordinary good, but it also is not bad, and surely not worse than most Android models with GPS, including the ones from Samsung
3- Antenna changes, or metalic foil "upgrades" may or not be positive, regarding increased signal. Whoever wants may try it, but not necessarily needing to damage/open your UMI X1.
4- About the EPO files: there was some problems with Mediatek servers on Nov/2012, but they look to be solved now, so you won't need to download these files via a FTP client. Just let your phone do it!

However, if your EPO files are not downloading, (goes till 25% or 50% and restarts):
- Install app "Root Browser Lite"
- Goto /data/misc
- Change permissions of mtkgps.dat, EPO.DAT and EPO.MD5 to 7777 (read, write, execute, etc..)
- Check that now Android can download and recognize the EPO files (with 1 month between the 2 dates)

What you can DO to make your GPS better and faster:

a) Download GPS.CONF from your country (e.g. this is from Portugal: LINK). Copy it to /etc (delete the one that was there previously)
(alternatively, use the "PIMP MY ROM" software)

b) Reboot

c) Go to an excelent visibility site (if possible, with clear sky)
d) Enter Engineering Mode: dial nr *#*#3646633#*#*
e) EPO TAB: Enable EPO
f) A-GPS TAB: Enable A-GPS
--- Allow network initiated request
--- Allow EM notifications
h) Use "GPS TEST" app to clear the A-GPS, and then start checking the sattelite coverage
i) If it is your first time: WAIT... WAIT.. WAIT... It can take 20mins or more to catch the first satellite. then the second one... slowly... until you get a FIX... and then the accuracy will progressively be better

On next usage (even after reboot), the GPS will be ready and probably get a fix in less than 30seconds!

j) Install a navigation Software (eg: Ndrive or one from GooglePlay)

[Source: several, buy mainly XDA-DEVELOPERS]

OP7 - Install Flash Player
Just install this app:
(it works on Android 4.1.2 JellyBean straight from the standard browser/Navigator, but you can also try Dolphin browser)
The Following 13 Users Say Thank You to xexexexexexe For This Useful Post: [ View ] Gift xexexexexexe Ad-Free
28th January 2013, 12:55 PM |#2  
Junior Member
Thanks Meter: 0
Another way to install new ROM on UMI X1 taken from Antelife website
2nd February 2013, 02:14 PM |#3  
cooldfuzion's Avatar
Senior Member
Thanks Meter: 10
Fast mirror for UMI_XI_4.1.2_13.01.18
4th March 2013, 02:39 AM |#4  
Junior Member
Thanks Meter: 0
Question hello
any body have rom with habrew? like flashing..
20th March 2013, 11:33 AM |#5  
Junior Member
Thanks Meter: 0
arouvor which
What are your experiences on the 15.03 Lewa OS?
26th March 2013, 04:47 PM |#6  
Junior Member
Flag Lisburn
Thanks Meter: 2
Re: UMI X1 - Root, ROMS and some TWEAKS
Thank you for all the info pal.

Sent from my UMI X1 using xda app-developers app
28th March 2013, 12:46 AM |#7  
ReiverBlade's Avatar
Senior Member
Flag Ovronnaz
Thanks Meter: 15
Thumbs up
thanks! i got myself a UMI X1 who had ICS on it but now im on JB and i dont know why but the Shuame tools didnt worked till i read your post xD and i did exactely the same manipulation luckystar? maybe

big thanks

sadpart my X1 has only a plain black back cover xD i wanted the "carbon" lookalike one but i will survive

one thing ... on the description they write : 2G:GSM 850/900/1800/1900 3G:WCDMA 2100mhz normaly isnt the 900mhz 3G too? in my box its written 2G 800/850/1800/1900 3G 900/2100mhz, that bug me a a little since Sunrise have 3G under the 900mhz and i get only Edge when i activate data and 3G in setup, is it a known problem (i've seen some people getting 3g and other dont) does a fix exist or its only operator related?

on the other hand i use my X1 with only one sim (in the W slot since the G is for GSM so i doubt W wouldnt mean WCDMA) what i suspect is : if there is only one sim in the phone does it works by default on 2G only? or am i paranoid...
9th April 2013, 07:12 AM |#8  
Junior Member
Flag Noosaville
Thanks Meter: 0
UMI x1 problems
Hi All
I was just following your procedure for CW recovery and the fist screen i got after the UMI screen was a list off chinese characters in to left corner.

Like other ndroid phones i have rooted I decided to get out and thinking the last set in the list was "power off" I tried that without luck now I have a screen with chinese charactors high lighted and the next line in english is camera with a space then home. Niether the power button or the volume button make any change.

Have I bricked the phone?

Can anyone help me please.

Thanks in advance Davoh
12th April 2013, 05:02 PM |#9  
Junior Member
Thanks Meter: 0
Hello All,

I have tried to root my UMI X1, but it keeps failing.

At first, I tried to follow the first step here. On my screen appeared prompt to restore my data from computer and the Shuame wizard showed me an image, that refers to accept the restoration of the data. (I didn't loose anything, because I had it in factory state...) After confirming, UMI just restarted and rooting process seems to be completed, but not correctly.
From two available buttons in wizard I guessed, that it was cancel and retry options.
I even try to access root explorer, but still "no root permission".

Now I was confused, so I try to do all from start. I wiped my phone, uninstall the wizard, set the english on phone, installed the wizards again and tried the whole procedure again.
...with the same result, of course.

So, I looked at the main page of Shuame, translate it to english through google and I found practically the same manual to root the phone.
And again, I followed the steps by this manual, and now.... surprisingly with the same NEGATIVE result.

At the end of that manual was reference to the advanced procedure how to root the phone, where I was supposed to download their .zip file, oped it with the wizard and let him upload the files to my phone.

Well, I followed this manual also. But the process has the same result.

Now I am desperate and I'm not able to find any other solution on the net. Please help.
I need to fix my GPS.
16th April 2013, 02:08 PM |#10  
Junior Member
Thanks Meter: 0
Hello All,

I left my UMI without battery for 2 days and I was searching for other solutions.
I don't know how, but after two days I tried the same procedure again. For my big surprise, I was able to root my phone and flash the CWM.

I was happy to finally see some results, but little bit to early.
I try one ROM here and it was installed without problems. Booting was a little longer, but nothing uncommon.

After boot I changed language to EN and tried to connect to my wifi at home. But now I found even bigger problem, than not working GPS.
My wifi stucked. The message was telling me "Turning on...", but it was there "like-forever".

I opened engeneering mode and looked at status of wifi - "UNINITIALIZED".

My guess was, that I lost drivers to wifi adapter, but I didn't how. So I started looking on internet for wifi problems with UMI X1... and didn't find even one solution. Nobody on the whole internet seems to have some problems with wifi.

OK, wifi out, I tried to fix GPS as well. Suprisingly no singal (or all satellites were on the other side of the planet. )
I came up with idea, it could be problem with this ROM, so I tried every one with the same steps like the first one. Still the same state.

This situation is driving me crazy and I am obviously loosing my mind.
Please, if anyone could be just a little helpful, I will VERY appreciate that.

Thank you all.
16th April 2013, 04:18 PM |#11  
Junior Member
Thanks Meter: 0
Samsung Galaxy S3 Gt-I9300 MTK 65**
Hi, i need help with my S3 Mtk 65** phones i rooted my phone using shuame and did a ROM but it fail and now my phone is empty but all items on the phone is in my comp. I cant seems to reverse the action. The only things left on my phone is the mediatek logo when i on it. Anybody here can help?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes