[APP] Official ViPER4Android Audio Effects (FX v2.5.0.5) - New Features & 7.0 Support

4,134 posts
Thanks Meter: 14,620
By zhuhang, Recognized Contributor on 15th March 2013, 05:42 AM
Post Reply Email Thread
12th February 2020, 02:54 AM |#28201  
Originally Posted by mrclaver

Unfortunately all of the guides off google and xda I could find didn't work. Every workaround just doesn't fix it for OnePlus 3 Android 10. If someone begs the differ, please help me out.

Step 1: Establish Root access via magisk or otherwise.

Step 2: Set selinux to permissive by flashing the permissive patcher, a flashable version is available here on XDA

Step 3: Install The SELinux Switch by xda developer Ibuprofen. This app can be found on XDA labs. Once it's installed set SElinux to permissive in the app

Step 4: Install viper4android apk of your choice. I used the OP version. Open the app, and grant magisk root permission and then enable the master limiter of your choice... speaker, headphones etc.

Step 5: Enjoy!

To be noted if you are using stock rom that uses dolby (stock) or audioFX (lineage) or otherwise, turn these apps off first to ensure no conflicts with viper4android. If your android settings enable you to choose a default equalizer, make sure Viper is selected. I also have these files mentioned above. If you need them let me know. Best of luck!

Sent from my moto g(6) play using XDA Labs
The Following User Says Thank You to Sands207 For This Useful Post: [ View ] Gift Sands207 Ad-Free
12th February 2020, 07:48 PM |#28202  
Thanks Meter: 7
I installed Viper4AndroidFX on my rooted Mi8 with the latest Android 10 MIUI from It tried to install the driver, but upon reboot it now immediately goes to fastboot. I can make it to TWRP if I directly boot into the twrp.img. Any way to reverse the obviously failed driver installation in TWRP? Or should I just dirty-flash my ROM again?

EDIT: I could solve it by deleting the folder of the module in /data/adb/modules in TWRP.
13th February 2020, 02:00 PM |#28203  
Junior Member
Thanks Meter: 0

Sorry, for my bad english.

My galaxy S7 have the LineageOS17.1, rooted and worked very fine until I 've installed this module... now the phone won't start: it stay's on the Samsung Logo.

I have installed the module via Magisk, by downloading it, then install it and then restart... but the phone doees'nt restart... freeze on the Samsung logo.

It's still possible to access to the TWRP recovery, but please, wich sequence do I need to de-install the module that brixk my phone ?

thank you for your help.
13th February 2020, 02:17 PM |#28204  
Thanks Meter: 7
In TWRP, go to Advanced/File Manager, then to /data/adb/modules and delete the folder of the Viper4Android module.
The Following User Says Thank You to HenryLolsen For This Useful Post: [ View ] Gift HenryLolsen Ad-Free
Post Reply Subscribe to Thread

best settings, convolver, cure tech+, fx xhifi, irs impulse response sample, settings, viper4android v4a, virtual headphone surround engine+

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes