Remove All Ads from XDA

[TUT] Instructions MTK6577 USB VCOM Driver Installation

1,028 posts
Thanks Meter: 1,943
Post Reply Email Thread
12th August 2013, 04:31 AM |#31  
haree's Avatar
Senior Member
Thanks Meter: 713
i just installed the 64Bit drivers from the 1st post link and now when i connect my phone via USB it shows as A116 connected is this good enough for me to use the SP tool to flash what i want

Note : Yes its working fine for me used SP tool and flashed CWM sucessfully & also flashed melting rock rom
im using win7 64bit OS on my laptop
19th August 2013, 10:58 PM |#32  
bayustev's Avatar
Senior Member
Flag in my head
Thanks Meter: 44
Originally Posted by n4w4k

The fact that the "preloader COM port" appears and then disappears 3 sec later IS THE CORRECT BEHAVIOR!! I also had a hard time with this driver because I thought it meant there was a problem. That's why when you flash with Flash_tool.exe, you FIRST click on "download" THEN connect the (off) phone. Flash_tool will connect to it in the brief moment it is seen by the device manager and KEEP IT CONNECTED while it flashes!
IMHO, this information should be included in red in the 1st post because it seems to throw off a lot of people!

canceled sorry.
The Following User Says Thank You to bayustev For This Useful Post: [ View ] Gift bayustev Ad-Free
2nd September 2013, 06:09 PM |#33  
Junior Member
Flag Karachi
Thanks Meter: 2
Thanks man you are life saver... I finally solved with your guide.. before that i was messing with many other guides and finally it has be resolved.. Your guide is 100% correct and working with Xp sp3 as I am gsm technician so we are bound to use it....
1st October 2013, 12:03 PM |#34  
Jeewan Deep's Avatar
Senior Member
Thanks Meter: 16
MX IMEI prob solved ...and its all thx to u bro..
Due ... it was a headache for me since i had this NVRAM issues...(IMEI & WIFI) which actually occurred due to my fault only.. . Really thx 4 sharing the methods to fix it . My IMEI is fixed now... but wanted to know what lock IMEI would do...??? and i am having a bit doubt abt wifi... the thing is ... did u said to type the wifi mac address which i can c now ..that is when i am having the NVRAM error .. dt time smthing like it shows 00:08: etc etc.... ??? I typed the MAC address which i saw...on abt phone status.. while i ws receiving the error..!! and after doing thatand finishing..... i checked .it again.!!! it gave a different MAC address.. nd ws not giving me the error... so...!! i take it as fixed.. still plz clear my doubt...
21st October 2013, 08:18 PM |#35  
Junior Member
Flag Bangalore
Thanks Meter: 2
Question Issues with Karbonn K1616(non Android) flash
using the instructions mentioned in the post I was able to install MTK drivers in Windows 8. But as some people have complained , the COM port is detected for hardly 2 seconds. I'm trying to flash a non Android Device karbonn K1616. I read most of the places that a flash box is required.
I was trying out few things to get something working with just a micro USB cable. FYI , I have flashed MMX A110 and Karbonn A9+ android devices earlier so ADB are getting detected properly.

I wanted to ask if the flash box is necessary even when I'm able to just detect the COM port in Device Manager, but I haven't been able to download or get the device detected in any of the flash tools so far. I believe the device supports MTK62xx series.

Any advice would be helpful. Thanks All.
23rd October 2013, 12:48 AM |#36  
zEr!'s Avatar
Flag ahmedabad
Thanks Meter: 28
Unhappy HELP?????!!!!!!!!!!!!
Originally Posted by kumar abhishek

Since here every day again and again problems with the USB VCOM driver installation for MTK6577 appear Phones, here is a short guide to the installation, and a final, successful test with SPFlashtool!

Installation of the USB VCOM driver:

[1] With USBDeview, clean up your PC from all possible old MTK VCOM entries, then reboot your PC.

[2] Smartphone is switched off, and still dont connect via USB to the PC.

[3] Open Device Manager and leave it open!

[4] Your switched off Smartphone with inserted rechargeable battery via USB connect now on the PC, you should now see a MT65xx preloader in the Device Manager.
(With some MTK6577 Smartphones should be installed without battery. Please before hand inform.)

[5] now launch the Installdriver.exe from the unzipped MT6577 USB VCOM drivers folder. Confirm the installation of unsigned drivers

[6] now! (W7 x 64 this confirmation comes later in the manual installation!) After the installation is complete, you have no entry in the Device Manager, it is correctly!

[7] PC reboot!

[8] Open Device Manager and open the switched-off Smartphone via USB to the PC release, now connect (same USB port!)

[9] Now a MediaTek PreLoader USB VCOM should appear for a brief moment in the Device Manager entry!

[10] At the moment the entry double click and click on "Update driver" under the tab "Driver".

[11] With the wizard in the unzipped MTK 6577 USB VCOM drivers navigate and select the folder for your operating system.

there is no drivers for win 8 please help!!!!!!!!!!!!11:r olleyes:

---------- Post added at 05:18 AM ---------- Previous post was at 05:16 AM ----------

Originally Posted by ChinchilaO

The problem is that the link for Drivers for Windows 8 isnt the driver
Just look the links:

Download MT6577 USB VCOM Driver (W7/Vista/XP) ->

Download MT6577 USB VCOM Driver (W8) ->
8 mg???

this thread is dead!!! i need drivers for win 8 help me please or u r just like me waiting for the rain in desert???????:rolley es:
23rd October 2013, 03:33 PM |#37  
zEr!'s Avatar
Flag ahmedabad
Thanks Meter: 28
Exclamation Hope you can help
Originally Posted by mitchell_lra

Note for the step [4]:

If you can NOT find MT65xx Preloader under Other Devices in the Device Manager go to:
View -> Check Show hidden devices

---------- Post added at 01:35 PM ---------- Previous post was at 01:17 PM ----------

I followed this tutorial and I had the same issue, so I first installed the Windows 7 driver and after that I updated driver to the Windows 8.

I'm using Win8 (x64)

Good luck!

i tried installing win 7 drivers but im not getting mtk preloader option when i connect my switch off phone without battery or with battery help!!!!!!!!!!
The Following 2 Users Say Thank You to zEr! For This Useful Post: [ View ] Gift zEr! Ad-Free
12th November 2013, 11:47 PM |#38  
Rocco61's Avatar
Thanks Meter: 5
Hello!! I'm trying to install on My Asus memopad hd 7 a custom recovery but the PC never find MTK peloader device so when I start flash tool and try to flash it the tool stuck on sercing... I use win 7 home premium 64bit.. Any idea for that? I try 50 time to install again the driver but same results every time..
1st December 2013, 01:43 PM |#39  
Senior Member
Flag Mumbai
Thanks Meter: 7
Not able to install Micromax A90s drivers
I have tried this procedure but I am not able to install it. Instead of MediaTek 6577 driver, Mobistel PreLoader USB vcom gets installed. What is the matter? I want to udpate my Micromax A90s to jelly bean.
11th December 2013, 11:15 AM |#40  
Junior Member
Thanks Meter: 2
don't re-post ALL THE GUIDE just to make a question
Originally Posted by zEr!

there is no drivers for win 8 please help!!!!!!!!!!!!11:r olleyes:
---------- Post added at 05:18 AM ---------- Previous post was at 05:16 AM ----------

this thread is dead!!! i need drivers for win 8 help me please or u r just like me waiting for the rain in desert???????:rolley es:

and you cited ALL THE GUIDE just to say you don't find the driver?!!? could you, please, delete the unnecesary and long texts with no relevance to your question?
The Following User Says Thank You to culae For This Useful Post: [ View ] Gift culae Ad-Free
11th December 2013, 02:34 PM |#41  
Junior Member
Thanks Meter: 2
error message with the SP flashtool
I tried to follow the guide step by step. I had some problems. as at step 9 I didn't have a "Media Tek Preloader..." but a something generic (like "unknown device..."). going on I didn't get a succesful instalation of the driver.
but continuing with the SP flashtool succeded nothing and after unpluging and repluging the Goophone i5S from the computer (still in off-mode) I get this message from flashtool (see attacment):

what the problem could be, guys?
Attached Thumbnails
Click image for larger version

Name:	error.PNG
Views:	1361
Size:	48.2 KB
ID:	2448095  
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes