FORUMS
Remove All Ads from XDA

[WARINING] DO NOT install a recovery from 4.1 on a 4.2 tablet!

1,505 posts
Thanks Meter: 1,356
 
Post Reply Email Thread
Guys, I think this post is needed and probably should be sticked on all TF300T forums. I saw a lot of people bricked their tablets for good on Q&A because they didn't read all the info or were just careless. So, if you are on 4.2.1 firmware version, or thinking about upgrading, read this info carefully!

If your tablet has 4.2.1 Android version from Asus, DO NOT FLASH A RECOVERY THAT WAS ACTUALLY MADE FOR 4.1 TABLETS! You will end up on a PERMANENT BRICK with no solution until now. You won't be able to use fastboot ever again. You won't be able to flash anything ever again. You will be stuck with a bricked tablet!

Older ROMs won't work with the new bootloader, such as CM10.1 and ParanoidAndroid ! READ THE ROM THREAD AND ENSURE IT SAYS IT WORKS ON A 4.2 BOOTLOADER! If you are unsure, then READ THE THREAD ANSWERS, ASK AND SEARCH! Five minutes of search can save you from ruin your tablet.

OLDER KERNELS WON'T WORK ON THE NEW BOOTLOADER!! Don't even try to flash TF700T ones!!





If you are looking for a Recovery for a 4.2.1 bootloader (and a complete guide for updating), read this thread: http://forum.xda-developers.com/show....php?t=2187982 Don't do it with any other tutorial: they are for 4.1 bootloaders!

STAY AWAY FROM CWM FOR NOW!

If you don't want to download TWRP from the post above and want to do it from the official TWRP website ensure that you use the correct version for your bootloader! Any other one will brick your tablet! Read the list below:[LIST][*]If you are on Ice Cream Sandwich (Android 4.0.3): download openrecovery-twrp-2.#.#.#-tf300t(g)-ICS.blob[*]If you are on Jelly Bean (Android 4.1.1): download openrecovery-twrp-2.#.#.#-tf300t(g)-JB.blob[*]If you are on Jelly Bean (Android 4.2.1): download openrecovery-twrp-2.#.#.#-tf300t(g)-4.2.blob




Here you have a list of ROMs that are compatible with the new bootloader and are safe to flash once you are on 4.2.1 firmware:


I hope I was clear enough :P
The Following 22 Users Say Thank You to joelalmeidaptg For This Useful Post: [ View ] Gift joelalmeidaptg Ad-Free
 
 
25th March 2013, 06:29 PM |#2  
LucentW's Avatar
Junior Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by joelalmeidaptg

There is NO CONFIRMED WAY FOR DOWNGRADING, so if you want to upgrade to 4.2.1, keep in mind that you may never be able to return to 4.1 bootloader.

Just tried downloading the oldest update image from ASUS' official website and flashing it manually via fastboot, I managed to downgrade to 4.1.1 and flash recovery-jb.img without any mounting/bootloop issue whatsoever.

You just need to unpack the official zip, get the blob and flash it inside the "staging" partition. The tablet will repartition the whole NAND and reinstall 4.1.1. (obviously after flashing you need to wipe /data to prevent bootloops -- /emmc will be formatted while flashing)
The Following 2 Users Say Thank You to LucentW For This Useful Post: [ View ] Gift LucentW Ad-Free
25th March 2013, 06:47 PM |#3  
joelalmeidaptg's Avatar
OP Senior Member
Thanks Meter: 1,356
 
Donate to Me
More
Re: [WARINING] DO NOT install a recovery from 4.1 on a 4.2 tablet!
Quote:
Originally Posted by LucentW

Just tried downloading the oldest update image from ASUS' official website and flashing it manually via fastboot, I managed to downgrade to 4.1.1 and flash recovery-jb.img without any mounting/bootloop issue whatsoever.

You just need to unpack the official zip, get the blob and flash it inside the "staging" partition. The tablet will repartition the whole NAND and reinstall 4.1.1. (obviously after flashing you need to wipe /data to prevent bootloops -- /emmc will be formatted while flashing)

Well, didn't know that I'm removing that part from the post

Sent from my ASUS Transformer Pad TF300T using CROMI
The Following User Says Thank You to joelalmeidaptg For This Useful Post: [ View ] Gift joelalmeidaptg Ad-Free
25th March 2013, 08:21 PM |#4  
Senior Member
Flag PARIS
Thanks Meter: 13
 
More
Hi all

Just a fact : I managed to install the CWMrecovery over the Official Asus update 4.2.1. I'm not sure, but I think the issue is with TWRP. My 64 Go ext.SD became unstable (had to reformat it via Gparted) and the whole system too...
Now I'm back on a "classical" recovery, no root, no unlock, official 4.2.1 Asus and everything is smooth so far...i'll let you know.
Narrow escape, I must say...

Joel, you're the man : you're right to prevent everyone from a catastrophy. Thanks.

Okdac
25th March 2013, 11:35 PM |#5  
sbdags's Avatar
Recognized Contributor
Flag Kenilworth, Coventry
Thanks Meter: 15,732
 
Donate to Me
More
Wow.....So many people bricking their TF300s. Q&A section is like walking into A&E.....

People need to stop, read and flash after reading again....

It's a real shame. I wish we could help. There are so many threads in there where the answer is sorry, you are bricked because you didn't do your research.....
26th March 2013, 12:00 AM |#6  
joelalmeidaptg's Avatar
OP Senior Member
Thanks Meter: 1,356
 
Donate to Me
More
Quote:
Originally Posted by sbdags

Wow.....So many people bricking their TF300s. Q&A section is like walking into A&E.....

People need to stop, read and flash after reading again....

It's a real shame. I wish we could help. There are so many threads in there where the answer is sorry, you are bricked because you didn't do your research.....

Yeah, Q&A is like a "brick sanctuary"... Poor creatures lol
26th March 2013, 01:38 AM |#7  
kaos420's Avatar
Recognized Contributor
dantes inferno
Thanks Meter: 2,092
 
Donate to Me
More
Re: [WARINING] DO NOT install a recovery from 4.1 on a 4.2 tablet!
part of the reason i haven't done mine. until we get a o.c kernel its not worth it i have o.c on cm10.1 with 4.2.2 . not worth the plunge until then . once we get source and sd does his magic. ill do it. but i feel like ive read the thread so much i see it in my sleep.lol

Sent From My Unlocked & Rooted 4.2.2 Android Powered []D [] []V[] []D TF300T
26th March 2013, 09:06 AM |#8  
wetbiker7's Avatar
Senior Member
Thanks Meter: 1,694
 
More
Re: [WARINING] DO NOT install a recovery from 4.1 on a 4.2 tablet!
I'm glad you made this thread Joel. Hopefully people will take the time to actually read because It will definitely help them out.

I've decided to revert back to CROMI 3.3 for now. Everything works for me plus I still have the option to change ROMs and overclock the kernel.

Hopefully an OC Kernel will be released soon.

Sent from my LG-LG855 using Xparent SkyBlue Tapatalk 2
26th March 2013, 06:33 PM |#9  
Langduscher's Avatar
Senior Member
Flag Texel
Thanks Meter: 337
 
More
Just to make sure: this file contains the patched TWRP for 4.2.1

Good post!
27th March 2013, 12:01 AM |#10  
joelalmeidaptg's Avatar
OP Senior Member
Thanks Meter: 1,356
 
Donate to Me
More
Re: [WARINING] DO NOT install a recovery from 4.1 on a 4.2 tablet!
Just bumping up this post


Sent from my ASUS Transformer Pad TF300T using CROMI
27th March 2013, 01:38 AM |#11  
treo4life's Avatar
Senior Member
Flag Atlanta, Ga.
Thanks Meter: 100
 
More
Quote:
Originally Posted by joelalmeidaptg

Just bumping up this post


Sent from my ASUS Transformer Pad TF300T using CROMI

Hopefully people will read this!
Post Reply Subscribe to Thread

Tags
4.2.1, bootloader, brick, tf300t, warning

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes