FORUMS
Remove All Ads from XDA

SD Card is Damaged. Try Reformatting it.

14 posts
Thanks Meter: 0
 
By mattskr, Junior Member on 14th May 2013, 11:48 PM
Post Reply Email Thread
Anyone else getting this with their S4? I bought my S4 two weeks ago and a Sandisk 64gb card to go with it and started seeing this error about twice a day. I returned it for a Samsung SD and didn't see the error for almost a week until today.

The card actually appears to be fine, all I have to do is remount it after seeing the message and all is good, it's just worrisome cause I store all my photos on there. I'm wondering if it could be the phone itself? I have one day left to exchange it, but it's rooted.
 
 
14th May 2013, 11:57 PM |#2  
Senior Member
Thanks Meter: 131
 
More
SD Errors are because the card is physically moving when its being written to. This cause bad sectors on the card. Try putting a piece of thin scotch tape and cut to shape of the face of the SD Card. See if it fits more snug....

Are you jogging with the S4 or something? Samsung SD's are class 10 which I think write faster. Maybe that is less likely to cause damage because its written so fast? Not sure....

Try the tape trick and see if it reduces the problem. Else its a physical problem with the slot.
15th May 2013, 12:40 AM |#3  
Senior Member
Flag Montreal
Thanks Meter: 491
 
Donate to Me
More
i also have a class 10 64gb, some guy on the forum posted this problem too, he said that by formating the card with a PC and then formating it with the format utility in the phone settings has solved his problem. If not, might be a slot problem like slider mentionned
The Following User Says Thank You to polish_pat For This Useful Post: [ View ] Gift polish_pat Ad-Free
15th May 2013, 01:34 AM |#4  
JChespirito24's Avatar
Member
Thanks Meter: 7
 
More
I had this problem too with my 32 gig class 10. When I put my shock absorbant case on it my problem went away

Sent from my SAMSUNG-SGH-I337
15th May 2013, 01:42 AM |#5  
ricktat's Avatar
Senior Member
Thanks Meter: 61
 
More
I had never had an issue with a Sandisk card until my S3 ate a 32GB. I then started readibg how the S3 ate non- Samsung cards. I have been using a Samsung card with no issues
GuestX0019
15th May 2013, 02:17 AM |#6  
Guest
Thanks Meter: 0
 
More
hope you make regular sdcard backups and copy to pc

polish_pat is correct, reformat your card with sdformatter, use Full Erase On and Size Adjustment On

Of course backup first

you shouldn't have to reformat again in phone--

if the card is good this should solve your issue
15th May 2013, 10:09 AM |#7  
Rastabolino's Avatar
Senior Member
Flag Monterey Ca
Thanks Meter: 490
 
More
I had tried 3 different San disk 64GBP class 10 cards and had this problem, the fourth one works so far...doing some searching I found lots of complaints from lots of different device forums about this card. Only fix I found was running chkdsk repair on the card in Windows but this only worked for a few people ( couldn't save my first three cards)
anyway, imo exchange the card or better yet buy a different brand

Sent from my SAMSUNG-SGH-I337 using xda premium
31st May 2013, 05:04 AM |#8  
Junior Member
Thanks Meter: 0
 
More
Posting here as doing a search revealed this is the closest to the problem that I'm having. I've had my AT&T Samsung Galaxy S4 for approximately 1 month now. I purchased a Sandisk 32GB SD Card for the phone. Two days ago I began experiencing issues where when unlocking the phone I would notice the card would unmount then remount (this was in the notification bar). Later that night, the card unmounted and there wasn't any way to get it recognized again. I posted in some other forums and someone said there were some good posts here.

I've contacted Sandisk regarding the card and they refused any involvement stating it's a problem with the phone, not the card. They determined this because once I was able to get the phone to recognize the card and plugged the phone into the PC, the card was able to be read. As long as it's readable, it's fine. After dealing with this I eventually found my MicroSD to SD reader and plugged it into my media reader in my printer. I had quite a few issues from time to time reading the card, however I can't 100% for sure say whether this is the card or the printer.

Anywho, I grabbed copies of what I needed. Formatted the card on the PC, then formatted it on the phone. I began to copy my entries however at one point instead of saying I had 29.* GB Available, it said something like 2.0 EV of 3.0 PE or something like that... these weren't the typical numbers I've seen nor the units of storage space. I apologize that I can't recall that information. I reformatted again and it worked. Left the card in the phone empty over night then tried to copy files later today. This worked.

Now, approximately 48 hours after the problems began, I noticed more issues. SD card stated that it had been damaged and that I should reformat it. While this message stayed in notifications, I confirmed I was still able to read files on the SD card. When googling that error hoping I'd find more resources, the card again unmounted.

One of the resources I found had me do a CHKDSK /F /X on the card. I did this and found no issues. I've replaced it back into the phone and it seems to be working for the moment.

1) Are there any confirmations if this is a bad card, or if perhaps any applications are causing the card to do this? I do have QuickPic and have enabled some of the hidden file features if that helps.
2) Do we know if there are any logs that can be pulled to help verify this?
3) Is it a specific card? (I've heard SanDisk 32gb, but also have heard non-Samsung SD will fail)

Looking to get this resolved ASAP. This card was purchased directly from AT&T when the phone was purchased. I am just looking for some confirmation that if I have to buy another card, I'm not going to gamble if that's going to have the problem as well.

Thanks! If I forgot anything please ask!

Edit: Per the thread, this is a Class 4 card. Also the phone was not moving when it was writing data. I've been couch-ridden all day and unlocked it. I don't believe the phone was in deep-sleep mode as I had received a text not long before I began noticing these messages.
16th August 2013, 12:47 AM |#9  
Member
Flag Amman
Thanks Meter: 1
 
More
same problem
i have the same problem and guess what ?
the phone is acting like the bitch it stays ok for 3 weeks while that time i download to many stuff to my ext card 32g Elixir Memory after that it crach and give me notification that sd card is damaged and i have to reformat it sucks
by the ****in way this's the fifth time it crash i changed the memory to sony and same and changed to Kodak and the same
so abso****inlotley its the S3 for me soon its going to trash
17th August 2013, 05:51 PM |#10  
BookerSalts's Avatar
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by polish_pat

i also have a class 10 64gb, some guy on the forum posted this problem too, he said that by formating the card with a PC and then formating it with the format utility in the phone settings has solved his problem. If not, might be a slot problem like slider mentionned

This works! It fixed the issue I was having with my SanDisk 64GB.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes