Remove All Ads from XDA

Fix and prevent ROM upgrade/downgrade Country ID errors

423 posts
Thanks Meter: 6
By dcs, Senior Member on 23rd September 2004, 12:11 AM
Thread Deleted Email Thread
3rd January 2005, 09:24 PM |#101  
LaserProUSA's Avatar
Junior Member
Las Vegas, NV
Thanks Meter: 0
DevideData.txt only shows "U" any ideas?
Attempting to follow your dirctions in "Fix and prevent ROM upgrade/downgrade Country ID errors" but can't even get passed the first step. My DeviceData.txt only shows "U"

Have ran it half dozen times and nothing shows up. My unit is a TMobile MDA II and running Sin's SE update. His carriers are for Australia only so I need to ensure all is switched to TMobile US. Already did the upgrade and tried to use the OperatorUpdate but when attempting to reflash get the country code error. Hence on to your directions on the fix and hit that "U" only issue.

My system info is:

Unit: MDA II
Windows Mobile 2003 Second Edition
ROM version: 2.06.00WWE
ROM date: 06/14/04
Radio version: 1.18.00
Protocol version: 1337.38
ExtROM version: blank
3rd January 2005, 10:33 PM |#102  
Senior Member
Thanks Meter: 7
move devicedata.txt to pc before opening it
5th January 2005, 01:12 AM |#103  
Junior Member
Thanks Meter: 0
Re: Fix and prevent ROM upgrade/downgrade Country ID errors
Originally Posted by dcs

IMPORTANT: Updated 28th September - I now know that if you have bootloader v1.06 on your XDA II, you cannot downgrade your ROM (at the moment). We will see if we can find a way round this but cannot promise anything. My thanks to gerald8297 for his patience and help using his device and thus enabling me and him to determine this.

I maybe found a way around the 1.06 bootloader problem. I have a Qtek 2020 wich i have upgraded to 2.20 (chiness translation of WM2003SE) and for some reason i want the original rom to replace it. It's a 1.75 (WM2003)

In the first place i try to simply update it. It fails with a contry error. So i tried to put the thing in bootloader (Holding down the navigator-key while doing a hard-reset) and put it back (still in bootloader) in the cradel and run the HimaUpgradUT anf BINGO!!! it works. My point of view is whenever this thing is in bootloader the upgrade utility have no access to the software version on the thing. You should se this figured out by the missing values of the old software at the top ofg thw update windoow while the thing is in bootloader. Haven't no vclue of trhe old software, the upgrade utility just upgrades the roms as normal without problems.

5th January 2005, 01:14 AM |#104  
Junior Member
Thanks Meter: 0
Just to be specific. It was at English translation of a chiness rrom i have before downgrading.
5th January 2005, 05:29 PM |#105  
Junior Member
Thanks Meter: 0
XDAII with bootloader 1.06 dowgraded !!
First of all, thanks to dcs for the post. I've just to downgrade a XDAII with bootloader 1.06, and I want to explain how it is.

First of all the XDA is featured with a ROM 1.72 ESN and with a bootloader 1.06 as well. My aim was to upgrade it to a 1.59 ESN, nevertheless I think wich version applies doesn't make any difference.

It's enough with making a backup of the current version (ms_.nbf, NK.nbf and Radio_.nbf). By using the commands provided by dcs it's easy to get the .nba files.

The procedure has to be repeated with all files you like to load (that ones from the new version), and ALL headers from the old files to the new files shall be copied (Carrier, Language, Version, model, etc.). Into the file it has to be copied twice.

Then after the files CRC shall be updated, as indicated by dcs, and the new files are encrypted once again, with the .nbf file, and finally the upgrade shall be executed.

Consequently I have succeded in restoring a "dead" XDA.
18th January 2005, 09:35 PM |#106  
Junior Member
Thanks Meter: 0
Cannot run HimaGetDeviceData

I tried to upgrade my device and I followed the instructions. It started the upgrade but then suddenly said "Country Error". Now I am stuck with the USB/Serial boot screen and nothing else. I cannot reset the device and I can't communicate with the device. I cannot put HimaGetDeviceData on the device to get my device data to get the correct country code anymore. Is there any way to get around this?
20th January 2005, 11:08 PM |#107  
Thanks Meter: 0
Could someone post a guide in a *.txt file in order to download?
26th January 2005, 11:15 AM |#108  
Junior Member
Thanks Meter: 0
still unable to get going
i guys i am from india
first of all i would like to congratulate you guys on the great work done by you all..
i bought the Krome F1 Navigator
the devicedata.txt is as follows
U S B   3 2   1 . 7 2 . 0 0 W W E                               P H 1 0               E - C h a r g e                           W W E                 1 . 7 2 . 1 9 5                 1 . 1 7 . 0 0
i have read all the 28 pages and i am still yet to find a solution am foist just trying to update the NK.nbf file i changes the headers to E-Charge and still i get the operator id error
the site that has the details of my phone is
now the problem is like this is downloaded the dcs rom upgrade file and it had radio.nbf and nk.nbf i changed the headers to E-Charge i still get the country code error and now is see a Serial and V 1.06 screen and when i connect it to the usb cradle it becomes USB 1.06 also i wanted to know if i should insert the simcard of my gsm company while upgrading or not and how do i proceed?
thanks in advance
i already had posted this in the genuine win2003 thread buy got jusdt 1 reply i dunno what uis wrong i tried all possible names useing the batch file made by dcs and still this is not working i read somewhetre on this forum that someone has made a country id free rom 2.20wwe if u can tell me how to do it it will be gr8 and thanks ashaqq for help i will call u in some time till then guys please help me my phone is in the boot loader mode.. thanks once again
p.s this is the first time i flashed my rom and had changed all the headers of nk and radio nbf files i had not used the ms.nbf file so the 74/94 offset shouldnt come into the picture and one more thing does the simcard being inside the phone or should i remove it while flashing?
12th February 2005, 03:13 PM |#109  
Junior Member
Thanks Meter: 0
GetDeviceData doesn't work
It seems that I can't get the GetDeviceData.exe to work on my Phone.
The DeviceData.txt only contains the letter U, nothing more.
Can somebody help me? Thanks in advance.
14th February 2005, 06:33 PM |#110  
Senior Member
Thanks Meter: 4
copy that file to your pc and open it there with note pad. you will see the detail. Good luck.

15th February 2005, 04:55 PM |#111  
Junior Member
Thanks Meter: 0
Cannot find file!
Am so close, yet am stuck on step 9 because I cannot locate the file. Have been searching for about an hour now. Could anyone please point me in the right direction? Thanks
Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes