Remove All Ads from XDA

[GUIDE] How to enable LTE on the Mobilicity / Wind / Vidéotron T889V

1,022 posts
Thanks Meter: 504
By Darkshado, Senior Member on 2nd June 2013, 11:46 PM
Post Reply Email Thread
Hello everyone,

If you're using an SGH-T889V (originally from Vidéotron, Wind or Mobilicity) on a carrier that runs LTE on the AWS band, e.g.: Rogers, Bell, Telus, Fido, Virgin Mobile Canada, Koodo, AT&T or T-Mobile; this will allow you to enable LTE.

Note: Vidéotron has launched their LTE network in September 2014. As of writing this, it is unclear whether there will be a new T889V modem released with LTE enabled in the coming weeks, much like there was with T-Mobile USA when they launched their LTE network.

If you're using a T-Mobile USA SGH-T889, this guide isn't for you.

The usual disclaimers apply.

Actually, let me rephrase that: This mod permanently damages your phone, and irrevocably voids your warranty.

No one has been able to flash back to a T889V modem (be it ALJ4, BMA3, CMK4 or DNE7) without encountering bootloops afterwards.
Interestingly, T889VVLUDNH2 did not bootloop, it simply showed an "unknown" IMEI and baseband with no network connection.

Some background:
Additional relevant threads:
You'll need:
  • LTE - Coverage, known working microSIM, proper plan and system provisioning, etc...
  • Proper APN settings for your carriers on hand. (Better yet if you're running TouchWiz ROMs: proper CSC files and knowledge on how to modify and apply those.)
  • ADB
  • Clockworkmod/TWRP recovery
  • CWM/TWRP flashable I317M modem image. (I originally used the BMA3 modem, although the mod should work with any of them.)

Bell/Rogers/Telus I317M modem files
Mobilicity/Vidéotron/Wind T889V modem files.
Once you've downloaded the above files:
  • Backup your NV settings (in CDMA Workshop text format) as per this thread. You can also use the EFS Professional Tool (currently at version 2.1.61) almost identically to the older NV_reader_writer tool. (It also contains the IMEI NV item generator functions that Peoplearmy's tool had, apparently gone missing too.)
    The only things I'll add are that:
    • RMNET + DM + MODEM is not available, you'll have to use RNDIS + DM + MODEM instead.
    • Finding the COM port can be done in device manager, you may need to refresh devices or disconnect and reconnect the USB port. If it's been properly detected, you can also click the Port text to the left of the droplist, there's an autodetect function there.
  • Also use this guide to backup (in QPST/QXDM .qcn format):
  • Optional: Backup the raw mk9efs partitions too, as per @connexion2005's suggestion: (they're not necessary for the mod itself, and are only made as an additional precaution)
  • Optional: Backup the raw mk9efs and efs partitions with this CWM or TWRP "flashable" zip based on the Synergyrom team's work. It outputs the dumps in a ready-to-flash restore zip.
  • Consider backing up other files and data from your phone with the usual complement of Titanium Backup, nandroid and so on. Copy those off the phone.

If you're running an AT&T or T-Mobile ROM: you may have to flash another ROM as well. The stock T889V ROM has a "Network Mode" setting that lets you toggle between LTE/WCDMA/GSM, WCDMA only and GSM only. The I317M and N7105 ROMs also have this, while the I317 and T889 probably don't.

On the T889V ROMs: to see LTE become an option, you'll need to edit your CSC files and remove the <CscFeature_Setting_DisableNetworkMode>lte</CscFeature_Setting_DisableNetworkMode> line in /system/csc/others.xml. This setting is only cosmetic: the notification bar icon will show "4G" and you won't see LTE in the network mode settings. However, the phone will still use LTE, which can be confirmed by looking in Settings / About Phone / Status. (I've come across this while flashing ROMs with unaltered CSC files.)

Let's proceed with the actual modification:
  1. Reboot to recovery, flash the 317M BMA3 modem. Wipe /cache and Dalvik cache for good measure.
  2. Reboot phone. No bootloops? Good.
  3. Check in Settings / About Phone that you still have a valid IMEI. (It's possible you still do at this point.)
  4. Reboot the phone. This time the IMEI and service should be lost.
  5. Using the same procedure you did to back them up, restore your NV items.
  6. Reboot the phone.
  7. Confirm your IMEI is correct and that you have service.

Check in Settings: Wireless and networks -> More settings -> Mobile Networks -> Network Mode that LTE/WCDMA/GSM is selected. Another menu worth mentioning here is the "Band Selection" menu accessed through the *#2263# dialer code. Note that if you force the phone onto the LTE bands, you will only have data service, and no voice calls or SMS.

I'd like to thank the following users for their help and feedback in writing this guide: @Byangmang, @deeznutz1977, @dspkeff, @hkfan, @rail205, @TEKHD

Good luck,

The Following 5 Users Say Thank You to Darkshado For This Useful Post: [ View ] Gift Darkshado Ad-Free
3rd June 2013, 02:10 AM |#2  
Senior Member
Thanks Meter: 83
Thank you so much. I have been waiting for this day to come. All the best, Darkshado! :beer:

Sent from my SGH-T889 using xda app-developers app
5th June 2013, 10:55 PM |#3  
jfive74's Avatar
Senior Member
Thanks Meter: 26
Works. Thanks allot. Only thing I didn't do is restore the 3 files backed up via adb.
6th June 2013, 08:01 AM |#4  
Darkshado's Avatar
OP Senior Member
Thanks Meter: 504
Donate to Me
Originally Posted by jfive74

Works. Thanks allot. Only thing I didn't do is restore the 3 files backed up via adb.

Those are very much a belt and suspenders bit. They're not to be restored in the instructions, and my inclusion here is mostly because connexion2005 had requested a set for a JTAG repair. I'm taking a guess here, but if there's any calibration data or other phone specific parameters in there, having those from your device on hand can't be bad.
30th June 2013, 04:13 AM |#5  
Thanks Meter: 4
What if I suffer boot loops, didn't do any backups, and my IMEI is already Zeroed out on my T889V? How can I fix this?
I have my IMEI still since it's written on the purchase box of the phone.
I used to be wind, now virgin mobile with LTE sim. I flashed tmobile modem. No love. Flashed T889V modem back, then got boot loops.

Please help!!!

Hi Darkshado, really hoping you can help.
I've done more reading. I can't seem to make the boot loops stop.
I've done odin to factory rom image. No luck.
I tried i317 custom modem you have here on XDA, no luck. Also Tmobile modem, etc... no luck.
I used CWM and permission fix, etc.. no luck.
My boot loop is a little weird. It will boot and stay live (working - no signal though) for about a min, then it will say some is not responding and reboot.
So I can't get NV to inject my IMEI as it will reboot too soon. From what I read, NV needs 5-10 min??

basically, I did JEDIX-15 tmobile rom install with latest tmobile modem. That's how I got into this mess. I have a T889V and virgin LTE sim such as yourself.
I just can't seem to make the boot loops end so I can move forward....
30th June 2013, 05:13 AM |#6  
Darkshado's Avatar
OP Senior Member
Thanks Meter: 504
Donate to Me
Try writing flashing back the T889 baseband and restoring a T889 or T889V NV items backup.
30th June 2013, 01:40 PM |#7  
Thanks Meter: 4
Will this do?
I'm going to try and odin the factory image and see if that stops the reboots.
I'm guessing baseband is the same as modem correct?
I'll go give it a try now and use CWM to inject it first before I odin.
I've never done an NV restore let alone backup, so that seems to be my hick up. I'll do some research and get that done then and get back to you.
Thanks for the assistance.

I'll try to write NV, but that might be an issue since I need the phone not to reboot, and it does in under a minute usually.
Any suggestions, or specific rom I can try to write so I can eliminate the reboots so I can do the nv?

ok, the tmo modem from that link above worked. It's not boot looping after a min now!
There is still zero signal. Does not connect. When I do *#2263# and choose automatic, it says menu does not exist, etc...
going to to try inject my IMEI with NV.
Will report back.

Edit 3
Ok, just used nv read/write to inject your t889v nv file. Then generated my imei and injected that.
reboot, and got signal! yay.
thank you so much!\
When I go to settings. I only see WCDMA/GSM/AUTO. No LTE option. I think I read somewhere that is cosmetic?
If I NV write the T889 NV file from deeznutz1977 will that fix it cosmetically?

Thanks again!

Originally Posted by Darkshado

Try writing flashing back the T889 baseband and restoring a T889 or T889V NV items backup.

1st July 2013, 02:20 AM |#8  
_Kippo_'s Avatar
Junior Member
Flag Chalk River
Thanks Meter: 3
Thumbs up 20% More Awsomeness
I switched over to Telus sine Mobilicity is going under . I could only get HSPA+ @ 5Mbps, Now I too have fully working LTE. Albeit with weaker signal strenth due to higher band freqency. But I can just toogle LTE when needed. I must admit that second reboot with IMIE 0 and no service was a bit nerve racking, but the backup was flawless. Thanks a million OP. ^_^
1st July 2013, 03:49 AM |#9  
Thanks Meter: 4
i edited the csc called other....
and the LTE line was already not present.
The LTE option is still not in the mobile settings however.
When I do the *#2263# menu and set it to LTE the data does keep working. And I do see it in the system info. Also using a tmobile radio with the JEDI-X15 rom. yay.
But I'd like to solve the cosmetics side of it.
I did inject the t889V nv setting.... could that affect it? Would the t889 NV settings fix it?

still no luck getting LTE option to appear, although it works, I'd like to solve the cosmetic side of it.
Any help?
The Following User Says Thank You to sidmuer For This Useful Post: [ View ] Gift sidmuer Ad-Free
1st July 2013, 08:17 AM |#10  
Darkshado's Avatar
OP Senior Member
Thanks Meter: 504
Donate to Me
You can also get confirmation that LTE is active by checking in About phone / Status.

I don't feel like going through the 664 pages of the Jedi X ROM thread to see if they've altered the network icons or not. Being based on the N7105 ROMs icons with either "4G" or "LTE" captions should be present. Are you editing the active CSC files? Namely those in /system/csc/ ?

I should mention that some CSC edits only apply upon factory reset, e.g. activating WB-AMR, (a.k.a. HD Voice). One neat trick is to make a backup in recovery (nandroid or TWRP), factory reset, then reboot to recovery and restore the backup. I don't recall if this applies to the network icon related lines or not.
1st July 2013, 07:43 PM |#11  
_Kippo_'s Avatar
Junior Member
Flag Chalk River
Thanks Meter: 3
Question Older Modems

As I stated before it was a smooth transition. But... Some claim the older modem worked better (I317M-I317MVLALJ2). I tried through TWRP as before but the return status says FAILED. No changers are thus made. Any ideas? Thanks.
Post Reply Subscribe to Thread

lte, t889v

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes