FORUMS

[Q] /storage/emulated/0 missing

137 posts
Thanks Meter: 24
 
By tabooki, Senior Member on 11th June 2013, 07:29 PM
Post Reply Email Thread
After upgrading to trickdroids 4.2.2. based release I have some problems. Only with Grooveshark so far. It crashes every time I run it.
Here is a pastbin for it.
http://pastebin.com/VEHkWvZQ

I understand that
/storage/emulated/0/: to my knowledge, this refers to the "emulated MMC" ("owner part"). Usually this is the internal one. The "0" stands for the user here, "0" is the first user aka device-owner. If you create additional users, this number will increment for each.

/storage/emulated/legacy/ as before, but pointing to the part of the currently working user (for the owner, this would be a symlink to /storage/emulated/0/). So this path should bring every user to his "part".

My app that is crashing since upgrading to 7.? is Grooveshark it requires storage in
/storage/emulated/0/Android/data/com.grooveshark.android.v1/files/cache/player


I have no
/storage/emulated/0
I do have
/storage/emulated/legacy/

How would I make the link to this.
I have tried this but it fails

ln -s /storage/emulated/legacy /storage/emulated/0

link failed Read-only file system


Can somebody help with the commands needed to make this link that is required.
22nd December 2013, 06:15 PM |#2  
Junior Member
Thanks Meter: 0
 
More
I've got the same problem. Have u solved it? if yes, how?
3rd February 2014, 06:42 AM |#3  
BadProf's Avatar
Junior Member
Flag Christchurch
Thanks Meter: 3
 
More
I've struck similar problem after accidentally deleting internal storage. I had no /sdcard in storage.

Apparently you need to run ;

mount -w -o remount rootfs /

Then ;

ln -s /data/media/0 /sdcard

You can check with ;

ls -l -a /sdcard

I have /sdcard0 now in /storage which appears to be the correct description. I use X-plore file manager and it can now see the internal storage correctly.

However CM File Manager (CM11) indicates internal storage should be at /storage/emulated/0 where as mine is /storage/emulated/legacy. Of course I can create a bookmark in CM File Manager to the folder and can see the storage.

All my apps and phone appear to function normally but i can't help wondering if the structure I have in /root for my internal storage is not quite correct. If anyone can tell me the folder and symlinks I should have it would be of great use.

I've tried recreating symlinks with succes so that CM File Manager can see the internal storage at /storage/emulated/0 but the moment I reboot the phone it's back the to the way it was. Have yet to find a simple explanation for what controls the folder structure in /root and why I can't get the symlinks I create to stick.

Update 5Feb - Did another factory reset and flashed CM11 M2. Everything OK now. Maybe needed a couple of resets to sort the ghosts in the machine.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes